aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-11-19 17:09:07 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-11-19 17:45:04 +0000
commit855b2e50340ebc30d6daec438d7368e3fc91f7cb (patch)
treeefe5ea4deeeee8217095bbf311d5de51a0fba2bb
parent3504ad16ed131b7bd9d0b82417f689eb9dfa11ab (diff)
downloadports-855b2e50340ebc30d6daec438d7368e3fc91f7cb.tar.gz
ports-855b2e50340ebc30d6daec438d7368e3fc91f7cb.zip
x11-wm/phoc: move bundled wlroots to -phosh flavor
Partially revert 4ea852fab0aa after 79c3c0814886. Other consumers may not need Phosh-specific changes from PureOS, and system wlroots helps debugging bundled version.
-rw-r--r--x11-wm/phoc/Makefile13
-rw-r--r--x11-wm/phoc/files/extra-patch-private-wlroots (renamed from x11-wm/phoc/files/patch-private-wlroots)0
2 files changed, 13 insertions, 0 deletions
diff --git a/x11-wm/phoc/Makefile b/x11-wm/phoc/Makefile
index 05ca77d8ee49..083dbae31388 100644
--- a/x11-wm/phoc/Makefile
+++ b/x11-wm/phoc/Makefile
@@ -19,6 +19,8 @@ LIB_DEPENDS= libwayland-server.so:graphics/wayland \
libxkbcommon.so:x11/libxkbcommon
RUN_DEPENDS= ${LOCALBASE}/share/glib-2.0/schemas/org.gnome.mutter.gschema.xml:x11-wm/mutter
+FLAVORS= default phosh
+
USES= compiler:c11 gl gnome meson pkgconfig python:build shebangfix xorg
USE_GITLAB= yes
USE_GL= glesv2
@@ -32,5 +34,16 @@ CFLAGS+= -Wno-error=format-nonliteral # clang
PLIST_FILES= bin/${PORTNAME}
GLIB_SCHEMAS= sm.puri.phoc.gschema.xml
+.if ${FLAVOR:U} == phosh
+PKGNAMESUFFIX= -${FLAVOR}
+COMMENT+= (with patched wlroots from PureOS)
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-private-wlroots
+CONFLICTS_INSTALL= ${PORTNAME}
.include "${.CURDIR}/Makefile.wlroots"
+.else
+COMMENT+= (with system wlroots)
+CONFLICTS_INSTALL= ${PORTNAME}-phosh
+.include "${.CURDIR:H:H}/x11-toolkits/wlroots015/override.mk"
+.endif
+
.include <bsd.port.mk>
diff --git a/x11-wm/phoc/files/patch-private-wlroots b/x11-wm/phoc/files/extra-patch-private-wlroots
index db9282d88597..db9282d88597 100644
--- a/x11-wm/phoc/files/patch-private-wlroots
+++ b/x11-wm/phoc/files/extra-patch-private-wlroots