aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2023-02-22 13:14:46 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2023-02-22 13:14:46 +0000
commit857fbed61523d9c45b3ab79f3ddb8eed5f2898a4 (patch)
treeb40c4ecc07d57e104b3d2557ef32e79e15e329e9
parent5757df366a8a7f6a4c17e2cbdfeba36a3340530f (diff)
downloadports-857fbed61523d9c45b3ab79f3ddb8eed5f2898a4.tar.gz
ports-857fbed61523d9c45b3ab79f3ddb8eed5f2898a4.zip
devel/libphdi: new port
Library and tools to access the Parallels Hard Disk image format WWW: https://github.com/libyal/libphdi
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libphdi/Makefile29
-rw-r--r--devel/libphdi/distinfo3
-rw-r--r--devel/libphdi/pkg-descr1
-rw-r--r--devel/libphdi/pkg-plist18
5 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0d2a998c2fb7..193199edd634 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1330,6 +1330,7 @@
SUBDIR += libpeak
SUBDIR += libpeas
SUBDIR += libpff
+ SUBDIR += libphdi
SUBDIR += libphk
SUBDIR += libphonenumber
SUBDIR += libplist
diff --git a/devel/libphdi/Makefile b/devel/libphdi/Makefile
new file mode 100644
index 000000000000..0347af88b3e0
--- /dev/null
+++ b/devel/libphdi/Makefile
@@ -0,0 +1,29 @@
+PORTNAME= libphdi
+# If/When moving from experimental to alpha, switch to DISTVERSIONPREFIX to prevent PORTEPOCH
+DISTVERSION= experimental-20221025
+CATEGORIES= devel
+MASTER_SITES= https://github.com/libyal/libphdi/releases/download/${PORTVERSION:E}/ \
+ LOCAL/antoine
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Library and tools to access the Parallels Hard Disk image format
+WWW= https://github.com/libyal/libphdi
+
+LICENSE= LGPL3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-python
+CONFIGURE_ENV= PYTHON_CONFIG=${PYTHON_CMD}-config
+USES= fuse libtool pathfix pkgconfig python
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:E}
+
+OPTIONS_DEFINE= NLS
+
+NLS_USES= gettext
+NLS_CONFIGURE_ON= --with-libintl-prefix=${LOCALBASE}
+NLS_CONFIGURE_OFF= --disable-nls
+
+.include <bsd.port.mk>
diff --git a/devel/libphdi/distinfo b/devel/libphdi/distinfo
new file mode 100644
index 000000000000..fced4407aa89
--- /dev/null
+++ b/devel/libphdi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1676992208
+SHA256 (libphdi-experimental-20221025.tar.gz) = 899fc28652c6a48f1421537df71316b77eef5f64cecd062e14ee30686488311e
+SIZE (libphdi-experimental-20221025.tar.gz) = 1912255
diff --git a/devel/libphdi/pkg-descr b/devel/libphdi/pkg-descr
new file mode 100644
index 000000000000..1c2f13a5cb38
--- /dev/null
+++ b/devel/libphdi/pkg-descr
@@ -0,0 +1 @@
+Library and tools to access the Parallels Hard Disk image (PHDI) format.
diff --git a/devel/libphdi/pkg-plist b/devel/libphdi/pkg-plist
new file mode 100644
index 000000000000..4b69ea59b456
--- /dev/null
+++ b/devel/libphdi/pkg-plist
@@ -0,0 +1,18 @@
+bin/phdiinfo
+bin/phdimount
+include/libphdi.h
+include/libphdi/codepage.h
+include/libphdi/definitions.h
+include/libphdi/error.h
+include/libphdi/extern.h
+include/libphdi/features.h
+include/libphdi/types.h
+lib/libphdi.a
+lib/libphdi.so
+lib/libphdi.so.1
+lib/libphdi.so.1.0.0
+%%PYTHON_SITELIBDIR%%/pyphdi.a
+%%PYTHON_SITELIBDIR%%/pyphdi.so
+libdata/pkgconfig/libphdi.pc
+man/man1/phdiinfo.1.gz
+man/man3/libphdi.3.gz