aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-04-21 21:36:33 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-04-22 01:00:02 +0000
commit85a65c9557ca41cc459b7488eb161e6a91335e68 (patch)
tree807721301cd822c66cc019dd6af79fd1e4d1a9c2
parent6b5a1043fe8d34c223a0121a6ff16852f266851e (diff)
downloadports-85a65c9557ca41cc459b7488eb161e6a91335e68.tar.gz
ports-85a65c9557ca41cc459b7488eb161e6a91335e68.zip
emulators/yuzu: update to s20210421
-rw-r--r--emulators/yuzu/Makefile4
-rw-r--r--emulators/yuzu/distinfo6
-rw-r--r--emulators/yuzu/files/patch-CMakeLists.txt30
3 files changed, 21 insertions, 19 deletions
diff --git a/emulators/yuzu/Makefile b/emulators/yuzu/Makefile
index 33f28badea7b..004b72dd1c86 100644
--- a/emulators/yuzu/Makefile
+++ b/emulators/yuzu/Makefile
@@ -1,5 +1,5 @@
PORTNAME= yuzu
-PORTVERSION= s20210419
+PORTVERSION= s20210421
PORTREVISION?= 0
CATEGORIES= emulators
@@ -42,7 +42,7 @@ LIB_DEPENDS= liblz4.so:archivers/liblz4 \
USE_GITHUB= yes
GH_ACCOUNT= yuzu-emu
-GH_TAGNAME= 0da84c4de
+GH_TAGNAME= 607ff3489
GH_TUPLE= yuzu-emu:mbedtls:v2.16.9-52-geac2416b8:mbedtls/externals/mbedtls \
KhronosGroup:SPIRV-Headers:2c51218:SPIRV_Headers/externals/sirit/externals/SPIRV-Headers \
KhronosGroup:Vulkan-Headers:v1.2.145:Vulkan_Headers/externals/Vulkan-Headers \
diff --git a/emulators/yuzu/distinfo b/emulators/yuzu/distinfo
index 72c094a2f412..600fbea488f1 100644
--- a/emulators/yuzu/distinfo
+++ b/emulators/yuzu/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1618867836
-SHA256 (yuzu-emu-yuzu-s20210419-0da84c4de_GH0.tar.gz) = 87031df2ab1eade83bca2f151893273566ce710705ac0517f3fd57a46d570c3b
-SIZE (yuzu-emu-yuzu-s20210419-0da84c4de_GH0.tar.gz) = 3795217
+TIMESTAMP = 1619040993
+SHA256 (yuzu-emu-yuzu-s20210421-607ff3489_GH0.tar.gz) = c890653a4723cc8751d222e701ed097bb5df26d9d8a203561774c63d21cc84ce
+SIZE (yuzu-emu-yuzu-s20210421-607ff3489_GH0.tar.gz) = 3795852
SHA256 (yuzu-emu-mbedtls-v2.16.9-52-geac2416b8_GH0.tar.gz) = 8d3b480b4121feaa30f12fdec06de741775465454610202363edaf7564d4f3bb
SIZE (yuzu-emu-mbedtls-v2.16.9-52-geac2416b8_GH0.tar.gz) = 2676404
SHA256 (KhronosGroup-SPIRV-Headers-2c51218_GH0.tar.gz) = 08f70947b69e17c7e322156adcd471cf02b4b3f63e7baf8ee0f02d32603ac5ff
diff --git a/emulators/yuzu/files/patch-CMakeLists.txt b/emulators/yuzu/files/patch-CMakeLists.txt
index ec3911fb99a5..6b7b96fe03ef 100644
--- a/emulators/yuzu/files/patch-CMakeLists.txt
+++ b/emulators/yuzu/files/patch-CMakeLists.txt
@@ -1,28 +1,30 @@
yuzu (Qt) currently needs SDL for input
---- CMakeLists.txt.orig 2021-04-19 21:30:36 UTC
+--- CMakeLists.txt.orig 2021-04-21 21:36:33 UTC
+++ CMakeLists.txt
-@@ -273,9 +273,10 @@ if (ENABLE_SDL2)
+@@ -273,9 +273,13 @@ if (ENABLE_SDL2)
add_library(SDL2 INTERFACE)
target_link_libraries(SDL2 INTERFACE "${SDL2_LIBRARY}")
target_include_directories(SDL2 INTERFACE "${SDL2_INCLUDE_DIR}")
- else()
-- find_package(SDL2 2.0.12)
--
+ endif()
+endif()
++
+if (NOT YUZU_USE_BUNDLED_SDL2)
-+ find_package(SDL2 2.0.12)
- if(SDL2_FOUND)
+ find_package(SDL2 2.0.14 QUIET)
+
++ if (TRUE)
+ if (SDL2_FOUND)
# Some installations don't set SDL2_LIBRARIES
if("${SDL2_LIBRARIES}" STREQUAL "")
-@@ -287,9 +288,6 @@ if (ENABLE_SDL2)
- add_library(SDL2 INTERFACE)
- target_link_libraries(SDL2 INTERFACE "${SDL2_LIBRARIES}")
- endif()
-- endif()
--else()
-- set(SDL2_FOUND NO)
+--- src/input_common/CMakeLists.txt.orig 2021-04-21 21:36:33 UTC
++++ src/input_common/CMakeLists.txt
+@@ -62,7 +62,7 @@ else()
+ )
endif()
- # Install any missing dependencies with conan install
+-if (ENABLE_SDL2)
++if (SDL2_FOUND)
+ target_sources(input_common PRIVATE
+ sdl/sdl_impl.cpp
+ sdl/sdl_impl.h