aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKyle Evans <kevans@FreeBSD.org>2021-11-10 15:39:34 +0000
committerKyle Evans <kevans@FreeBSD.org>2021-11-10 16:03:52 +0000
commit85ee66732b16513bebd7363e8509665010209a6c (patch)
tree920a49f7c0aea7f226154aaaef73cedea4fa1677
parent80b2ec1a7f353c5ca3094e2754c6b4bd775f5e13 (diff)
downloadports-85ee66732b16513bebd7363e8509665010209a6c.tar.gz
ports-85ee66732b16513bebd7363e8509665010209a6c.zip
devel/zmusic: fix category to audio
devel is accurate, but audio is much more precise. Reported by: danfe
-rw-r--r--MOVED1
-rw-r--r--audio/Makefile1
-rw-r--r--audio/zmusic/Makefile (renamed from devel/zmusic/Makefile)2
-rw-r--r--audio/zmusic/distinfo (renamed from devel/zmusic/distinfo)0
-rw-r--r--audio/zmusic/files/patch-source_CMakeLists.txt (renamed from devel/zmusic/files/patch-source_CMakeLists.txt)0
-rw-r--r--audio/zmusic/files/patch-thirdparty_game-music-emu_gme_blargg__endian.h (renamed from devel/zmusic/files/patch-thirdparty_game-music-emu_gme_blargg__endian.h)0
-rw-r--r--audio/zmusic/pkg-descr (renamed from devel/zmusic/pkg-descr)0
-rw-r--r--audio/zmusic/pkg-plist (renamed from devel/zmusic/pkg-plist)0
-rw-r--r--devel/Makefile1
-rw-r--r--games/gzdoom/Makefile2
10 files changed, 4 insertions, 3 deletions
diff --git a/MOVED b/MOVED
index ebded7be779f..88c71bb250b0 100644
--- a/MOVED
+++ b/MOVED
@@ -16596,3 +16596,4 @@ devel/clanlib||2021-10-31|Has expired: Upstream no longer maintained
astro/boinc-setiathome||2021-11-03|No longer giving out work units
astro/boinc-astropulse||2021-11-04|boinc-setiathome removed, no longer needed
multimedia/celluloid-devel|multimedia/celluloid|2021-11-05|Out of date: use multimedia/celluloid for now
+devel/zmusic|audio/zmusic|2021-11-10|Category change
diff --git a/audio/Makefile b/audio/Makefile
index 2adae11009a7..f13f264041a1 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -894,6 +894,7 @@
SUBDIR += zita-njbridge
SUBDIR += zita-resampler
SUBDIR += zita-rev1
+ SUBDIR += zmusic
SUBDIR += zplugins-lv2
SUBDIR += zrythm
SUBDIR += zynaddsubfx
diff --git a/devel/zmusic/Makefile b/audio/zmusic/Makefile
index 1fada53de0c5..b6aa28d4b998 100644
--- a/devel/zmusic/Makefile
+++ b/audio/zmusic/Makefile
@@ -1,6 +1,6 @@
PORTNAME= zmusic
PORTVERSION= 1.1.8
-CATEGORIES= devel
+CATEGORIES= audio
MAINTAINER= kevans@FreeBSD.org
COMMENT= GZDoom's music system as a standalone library
diff --git a/devel/zmusic/distinfo b/audio/zmusic/distinfo
index ba6ec3c0e344..ba6ec3c0e344 100644
--- a/devel/zmusic/distinfo
+++ b/audio/zmusic/distinfo
diff --git a/devel/zmusic/files/patch-source_CMakeLists.txt b/audio/zmusic/files/patch-source_CMakeLists.txt
index 620ef0c37afc..620ef0c37afc 100644
--- a/devel/zmusic/files/patch-source_CMakeLists.txt
+++ b/audio/zmusic/files/patch-source_CMakeLists.txt
diff --git a/devel/zmusic/files/patch-thirdparty_game-music-emu_gme_blargg__endian.h b/audio/zmusic/files/patch-thirdparty_game-music-emu_gme_blargg__endian.h
index 890758e04a89..890758e04a89 100644
--- a/devel/zmusic/files/patch-thirdparty_game-music-emu_gme_blargg__endian.h
+++ b/audio/zmusic/files/patch-thirdparty_game-music-emu_gme_blargg__endian.h
diff --git a/devel/zmusic/pkg-descr b/audio/zmusic/pkg-descr
index 822387a9da11..822387a9da11 100644
--- a/devel/zmusic/pkg-descr
+++ b/audio/zmusic/pkg-descr
diff --git a/devel/zmusic/pkg-plist b/audio/zmusic/pkg-plist
index e7ce2336a287..e7ce2336a287 100644
--- a/devel/zmusic/pkg-plist
+++ b/audio/zmusic/pkg-plist
diff --git a/devel/Makefile b/devel/Makefile
index 0fc18569b0cc..7809ac52b59d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -7214,7 +7214,6 @@
SUBDIR += zeal
SUBDIR += zfp
SUBDIR += zls
- SUBDIR += zmusic
SUBDIR += zookeeper
SUBDIR += zpu-binutils
SUBDIR += zpu-gcc
diff --git a/games/gzdoom/Makefile b/games/gzdoom/Makefile
index 3aa9995bec34..efe0095e68ce 100644
--- a/games/gzdoom/Makefile
+++ b/games/gzdoom/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE_LGPL3= ${WRKSRC}/docs/licenses/lgpl.txt
BUILD_DEPENDS= zip:archivers/zip
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
- libzmusic.so:devel/zmusic
+ libzmusic.so:audio/zmusic
USES= cmake compiler:c++11-lang gl gnome jpeg pkgconfig sdl