aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-12-05 20:50:42 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-12-05 20:50:42 +0000
commit864d4fdd1804d2d4f46619f781e397b9ccdf1639 (patch)
treeb32b902152c04a4fbcf83802a3c18ca863d9ab88
parent316c372c7d133c416ced0bd6b1f21fdd011117eb (diff)
downloadports-864d4fdd1804d2d4f46619f781e397b9ccdf1639.tar.gz
ports-864d4fdd1804d2d4f46619f781e397b9ccdf1639.zip
biology/libgff: GFF/GTF parsing library based on GCLib
This is an attempt to perform a simple "libraryfication" of the GFF/GTF parsing code that is used in GFFRead codebase. There are not many (any?) relatively lightweight GTF/GFF parsers exposing a C++ interface, and the goal of this library is to provide this functionality without the necessity of drawing in a heavy-weight dependency like SeqAn. Note: This library draws directly from the code in GFFRead and GCLib, and exists primarily to remove functionality (and hence code) that is unnecessary for our downstream purposes. In the future, it may be appropriate to just replace this library wholesale with GCLib.
-rw-r--r--biology/Makefile1
-rw-r--r--biology/libgff/Makefile16
-rw-r--r--biology/libgff/distinfo3
-rw-r--r--biology/libgff/pkg-descr11
-rw-r--r--biology/libgff/pkg-plist14
5 files changed, 45 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 02ba7b46b286..4e16a737f636 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -78,6 +78,7 @@
SUBDIR += kallisto
SUBDIR += lamarc
SUBDIR += libbigwig
+ SUBDIR += libgff
SUBDIR += libgtextutils
SUBDIR += libneurosim
SUBDIR += libnuml
diff --git a/biology/libgff/Makefile b/biology/libgff/Makefile
new file mode 100644
index 000000000000..6a16d0cd4557
--- /dev/null
+++ b/biology/libgff/Makefile
@@ -0,0 +1,16 @@
+PORTNAME= libgff
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.0.0
+CATEGORIES= biology
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= GFF/GTF parsing library based on GCLib
+
+LICENSE= BSL
+LICENSE_FILE= ${WRKSRC}/BoostLicense.txt
+
+USES= cmake
+USE_GITHUB= yes
+GH_ACCOUNT= COMBINE-lab
+
+.include <bsd.port.mk>
diff --git a/biology/libgff/distinfo b/biology/libgff/distinfo
new file mode 100644
index 000000000000..9bb01692e5c1
--- /dev/null
+++ b/biology/libgff/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1631451501
+SHA256 (COMBINE-lab-libgff-v2.0.0_GH0.tar.gz) = 7656b19459a7ca7d2fd0fcec4f2e0fd0deec1b4f39c703a114e8f4c22d82a99c
+SIZE (COMBINE-lab-libgff-v2.0.0_GH0.tar.gz) = 102152
diff --git a/biology/libgff/pkg-descr b/biology/libgff/pkg-descr
new file mode 100644
index 000000000000..762881bedb74
--- /dev/null
+++ b/biology/libgff/pkg-descr
@@ -0,0 +1,11 @@
+This is an attempt to perform a simple "libraryfication" of the GFF/GTF
+parsing code that is used in GFFRead codebase. There are not many
+(any?) relatively lightweight GTF/GFF parsers exposing a C++ interface,
+and the goal of this library is to provide this functionality without
+the necessity of drawing in a heavy-weight dependency like SeqAn. Note:
+This library draws directly from the code in GFFRead and GCLib, and
+exists primarily to remove functionality (and hence code) that is
+unnecessary for our downstream purposes. In the future, it may be
+appropriate to just replace this library wholesale with GCLib.
+
+WWW: https://github.com/COMBINE-lab/libgff
diff --git a/biology/libgff/pkg-plist b/biology/libgff/pkg-plist
new file mode 100644
index 000000000000..474ea892d185
--- /dev/null
+++ b/biology/libgff/pkg-plist
@@ -0,0 +1,14 @@
+include/GArgs.h
+include/GBase.h
+include/GFaSeqGet.h
+include/GFastaIndex.h
+include/GHash.hh
+include/GList.hh
+include/GStr.h
+include/GVec.hh
+include/codons.h
+include/gdna.h
+include/gff.h
+lib/libgff.a
+lib/libgff/cmake/libgffConfig.cmake
+lib/libgff/cmake/libgffConfigVersion.cmake