aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-08-08 14:36:47 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-08-08 14:54:10 +0000
commit87682c881ef59de1a70297937645817bc693a0f1 (patch)
tree8a00b99bea728c0d04ebd1a2e4f10c5aa63fc144
parentba8b14c4f08c47d83f689aae8d4b6998a1051782 (diff)
downloadports-87682c881ef59de1a70297937645817bc693a0f1.tar.gz
ports-87682c881ef59de1a70297937645817bc693a0f1.zip
print/py-relatorio: Add CHART and FODT options
- Fix RUN_DEPENDS: it should be py-python-magic, not py-magic - Bump PORTREVISION for dependency change
-rw-r--r--print/py-relatorio/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/print/py-relatorio/Makefile b/print/py-relatorio/Makefile
index 50a021ae9b93..50f9d483ae57 100644
--- a/print/py-relatorio/Makefile
+++ b/print/py-relatorio/Makefile
@@ -2,6 +2,7 @@
PORTNAME= relatorio
PORTVERSION= 0.9.3
+PORTREVISION= 1
CATEGORIES= print python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,14 +14,20 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Genshi>=0.5:textproc/py-genshi@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}lxml>=2.0:devel/py-lxml@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}magic>=0:devel/py-magic@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pycha>=0.4.0:graphics/py-pycha@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}yaml>=0:devel/py-yaml@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}lxml>=2.0:devel/py-lxml@${PY_FLAVOR}
USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
+OPTIONS_DEFINE= CHART FODT
+OPTIONS_DEFAULT=CHART FODT
+CHART_DESC= Chart support
+FODT_DESC= OpenDocument support
+
+CHART_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycha>=0.4.0:graphics/py-pycha@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=0:devel/py-yaml@${PY_FLAVOR}
+FODT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-magic>=0:devel/py-python-magic@${PY_FLAVOR} \
+
.include <bsd.port.mk>