aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2022-09-23 07:29:42 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2022-09-23 07:34:50 +0000
commit87c59187353dbd3f8e0b39b3130d797afbdef439 (patch)
tree6b22de9fcc9b08cf9906862dc444a56e0d279ed3
parent8c48c46e3f3c45cdb75e6d857a1c82a9615ec59b (diff)
downloadports-87c59187353dbd3f8e0b39b3130d797afbdef439.tar.gz
ports-87c59187353dbd3f8e0b39b3130d797afbdef439.zip
www/piwigo: rework dependencies
- use canonical way for sodium depend3ncy [1] - add php-zip dependency (needed for a plugin) Thus is tested upto php 8.1. Noticed by: fluffy [1]
-rw-r--r--www/piwigo/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/www/piwigo/Makefile b/www/piwigo/Makefile
index 397c4ac769bb..eed70ad60fda 100644
--- a/www/piwigo/Makefile
+++ b/www/piwigo/Makefile
@@ -1,9 +1,9 @@
PORTNAME= piwigo
DISTVERSION= 12.3.0
-PORTREVISION= 2
+PORTREVISION= 3
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
CATEGORIES= www
MASTER_SITES= https://piwigo.org/download/dlcounter.php?code=${PORTVERSION}&/
-PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
MAINTAINER= netchild@FreeBSD.org
COMMENT= PHP based Web Gallery
@@ -12,11 +12,13 @@ WWW= https://piwigo.org/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/doc/COPYING
-RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/sodium.so:security/pecl-libsodium@${PHP_FLAVOR}
-
USES= cpe php:web,flavors zip
USE_PHP= ctype dom exif filter gd hash iconv json mbstring mysqli \
- openssl pcre pdo session simplexml spl tokenizer xml zlib
+ openssl pcre pdo session simplexml sodium spl tokenizer \
+ xml zip zlib
+# sodium is needed for randomisation stuff (prefferred option),
+# could be replaced by mcrypt
+# zip is used by an optional plugin
NO_ARCH= yes
NO_BUILD= yes