aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2023-04-24 20:31:37 +0000
committerDimitry Andric <dim@FreeBSD.org>2023-04-25 16:27:56 +0000
commit88f549c0d62c1a897a69aeebbb15d8ec91c9dc20 (patch)
tree7493db58ccd25a3f89e551839bc30f1b18b7420a
parent8948cc04ebd1b07d1e05891a4951732302e7af83 (diff)
downloadports-88f549c0d62c1a897a69aeebbb15d8ec91c9dc20.tar.gz
ports-88f549c0d62c1a897a69aeebbb15d8ec91c9dc20.zip
graphics/libGLU: fix build with clang 16
Since clang 16 (and gcc 11) the default C++ standard is now gnu++17. Because graphics/libGLU's Makefile does not explicitly set its C++ standard, this leads to several errors: ../src/libnurbs/internals/varray.cc:76:5: error: ISO C++17 does not allow 'register' storage class specifier [-Wregister] register long ds = sgn(arc->tail()[0] - arc->prev->tail()[0]); ^~~~~~~~~ ../src/libnurbs/internals/varray.cc:77:5: error: ISO C++17 does not allow 'register' storage class specifier [-Wregister] register long dt = sgn(arc->tail()[1] - arc->prev->tail()[1]); ^~~~~~~~~ Upstream already noticed this, and committed https://gitlab.freedesktop.org/mesa/glu/-/commit/b6c308172993 as a fix, so add this as an additional patch, until the next version is released. PR: 271055 Approved by: manu (maintainer) MFH: 2023Q2
-rw-r--r--graphics/libGLU/Makefile5
-rw-r--r--graphics/libGLU/distinfo4
2 files changed, 7 insertions, 2 deletions
diff --git a/graphics/libGLU/Makefile b/graphics/libGLU/Makefile
index 1d97e66d0335..2b5fde873366 100644
--- a/graphics/libGLU/Makefile
+++ b/graphics/libGLU/Makefile
@@ -1,11 +1,14 @@
PORTNAME= libGLU
PORTVERSION= 9.0.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.freedesktop.org/pub/mesa/glu/ \
https://mesa.freedesktop.org/archive/glu/
DISTNAME= glu-${PORTVERSION}
+PATCH_SITES= https://gitlab.freedesktop.org/mesa/glu/-/commit/
+PATCHFILES+= b6c308172993.patch:-p1 #https://gitlab.freedesktop.org/mesa/glu/-/merge_requests/10
+
MAINTAINER= x11@FreeBSD.org
COMMENT= OpenGL utility library
WWW= https://gitlab.freedesktop.org/mesa/glu
diff --git a/graphics/libGLU/distinfo b/graphics/libGLU/distinfo
index d0b35fda2468..158535aaf264 100644
--- a/graphics/libGLU/distinfo
+++ b/graphics/libGLU/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1624573301
+TIMESTAMP = 1682367009
SHA256 (glu-9.0.2.tar.xz) = 6e7280ff585c6a1d9dfcdf2fca489251634b3377bfc33c29e4002466a38d02d4
SIZE (glu-9.0.2.tar.xz) = 436176
+SHA256 (b6c308172993.patch) = 54ea23facb71f3e2f1cdab535f95ea55e74982b6ec70763d4d39937a5e456487
+SIZE (b6c308172993.patch) = 1187