aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2024-06-09 05:18:41 +0000
committerCy Schubert <cy@FreeBSD.org>2024-06-09 05:19:47 +0000
commit8930e017ab2424f8ad9526d5ec8ce16ae8ec2dbf (patch)
treef9ede12c93e05a8aeb08aa3ce71d9f1bb355c3cc
parenta3584f5c3aa1d8d4d48dcab219359e9852fefce8 (diff)
downloadports-8930e017ab2424f8ad9526d5ec8ce16ae8ec2dbf.tar.gz
ports-8930e017ab2424f8ad9526d5ec8ce16ae8ec2dbf.zip
net/wpa_supplicant_gui: Fix 15-CURRENT 108de784513d build
On FreeBSD systems without 108de784513d the old definition will be used while on 108de784513d and newer the duplicate case will be removed. Obtained from: src 676041c41ba5
-rw-r--r--net/wpa_supplicant_gui/Makefile2
-rw-r--r--net/wpa_supplicant_gui/files/patch-src_utils_os__unix.c26
2 files changed, 15 insertions, 13 deletions
diff --git a/net/wpa_supplicant_gui/Makefile b/net/wpa_supplicant_gui/Makefile
index 68689f8c8e74..666ed2be8285 100644
--- a/net/wpa_supplicant_gui/Makefile
+++ b/net/wpa_supplicant_gui/Makefile
@@ -1,6 +1,6 @@
PORTNAME= wpa_supplicant_gui
DISTVERSION= 2.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= https://w1.fi/releases/ \
LOCAL/yuri/net/wpa_supplicant_gui/:icons
diff --git a/net/wpa_supplicant_gui/files/patch-src_utils_os__unix.c b/net/wpa_supplicant_gui/files/patch-src_utils_os__unix.c
index ccb80bf9fbe6..612df647489e 100644
--- a/net/wpa_supplicant_gui/files/patch-src_utils_os__unix.c
+++ b/net/wpa_supplicant_gui/files/patch-src_utils_os__unix.c
@@ -1,13 +1,15 @@
---- src/utils/os_unix.c.orig 2015-09-27 19:02:05 UTC
-+++ src/utils/os_unix.c
-@@ -23,6 +23,10 @@
- #include <mach/mach_time.h>
- #endif /* __MACH__ */
-
-+#ifdef __FreeBSD__
-+#define fdatasync fsync
+--- src/utils/os_unix.c.orig 2022-01-16 12:51:29.000000000 -0800
++++ src/utils/os_unix.c 2024-06-01 22:03:18.774245000 -0700
+@@ -103,10 +103,12 @@
+ break;
+ #endif
+ #ifdef CLOCK_MONOTONIC
++#if !(defined(CLOCK_BOOTTIME) && CLOCK_BOOTTIME == CLOCK_MONOTONIC)
+ case CLOCK_MONOTONIC:
+ clock_id = CLOCK_REALTIME;
+ break;
+ #endif
+#endif
-+
- #include "os.h"
- #include "common.h"
-
+ case CLOCK_REALTIME:
+ return -1;
+ }