aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-01-24 02:42:13 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-01-24 02:42:56 +0000
commit8948a51ce79c8bf7eb298e45cacc08314ddfed7c (patch)
tree8195a9bd0d11d06f23c350f766d6ee03e9517fa6
parent0bcc1286080f4460d9bb143e043320b111860abf (diff)
downloadports-8948a51ce79c8bf7eb298e45cacc08314ddfed7c.tar.gz
ports-8948a51ce79c8bf7eb298e45cacc08314ddfed7c.zip
audio/py-soxr: Fix build on arm64
Reported by: fallout (cherry picked from commit 65230ac4139e40ad40b506ef2b39d2ccbb0b9d84)
-rw-r--r--audio/py-soxr/files/patch-setup.py14
1 files changed, 14 insertions, 0 deletions
diff --git a/audio/py-soxr/files/patch-setup.py b/audio/py-soxr/files/patch-setup.py
new file mode 100644
index 000000000000..8ce5eb695372
--- /dev/null
+++ b/audio/py-soxr/files/patch-setup.py
@@ -0,0 +1,14 @@
+- workaround for https://github.com/dofuuz/python-soxr/issues/25
+
+--- setup.py.orig 2024-01-24 02:08:37 UTC
++++ setup.py
+@@ -122,7 +122,8 @@ if '-arm' in platform:
+
+ platform = sysconfig.get_platform()
+ if '-arm' in platform:
+- compile_args.append('-mfpu=neon')
++ #compile_args.append('-mfpu=neon')
++ pass
+ elif '-i686' in platform:
+ compile_args.append('-msse')
+