aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-10-09 07:00:27 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-10-09 07:43:12 +0000
commit89bfe87e0e27beab4b0e384e00769f68eba03986 (patch)
treef2ad308334a76fd92611e5b9577e2c84a54738fe
parent68016c256e8dcea59e8948722541047e89689de3 (diff)
downloadports-89bfe87e0e27beab4b0e384e00769f68eba03986.tar.gz
ports-89bfe87e0e27beab4b0e384e00769f68eba03986.zip
shells/nushell: fix build on armv7
- mark as LTO_UNSAFE on armv6/armv7 to avoid address space exhaustion - remove custom do-test target to avoid a conflict with cargo.mk's do-test; cargo.mk's default do-test does the job well enough Approved by: portmgr (build fix blanket) MFH: 2023Q4 (cherry picked from commit f22649e35840ddc7d3a19b8e9dd643b3f7885e0f)
-rw-r--r--shells/nushell/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/shells/nushell/Makefile b/shells/nushell/Makefile
index 2edd25cb071e..be61596d5b7a 100644
--- a/shells/nushell/Makefile
+++ b/shells/nushell/Makefile
@@ -607,10 +607,14 @@ DATAFRAME_DESC= Include the dataframe feature
DATAFRAME_VARS= CARGO_BUILD_ARGS+=--features=dataframe
DATAFRAME_BROKEN= see https://github.com/nushell/nushell/issues/7665
+.include <bsd.port.pre.mk>
+
+# avoid address space exhaustion in compiler
+.if ${ARCH:Marmv?}
+LTO_UNSAFE= yes
+.endif
+
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/nu
-do-test:
- @${CARGO_CARGO_RUN} test --workspace
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>