aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-08-16 13:24:33 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-08-16 14:27:02 +0000
commit89e5c5677eeda5fdac995bf4bc936094348f8e8b (patch)
tree26766a13a39a75b6054d36166eb28fc7c44f39ff
parentd7154b67b7d5545917082a61ce8472397653f9f7 (diff)
downloadports-89e5c5677eeda5fdac995bf4bc936094348f8e8b.tar.gz
ports-89e5c5677eeda5fdac995bf4bc936094348f8e8b.zip
devel/py-types-Flask: new port: typing stubs for Flask
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-types-Flask/Makefile20
-rw-r--r--devel/py-types-Flask/distinfo3
-rw-r--r--devel/py-types-Flask/pkg-descr5
4 files changed, 29 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2b40e5f2edb6..148d1ec345a6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5232,6 +5232,7 @@
SUBDIR += py-typechecks
SUBDIR += py-typed-ast
SUBDIR += py-typer
+ SUBDIR += py-types-Flask
SUBDIR += py-types-Jinja2
SUBDIR += py-types-MarkupSafe
SUBDIR += py-types-PyYAML
diff --git a/devel/py-types-Flask/Makefile b/devel/py-types-Flask/Makefile
new file mode 100644
index 000000000000..d0e815f38be2
--- /dev/null
+++ b/devel/py-types-Flask/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= types-Flask
+PORTVERSION= 1.1.3
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Typing stubs for Flask
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}types-Jinja2>=0:devel/py-types-Jinja2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}types-Werkzeug>=0:devel/py-types-Werkzeug@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}types-click>=0:devel/py-types-click@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-types-Flask/distinfo b/devel/py-types-Flask/distinfo
new file mode 100644
index 000000000000..d16ae799f1ed
--- /dev/null
+++ b/devel/py-types-Flask/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1629117645
+SHA256 (types-Flask-1.1.3.tar.gz) = c9e476d9e584d804b5ddd5a35ac8b7f46dba13560a43fd0e1b1215419fd992aa
+SIZE (types-Flask-1.1.3.tar.gz) = 9577
diff --git a/devel/py-types-Flask/pkg-descr b/devel/py-types-Flask/pkg-descr
new file mode 100644
index 000000000000..0f41edeb594c
--- /dev/null
+++ b/devel/py-types-Flask/pkg-descr
@@ -0,0 +1,5 @@
+This is an auto-generated PEP 561 type stub package for Flask
+package. It can be used by type-checking tools like mypy, PyCharm,
+pytype etc. to check code that uses Flask.
+
+WWW: https://pypi.org/project/types-Flask/