aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-04-27 09:46:41 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-04-27 12:01:42 +0000
commit89fef4d904086fa7d15c87885f6e59041f2c86a0 (patch)
tree72c6535788abcae474c47827abb1bfd90258b9d8
parent3e0515560556dc48ce03e315b2de73143a95ca22 (diff)
downloadports-89fef4d904086fa7d15c87885f6e59041f2c86a0.tar.gz
ports-89fef4d904086fa7d15c87885f6e59041f2c86a0.zip
graphics/wdune: Move to FFmpeg 4
Fails to build with FFmpeg 6 PR: 270212 Approved by: portmgr (blanket, build fix) Sponsored by: Blinkinblox
-rw-r--r--graphics/wdune/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/graphics/wdune/Makefile b/graphics/wdune/Makefile
index 404521d1654c..9f059cba4aff 100644
--- a/graphics/wdune/Makefile
+++ b/graphics/wdune/Makefile
@@ -18,19 +18,19 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libmpfr.so:math/mpfr \
libosdCPU.so:graphics/opensubdiv \
libpng.so:graphics/png \
- libswresample.so:multimedia/ffmpeg
+ libswresample.so.3:multimedia/ffmpeg4
USES= compiler:c++11-lang gl jpeg motif sdl tar:bzip2 xorg
USE_XORG= x11 xft xi xmu xext xt
USE_GL= gl glu glut
USE_SDL= sdl
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-optimization \
+CONFIGURE_ARGS= --with-optimization \
--without-devil \
--with-cgalheaders \
--with-helpurl="${DOCSDIR}/index.html"
-CPPFLAGS+= -I${LOCALBASE}/include/freetype2 -D__FREEBSD__
-LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/ffmpeg4/include -I${LOCALBASE}/include/freetype2 -D__FREEBSD__
+LDFLAGS+= -L${LOCALBASE}/ffmpeg4/lib -L${LOCALBASE}/lib
CONFLICTS_INSTALL= ocaml-dune