aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLorenzo Salvadore <salvadore@FreeBSD.org>2023-05-08 07:24:42 +0000
committerLorenzo Salvadore <salvadore@FreeBSD.org>2023-05-15 13:32:08 +0000
commit8a1885234ce78307fcc224c6698f8fc4628a8a8c (patch)
tree01146fda5f13312cc672c42339a445147e69117d
parentc3345b90252ef709ab011e015d1e5a2e5f6a9d7c (diff)
downloadports-8a1885234ce78307fcc224c6698f8fc4628a8a8c.tar.gz
ports-8a1885234ce78307fcc224c6698f8fc4628a8a8c.zip
lang/gcc14-devel: Enable support for .init_array and .fini_array
Enable support for .init_array and .fini_array, which FreeBSD supports since commit 83aa9cc00c2d83d05a0efe7a1496d8aab4a153bb in the src repository. There __FreeBSD_version is 1000009, so we start enabling the support from __FreeBSD_version == 1000010. See also review https://reviews.freebsd.org/D39968 for lang/gcc11-devel. Reported by: Dan McGregor <dan.mcgregor@usask.ca>
-rw-r--r--lang/gcc14-devel/Makefile1
-rw-r--r--lang/gcc14-devel/files/patch-gcc_configure20
2 files changed, 21 insertions, 0 deletions
diff --git a/lang/gcc14-devel/Makefile b/lang/gcc14-devel/Makefile
index 42bb12f52332..276cbae91789 100644
--- a/lang/gcc14-devel/Makefile
+++ b/lang/gcc14-devel/Makefile
@@ -1,5 +1,6 @@
PORTNAME= gcc
PORTVERSION= 14.0.0.s20230507
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= GCC/snapshots/${DIST_VERSION}
PKGNAMESUFFIX= ${SUFFIX}-devel
diff --git a/lang/gcc14-devel/files/patch-gcc_configure b/lang/gcc14-devel/files/patch-gcc_configure
new file mode 100644
index 000000000000..d4e7e8d23e60
--- /dev/null
+++ b/lang/gcc14-devel/files/patch-gcc_configure
@@ -0,0 +1,20 @@
+Enable support for .init_array and .fini_array, which FreeBSD supports
+since commit 83aa9cc00c2d83d05a0efe7a1496d8aab4a153bb in the src
+repository.
+
+There __FreeBSD_version is 1000009, so we start enabling the support
+from __FreeBSD_version == 1000010.
+--- gcc/configure.orig 2023-05-04 17:36:54 UTC
++++ gcc/configure
+@@ -24214,6 +24214,11 @@ EOF
+ #else
+ # if defined __sun__ && defined __svr4__
+ /* Solaris ld.so.1 supports .init_array/.fini_array since Solaris 8. */
++# elif defined __FreeBSD__
++# include <sys/param.h>
++# if __FreeBSD_version >= 1000010
++ /* FreeBSD supports .init_array/.fini_array since FreeBSD 10. */
++# endif
+ # else
+ # error The C library not known to support .init_array/.fini_array
+ # endif