aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2023-09-29 21:15:58 +0000
committerDima Panov <fluffy@FreeBSD.org>2023-09-29 21:15:58 +0000
commit8a50a5c7fb3f9f1e166cd636a00249e3cfbe2dcf (patch)
tree9ea386a5ee8bc1028b80ae6eb15eefe967bb832d
parent04f4d5ba9b2a920d6fd52ebec4d8fdfb18de8adb (diff)
downloadports-8a50a5c7fb3f9f1e166cd636a00249e3cfbe2dcf.tar.gz
ports-8a50a5c7fb3f9f1e166cd636a00249e3cfbe2dcf.zip
graphics/libetonyek01: switch to MDDS 2.1 API (+)
This commit had to be pushed with recently updated LibreOffice and Co. Reported by: pkg-fallout
-rw-r--r--graphics/libetonyek01/Makefile7
-rw-r--r--graphics/libetonyek01/files/patch-configure6
2 files changed, 7 insertions, 6 deletions
diff --git a/graphics/libetonyek01/Makefile b/graphics/libetonyek01/Makefile
index a3cda3e0b3fa..060c75f53eea 100644
--- a/graphics/libetonyek01/Makefile
+++ b/graphics/libetonyek01/Makefile
@@ -1,6 +1,6 @@
PORTNAME= libetonyek
PORTVERSION= 0.1.10
-PORTREVISION= 6
+PORTREVISION= 7
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= LODEV/${PORTNAME}
@@ -20,9 +20,10 @@ LIB_DEPENDS= librevenge-0.0.so:textproc/librevenge \
liblangtag.so:devel/liblangtag \
libxml2.so:textproc/libxml2
-USES= compiler:c++11-lib gmake libtool localbase pkgconfig tar:xz
+USES= compiler:c++17-lang gmake libtool localbase pkgconfig tar:xz
+USE_CXXSTD= c++17
-MDDS_VERSION= 2.0
+MDDS_VERSION= 2.1
CONFIGURE_ARGS= --disable-tests --disable-werror --without-docs --with-mdds=${MDDS_VERSION}
diff --git a/graphics/libetonyek01/files/patch-configure b/graphics/libetonyek01/files/patch-configure
index 6a0c87502c96..45df135c387d 100644
--- a/graphics/libetonyek01/files/patch-configure
+++ b/graphics/libetonyek01/files/patch-configure
@@ -6,8 +6,8 @@
--without-PACKAGE do not use PACKAGE (same as --with-PACKAGE=no)
- --with-mdds=1.5|1.4|1.2|1.0|0.x
- Specify which version of mdds to use (1.5 is the
-+ --with-mdds=2.0|1.7|1.5|1.4|1.2|1.0|0.x
-+ Specify which version of mdds to use (2.0 is the
++ --with-mdds=2.1|2.0|1.7|1.5|1.4|1.2|1.0|0.x
++ Specify which version of mdds to use (2.1 is the
default)
--with-pic[=PKGS] try to use only PIC/non-PIC objects [default=use
both]
@@ -16,7 +16,7 @@
withval=$with_mdds;
else
- with_mdds="1.5"
-+ with_mdds="2.0"
++ with_mdds="2.1"
fi