aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-07-18 14:29:17 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-07-21 06:38:37 +0000
commit8a8806922e0f1b92e09b01302592e9458e62a98c (patch)
tree4e2ee953264a7f3e88955bdd6c71ae27f3b35ea9
parent084edc1eca0c76128ac7a78c40854ccef236a569 (diff)
downloadports-8a8806922e0f1b92e09b01302592e9458e62a98c.tar.gz
ports-8a8806922e0f1b92e09b01302592e9458e62a98c.zip
misc/py-thermocouples_reference: Mew port: Thermocouple emf reference functions
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-thermocouples_reference/Makefile27
-rw-r--r--misc/py-thermocouples_reference/distinfo3
-rw-r--r--misc/py-thermocouples_reference/files/test.py10
-rw-r--r--misc/py-thermocouples_reference/pkg-descr3
5 files changed, 44 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index cf6f98c4454c..1c15af2e03c4 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -474,6 +474,7 @@
SUBDIR += py-tflearn
SUBDIR += py-tflite
SUBDIR += py-tflite-support
+ SUBDIR += py-thermocouples_reference
SUBDIR += py-toil
SUBDIR += py-torch-geometric
SUBDIR += py-torchmetrics
diff --git a/misc/py-thermocouples_reference/Makefile b/misc/py-thermocouples_reference/Makefile
new file mode 100644
index 000000000000..70d4b8ff867e
--- /dev/null
+++ b/misc/py-thermocouples_reference/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= thermocouples_reference
+DISTVERSION= 0.20
+CATEGORIES= misc
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Thermocouple emf reference functions
+WWW= https://pypi.org/project/thermocouples_reference/
+
+LICENSE= PD
+
+#BUILD_DEPENDS= ${PY_SETUPTOOLS}
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist pytest
+
+NO_ARCH= yes
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+do-test:
+ @${SETENV} ${TEST_ENV} ${PYTHON_CMD} ${FILESDIR}/test.py
+
+.include <bsd.port.mk>
diff --git a/misc/py-thermocouples_reference/distinfo b/misc/py-thermocouples_reference/distinfo
new file mode 100644
index 000000000000..2275128e3c26
--- /dev/null
+++ b/misc/py-thermocouples_reference/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1689906306
+SHA256 (thermocouples_reference-0.20.tar.gz) = 94dd18ce6d44e92fffafbb0caf4ed2452efbc31a763850ff439929717f0f4f84
+SIZE (thermocouples_reference-0.20.tar.gz) = 17107
diff --git a/misc/py-thermocouples_reference/files/test.py b/misc/py-thermocouples_reference/files/test.py
new file mode 100644
index 000000000000..d92aadd7ceb6
--- /dev/null
+++ b/misc/py-thermocouples_reference/files/test.py
@@ -0,0 +1,10 @@
+from thermocouples_reference import thermocouples
+
+typeK = thermocouples['K']
+print(f"typeK={typeK}")
+
+t1 = typeK.emf_mVC(42, Tref=0)
+print(f"t1={t1}")
+
+t2 = typeK.emf_mVC([-3.14159, 42, 54], Tref=0)
+print(f"t2={t2}")
diff --git a/misc/py-thermocouples_reference/pkg-descr b/misc/py-thermocouples_reference/pkg-descr
new file mode 100644
index 000000000000..288f27b513db
--- /dev/null
+++ b/misc/py-thermocouples_reference/pkg-descr
@@ -0,0 +1,3 @@
+Python module containing calibration data and lookup functions for standard
+thermocouples of types B, C, D, E, G, J, K, M, N, P, R, S, T, and some less
+standard types too.