aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-10-29 09:43:43 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-11-23 14:57:41 +0000
commit8a891db501c5e80a964ca3954f2ae68375cc3373 (patch)
treea103c4f5d1bf56d18af2db0272168add68e82602
parent0f25620b591853e6de83761ab274b28f2aed734e (diff)
downloadports-8a891db501c5e80a964ca3954f2ae68375cc3373.tar.gz
ports-8a891db501c5e80a964ca3954f2ae68375cc3373.zip
devel/intel-graphics-compiler: update to 1.0.9289
-rw-r--r--devel/intel-graphics-compiler/Makefile7
-rw-r--r--devel/intel-graphics-compiler/distinfo12
-rw-r--r--devel/intel-graphics-compiler/files/patch-unix12
3 files changed, 21 insertions, 10 deletions
diff --git a/devel/intel-graphics-compiler/Makefile b/devel/intel-graphics-compiler/Makefile
index 8fd612154282..b32c380c8abb 100644
--- a/devel/intel-graphics-compiler/Makefile
+++ b/devel/intel-graphics-compiler/Makefile
@@ -1,9 +1,12 @@
PORTNAME= intel-graphics-compiler
DISTVERSIONPREFIX= igc-
-DISTVERSION= 1.0.8744
+DISTVERSION= 1.0.9289
CATEGORIES= devel
PKGNAMESUFFIX= -${FLAVOR}
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES+= 99edbf49d7c9.patch:-p1 # clang
+
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Intel Graphics Compiler for OpenCL
@@ -25,6 +28,8 @@ USES= bison cmake compiler:c++17-lang python:build
USE_GITHUB= yes
USE_LDCONFIG= yes
GH_ACCOUNT= intel
+GH_TUPLE= KhronosGroup:SPIRV-Headers:1.5.4.raytracing.fixed-123-g814e728:headers/../SPIRV-Headers \
+ KhronosGroup:SPIRV-Tools:v2021.4:tools/../SPIRV-Tools
CMAKE_OFF= INSTALL_SPIRVDLL
CMAKE_ARGS= -DCMAKE_PREFIX_PATH:PATH="${LOCALBASE}/${FLAVOR}" \
-DIGC_OPTION__LLVM_PREFERRED_VERSION:STRING="${FLAVOR:S/llvm//}"
diff --git a/devel/intel-graphics-compiler/distinfo b/devel/intel-graphics-compiler/distinfo
index fe8f08fcdfea..40433876fc3e 100644
--- a/devel/intel-graphics-compiler/distinfo
+++ b/devel/intel-graphics-compiler/distinfo
@@ -1,3 +1,9 @@
-TIMESTAMP = 1631782238
-SHA256 (intel-intel-graphics-compiler-igc-1.0.8744_GH0.tar.gz) = 1e8ef2dcebb670e7d66de053c2b0c92b8cf8733dae04503bf26dfd7cc798b5ef
-SIZE (intel-intel-graphics-compiler-igc-1.0.8744_GH0.tar.gz) = 7586378
+TIMESTAMP = 1635500623
+SHA256 (intel-intel-graphics-compiler-igc-1.0.9289_GH0.tar.gz) = 78fac5e59a0f50253a679d5ed1d66c19c970014ead3510b8b4cfab973015a110
+SIZE (intel-intel-graphics-compiler-igc-1.0.9289_GH0.tar.gz) = 7872553
+SHA256 (KhronosGroup-SPIRV-Headers-1.5.4.raytracing.fixed-123-g814e728_GH0.tar.gz) = e4880dccda018f63cdc684afd5e51972d8ad2e3f21e9bab346a865370ea2929e
+SIZE (KhronosGroup-SPIRV-Headers-1.5.4.raytracing.fixed-123-g814e728_GH0.tar.gz) = 416402
+SHA256 (KhronosGroup-SPIRV-Tools-v2021.4_GH0.tar.gz) = d68de260708dda785d109ff1ceeecde2d2ab71142fa5bf59061bb9f47dd3bb2c
+SIZE (KhronosGroup-SPIRV-Tools-v2021.4_GH0.tar.gz) = 2887505
+SHA256 (99edbf49d7c9.patch) = c7a96b5629384422ff2d848624ac60d5cc6dffd0289bce430df1ba813a45474c
+SIZE (99edbf49d7c9.patch) = 1151
diff --git a/devel/intel-graphics-compiler/files/patch-unix b/devel/intel-graphics-compiler/files/patch-unix
index ef8ba7e0a533..41458b19c707 100644
--- a/devel/intel-graphics-compiler/files/patch-unix
+++ b/devel/intel-graphics-compiler/files/patch-unix
@@ -256,17 +256,17 @@ CMake Error at IGC/CMakeLists.txt:1974 (message):
#define LINUX_RELEASE_MODE
#endif
---- visa/BuildCISAIRImpl.cpp.orig 2020-09-16 10:27:28 UTC
+--- visa/BuildCISAIRImpl.cpp.orig 2021-10-29 09:43:43 UTC
+++ visa/BuildCISAIRImpl.cpp
-@@ -576,7 +576,6 @@ extern void CISA_delete_buffer(YY_BUFFER_STATE buf);
-
- int CISA_IR_Builder::ParseVISAText(const std::string& visaHeader, const std::string& visaText, const std::string& visaTextFile)
+@@ -925,7 +925,6 @@ static std::mutex mtx;
+ int CISA_IR_Builder::ParseVISAText(const std::string& visaText, const std::string& visaTextFile)
{
+ const std::lock_guard<std::mutex> lock(mtx);
-#if defined(__linux__) || defined(_WIN64) || defined(_WIN32)
// Direct output of parser to null
#if defined(_WIN64) || defined(_WIN32)
CISAout = fopen("nul", "w");
-@@ -627,16 +626,11 @@ int CISA_IR_Builder::ParseVISAText(const std::string&
+@@ -973,16 +972,11 @@ int CISA_IR_Builder::ParseVISAText(const std::string&
}
return status;
@@ -283,7 +283,7 @@ CMake Error at IGC/CMakeLists.txt:1974 (message):
// Direct output of parser to null
#if defined(_WIN64) || defined(_WIN32)
CISAout = fopen("nul", "w");
-@@ -662,10 +656,6 @@ int CISA_IR_Builder::ParseVISAText(const std::string&
+@@ -1008,10 +1002,6 @@ int CISA_IR_Builder::ParseVISAText(const std::string&
fclose(CISAout);
}
return VISA_SUCCESS;