aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg A. Mamontov <oleg@mamontov.net>2023-08-07 18:30:02 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-08-09 13:01:16 +0000
commit8b299dec679441240f27cff3577a8a5b60fc6c9a (patch)
tree36ecffca8e5711ec6a87ea94c551eff85c98eaea
parente031e6e3a155ae3aa794ed78bf21b125f57bf33d (diff)
downloadports-8b299dec679441240f27cff3577a8a5b60fc6c9a.tar.gz
ports-8b299dec679441240f27cff3577a8a5b60fc6c9a.zip
www/angie-module-image-filter: Angie image-filter dynamic module
Module is a filter that transforms images in JPEG, GIF, PNG, and WebP formats. PR: 272999
-rw-r--r--www/Makefile1
-rw-r--r--www/angie-module-image-filter/Makefile24
-rw-r--r--www/angie-module-image-filter/files/pkg-message.in15
-rw-r--r--www/angie-module-image-filter/pkg-descr3
-rw-r--r--www/angie-module-image-filter/pkg-plist2
5 files changed, 45 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 4c19a0c69e7b..07be8a226767 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -31,6 +31,7 @@
SUBDIR += angie-module-brotli
SUBDIR += angie-module-cache-purge
SUBDIR += angie-module-geoip2
+ SUBDIR += angie-module-image-filter
SUBDIR += anyremote2html
SUBDIR += apache-mode.el
SUBDIR += apache24
diff --git a/www/angie-module-image-filter/Makefile b/www/angie-module-image-filter/Makefile
new file mode 100644
index 000000000000..7e8444efad30
--- /dev/null
+++ b/www/angie-module-image-filter/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= angie-module-image-filter
+
+COMMENT= Angie image-filter dynamic module
+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libgd.so:graphics/gd
+
+CONFIGURE_ADD= --with-http_image_filter_module=dynamic
+
+MASTERDIR= ${.CURDIR}/../../www/angie
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${MODDIR}
+
+ ${INSTALL_LIB} ${WRKSRC}/objs/ngx_http_image_filter_module.so \
+ ${STAGEDIR}${MODDIR}
+
+do-install-DEBUG-on:
+ ${INSTALL} ${COPY} -m ${_SHAREMODE} \
+ ${WRKSRC_DEBUG}/objs/ngx_http_image_filter_module.so \
+ ${STAGEDIR}${MODDIR}/ngx_http_image_filter_module-debug.so
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/angie-module-image-filter/files/pkg-message.in b/www/angie-module-image-filter/files/pkg-message.in
new file mode 100644
index 000000000000..dcd7615b258d
--- /dev/null
+++ b/www/angie-module-image-filter/files/pkg-message.in
@@ -0,0 +1,15 @@
+[
+{ type: install
+ message: <<EOM
+
+The image-filter dynamic module for Angie has been installed.
+To enable this module, add the following to %%PREFIX%%/etc/angie/angie.conf
+and reload angie:
+
+ load_module modules/ngx_http_image_filter_module.so;
+
+Please refer to the modules documentation for further details:
+https://angie.software/en/http_image_filter/
+EOM
+}
+]
diff --git a/www/angie-module-image-filter/pkg-descr b/www/angie-module-image-filter/pkg-descr
new file mode 100644
index 000000000000..750738941d1b
--- /dev/null
+++ b/www/angie-module-image-filter/pkg-descr
@@ -0,0 +1,3 @@
+Module is a filter that transforms images in JPEG, GIF, PNG, and WebP formats.
+Transformation capabilities include crop, resize, rotate, and others. Several
+resulting image options are configurable.
diff --git a/www/angie-module-image-filter/pkg-plist b/www/angie-module-image-filter/pkg-plist
new file mode 100644
index 000000000000..8bee9ea158f0
--- /dev/null
+++ b/www/angie-module-image-filter/pkg-plist
@@ -0,0 +1,2 @@
+%%MODDIR%%/ngx_http_image_filter_module.so
+%%DEBUG%%%%MODDIR%%/ngx_http_image_filter_module-debug.so