aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@ninth-nine.com>2021-11-30 21:29:47 +0000
committerDries Michiels <driesm@FreeBSD.org>2021-12-01 13:36:59 +0000
commit8b46ce03f521842fc322d33c09b4c8f5bb90d746 (patch)
tree392d4a1b3745653b1ee6f0766e23072122246316
parent3679660191a6b735000b52db6627c79c2af679eb (diff)
downloadports-8b46ce03f521842fc322d33c09b4c8f5bb90d746.tar.gz
ports-8b46ce03f521842fc322d33c09b4c8f5bb90d746.zip
textproc/gojq: New port
Pure Go implementation of jq. PR: 259884 Approved by: philip (mentor) Differential Revision: https://reviews.freebsd.org/D33204
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/gojq/Makefile21
-rw-r--r--textproc/gojq/distinfo5
-rw-r--r--textproc/gojq/pkg-descr4
-rw-r--r--textproc/gojq/pkg-plist2
5 files changed, 33 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index b956937a92fe..e200f0c7dbc6 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -235,6 +235,7 @@
SUBDIR += gnugrep
SUBDIR += go-md2man
SUBDIR += go-yq
+ SUBDIR += gojq
SUBDIR += goldendict
SUBDIR += google-ctemplate
SUBDIR += google-translate-cli
diff --git a/textproc/gojq/Makefile b/textproc/gojq/Makefile
new file mode 100644
index 000000000000..e1fa9d5967a0
--- /dev/null
+++ b/textproc/gojq/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= gojq
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.12.5
+CATEGORIES= textproc
+
+MAINTAINER= nork@ninth-nine.com
+COMMENT= Pure Go implementation of jq
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+
+GO_MODULE= github.com/itchyny/gojq
+GO_TARGET= ./cmd/gojq
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/zsh/site-functions
+ ${INSTALL_DATA} ${WRKSRC}/_gojq ${STAGEDIR}${PREFIX}/share/zsh/site-functions/
+
+.include <bsd.port.mk>
diff --git a/textproc/gojq/distinfo b/textproc/gojq/distinfo
new file mode 100644
index 000000000000..8fc59b9b3c6e
--- /dev/null
+++ b/textproc/gojq/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1638309443
+SHA256 (go/textproc_gojq/gojq-v0.12.5/v0.12.5.mod) = a6e12fbe75a18ef3fbbc01fdc7e9e03b74def733c07994fe49d4d36d330b8fad
+SIZE (go/textproc_gojq/gojq-v0.12.5/v0.12.5.mod) = 352
+SHA256 (go/textproc_gojq/gojq-v0.12.5/v0.12.5.zip) = 920d40767ef6dd675d0f35cfa882cf8a5ad4dcc8818bee0f1869cab994d3b6d5
+SIZE (go/textproc_gojq/gojq-v0.12.5/v0.12.5.zip) = 145577
diff --git a/textproc/gojq/pkg-descr b/textproc/gojq/pkg-descr
new file mode 100644
index 000000000000..2f3329fa4174
--- /dev/null
+++ b/textproc/gojq/pkg-descr
@@ -0,0 +1,4 @@
+gojq is an implementation of the jq command written in Go.
+You can also embed gojq as a library to your Go products.
+
+WWW: https://github.com/itchyny/gojq
diff --git a/textproc/gojq/pkg-plist b/textproc/gojq/pkg-plist
new file mode 100644
index 000000000000..d53bd788a457
--- /dev/null
+++ b/textproc/gojq/pkg-plist
@@ -0,0 +1,2 @@
+bin/gojq
+share/zsh/site-functions/_gojq