aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-20 20:46:29 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-20 20:46:29 +0000
commit8be82b9d901ae6645174fa333c80ebae675ad17a (patch)
treed4b01516442bdb16db8bf62f4a956be80ba5d892
parent33c6b6a9107ebd7eb4d395bd1aed6747b99761f9 (diff)
downloadports-8be82b9d901ae6645174fa333c80ebae675ad17a.tar.gz
ports-8be82b9d901ae6645174fa333c80ebae675ad17a.zip
math/py-gym: Update to 0.18.3
-rw-r--r--math/py-gym/Makefile6
-rw-r--r--math/py-gym/distinfo6
-rw-r--r--math/py-gym/files/patch-setup.py11
3 files changed, 6 insertions, 17 deletions
diff --git a/math/py-gym/Makefile b/math/py-gym/Makefile
index ae1fa4975147..a56ed97cd4a2 100644
--- a/math/py-gym/Makefile
+++ b/math/py-gym/Makefile
@@ -1,8 +1,7 @@
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
PORTNAME= gym
-PORTVERSION= 0.18.0
-PORTREVISION= 1
+PORTVERSION= 0.18.3
CATEGORIES= math python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,11 +10,12 @@ MAINTAINER= sunpoet@FreeBSD.org
COMMENT= OpenAI toolkit for developing and comparing your reinforcement learning agents
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cloudpickle>=1.2.0<1.7.0:devel/py-cloudpickle@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}numpy>=1.10.4,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pillow>=0<8.2.1:graphics/py-pillow@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pyglet150>=1.4.0<1.5.1:graphics/py-pyglet150@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyglet150>=1.4.0<1.5.16:graphics/py-pyglet150@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>=0:science/py-scipy@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
diff --git a/math/py-gym/distinfo b/math/py-gym/distinfo
index 4f781661951b..259f6afab8ea 100644
--- a/math/py-gym/distinfo
+++ b/math/py-gym/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1608730757
-SHA256 (gym-0.18.0.tar.gz) = a0dcd25c1373f3938f4cb4565f74f434fba6faefb73a42d09c9dddd0c08af53e
-SIZE (gym-0.18.0.tar.gz) = 1573189
+TIMESTAMP = 1624189743
+SHA256 (gym-0.18.3.tar.gz) = 81a3e3fbf7fcf57c8cf98f7e22d1bdd5815f3824d9c148a7eb42420d3d642967
+SIZE (gym-0.18.3.tar.gz) = 1574545
diff --git a/math/py-gym/files/patch-setup.py b/math/py-gym/files/patch-setup.py
deleted file mode 100644
index b27fd3cf091a..000000000000
--- a/math/py-gym/files/patch-setup.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- setup.py.orig 2020-12-19 00:04:11 UTC
-+++ setup.py
-@@ -29,7 +29,7 @@ setup(name='gym',
- if package.startswith('gym')],
- zip_safe=False,
- install_requires=[
-- 'scipy', 'numpy>=1.10.4', 'pyglet>=1.4.0,<=1.5.0', 'Pillow<=7.2.0', 'cloudpickle>=1.2.0,<1.7.0',
-+ 'scipy', 'numpy>=1.10.4', 'pyglet>=1.4.0,<=1.5.0', 'Pillow<=8.2.0', 'cloudpickle>=1.2.0,<1.7.0',
- ],
- extras_require=extras,
- package_data={'gym': [