aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNuno Teixeira <eduardo@FreeBSD.org>2022-07-01 20:48:49 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2022-07-01 20:52:03 +0000
commit8c41f449bc05a5e8f126f2aeecb9dfcc61bec6ae (patch)
tree25362ed6848ff406ea1ddfeb03448dab88e33ff4
parent042147579bd224f27262bccb5c7b018245fa4c3e (diff)
downloadports-8c41f449bc05a5e8f126f2aeecb9dfcc61bec6ae.tar.gz
ports-8c41f449bc05a5e8f126f2aeecb9dfcc61bec6ae.zip
graphics/py-traitsui: Update to 7.4.0
- add PySide2 and wxPython backends - remove old 'do-test' targets ChangeLog: https://docs.enthought.com/traitsui/changelog.html#release-7-4-0
-rw-r--r--graphics/py-traitsui/Makefile33
-rw-r--r--graphics/py-traitsui/distinfo6
2 files changed, 10 insertions, 29 deletions
diff --git a/graphics/py-traitsui/Makefile b/graphics/py-traitsui/Makefile
index a5043a665711..3866cc384595 100644
--- a/graphics/py-traitsui/Makefile
+++ b/graphics/py-traitsui/Makefile
@@ -1,7 +1,7 @@
# Created by: Vladimir Chukharev
PORTNAME= traitsui
-DISTVERSION= 7.3.1
+DISTVERSION= 7.4.0
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -20,40 +20,21 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyface>=7.4.1:devel/py-pyface@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}traits>=6.2.0:devel/py-traits@${PY_FLAVOR}
# The requirements are defined in traitsui/__init__.py
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}configobj>0:devel/py-configobj@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}numpy>0:math/py-numpy@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pandas>0:math/py-pandas@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pygments>=0:textproc/py-pygments@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}traits>0:devel/py-traits@${PY_FLAVOR}
-# Those requirements (except for pip + coverage) were extracted from etstool.py
-
USES= python:3.7+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
-# Support for the wxPython toolkit is also available, but
-# Python 3 needs wxPython 4 which isn't ported, yet. So we use only Qt5 for a
-# while to make the port useful for Python 3.
-OPTIONS_DEFINE= QT5
+OPTIONS_DEFINE= PYSIDE QT5 WXPYTHON
OPTIONS_DEFAULT= QT5
+PYSIDE_DESC= PySide backend
+WXPYTHON_DESC= wxPython backend
+
+PYSIDE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyside2>=0:devel/pyside2@${PY_FLAVOR}
QT5_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pygments>=0:textproc/py-pygments@${PY_FLAVOR}
QT5_USES= pyqt:5
QT5_USE= PYQT=pyqt5_run
-
-# These tests were extracted from etstool.py and adapted to the ports test framework
-do-test:
- @cd ${WRKSRC} && ${PYTHON_CMD} -m nose -v traitsui.tests
-
-# The test "test_wrap_text_narrow_short" fails at the moment and is going to be
-# fixed with the next release.
-# See also: https://github.com/enthought/traitsui/issues/643
-#
-# Note: The occurences of "qt4" aren't typos
-do-test-QT5-on:
- @cd ${WRKSRC} && ${SETENV} ETS_TOOLKIT=qt4 QT_API=pyqt5 \
- ${PYTHON_CMD} -m nose -v traitsui.qt4.tests
+WXPYTHON_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}wxPython41>0:x11-toolkits/py-wxPython4@${PY_FLAVOR}
.include <bsd.port.mk>
diff --git a/graphics/py-traitsui/distinfo b/graphics/py-traitsui/distinfo
index 398d0d666a26..8599548a4a14 100644
--- a/graphics/py-traitsui/distinfo
+++ b/graphics/py-traitsui/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1656094117
-SHA256 (traitsui-7.3.1.tar.gz) = 9474ad67f345d96b326b401e9a01405c8082c92fa43bf47c0b039818e587ac69
-SIZE (traitsui-7.3.1.tar.gz) = 6781481
+TIMESTAMP = 1656662484
+SHA256 (traitsui-7.4.0.tar.gz) = 25335affee2342d47e35c25df5e7785d22a533584fe1be0943ccba45dc1ae589
+SIZE (traitsui-7.4.0.tar.gz) = 6772956