aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Kiselev <root@dc365.ru>2023-06-27 14:23:22 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-07-02 17:40:16 +0000
commit8c472957483b14e309d75f1c1ee3ece4187a39fa (patch)
tree2680a524633e2ef89e8d4f94ff07a68feebaecdf
parenta451002959c57a55688c6737401c5662aba822bc (diff)
downloadports-8c472957483b14e309d75f1c1ee3ece4187a39fa.tar.gz
ports-8c472957483b14e309d75f1c1ee3ece4187a39fa.zip
net/remmina: force libsoup2
If libsoup3 is present in the system, remmina might pick it even if it is expected to use libsoup2. This results in an error like: libsoup-ERROR **: 09:36:19.231: libsoup3 symbols detected. Using libsoup2 and libsoup3 in the same process is not supported. Force libsoup2. PR: 271557 Reported by: root@dc365.ru
-rw-r--r--net/remmina/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/net/remmina/Makefile b/net/remmina/Makefile
index a3f615c8084e..89c64e5967e7 100644
--- a/net/remmina/Makefile
+++ b/net/remmina/Makefile
@@ -35,7 +35,8 @@ USE_XORG= ice sm x11 xext
SHEBANG_FILES= data/desktop/remmina-file-wrapper.in
bash_CMD= ${SH}
-CMAKE_ARGS= -DWITH_APPINDICATOR:BOOL=false
+CMAKE_ARGS= -DWITH_APPINDICATOR:BOOL=false \
+ -DLIBSOUP_LIBRARY=/usr/local/lib/libsoup-2.4.so
CONFLICTS_INSTALL= remmina-plugin*
@@ -114,6 +115,7 @@ VNC_CMAKE_BOOL= WITH_LIBVNCSERVER
WWW_LIB_DEPENDS= libharfbuzz.so:print/harfbuzz \
libsoup-2.4.so:devel/libsoup \
libwebkit2gtk-4.0.so:www/webkit2-gtk3
+
WWW_CMAKE_BOOL= WITH_WEBKIT2GTK
ZSH_RUN_DEPENDS= zsh:shells/zsh