aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2024-06-16 07:34:43 +0000
committerJason E. Hale <jhale@FreeBSD.org>2024-06-16 08:51:27 +0000
commit8c63a3a2d926f49bab4644d60774ec64fc819c99 (patch)
tree9049e355d07e35e80836acc8b761b8827cf55374
parent33f9156c8c33039b761cbad8543a041e0fccbc92 (diff)
downloadports-8c63a3a2d926f49bab4644d60774ec64fc819c99.tar.gz
ports-8c63a3a2d926f49bab4644d60774ec64fc819c99.zip
x11/plasma5-plasma-workspace: QA improvements
Add missing pkg-plist entries after my rushed and pointy-hat-worthy commit 353079b68987. [1] I was under the impression that this version just contained the security fixes and didn't do my due diligence. To sort of make up for it: Add other missing pkg-plist entries if kuserfeedback is installed and add it as a dependency. Potentially improve wayland support by adding plasma-wayland-protocols and wayland-protocols as build dependencies. Add PIPEWIRE option and patch out auto-detection. Enable by default as x11/plasma5-plasma-desktop also enables PIPEWIRE by default. Remove ancient CONFLICTS. PR: 279744 [1] Reported by: jbeich [1] MFH: 2024Q2 (cherry picked from commit c75e3897416092ecd7dd255114dae100734524d7)
-rw-r--r--x11/plasma5-plasma-workspace/Makefile31
-rw-r--r--x11/plasma5-plasma-workspace/files/patch-CMakeLists.txt26
-rw-r--r--x11/plasma5-plasma-workspace/pkg-plist42
3 files changed, 89 insertions, 10 deletions
diff --git a/x11/plasma5-plasma-workspace/Makefile b/x11/plasma5-plasma-workspace/Makefile
index 21100793eeb9..9c5c494a31bb 100644
--- a/x11/plasma5-plasma-workspace/Makefile
+++ b/x11/plasma5-plasma-workspace/Makefile
@@ -1,12 +1,16 @@
PORTNAME= plasma-workspace
DISTVERSION= ${KDE_PLASMA_VERSION}.1
+PORTREVISION= 1
CATEGORIES= x11 kde kde-plasma
MAINTAINER= kde@FreeBSD.org
COMMENT= Plasma5 Plasma workspace
WWW= https://www.kde.org/plasma-desktop
-LIB_DEPENDS= libcln.so:math/cln \
+BUILD_DEPENDS= kio-extras>=23.08.5:devel/kio-extras \
+ wayland-protocols>=1.31:graphics/wayland-protocols
+LIB_DEPENDS= libKUserFeedbackCore.so:deskutils/kuserfeedback \
+ libcln.so:math/cln \
libdbusmenu-qt5.so:devel/libdbusmenu-qt@qt5 \
libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig \
@@ -18,6 +22,7 @@ LIB_DEPENDS= libcln.so:math/cln \
libxcb-util.so:x11/xcb-util
RUN_DEPENDS= ck-launch-session:sysutils/consolekit2 \
iceauth:x11/iceauth \
+ kio-extras>=23.08.5:devel/kio-extras \
xmessage:x11/xmessage \
xrdb:x11/xrdb \
xset:x11/xset \
@@ -35,13 +40,13 @@ USE_KDE= activities activities-stats activitymanagerd archive attica \
coreaddons crash dbusaddons emoticons filemetadata globalaccel \
guiaddons holidays i18n iconthemes idletime init itemmodels \
itemviews jobwidgets js jsembed kcmutils kdeclarative kdesu \
- kio kscreenlocker kwin layer-shell-qt libkscreen \
- libksysguard newstuff notifications notifyconfig package parts \
- people phonon plasma-framework plasma-integration prison pty runner \
- service solid sonnet syntaxhighlighting texteditor textwidgets \
- unitconversion wallet wayland widgetsaddons windowsystem \
- xmlgui xmlrpcclient \
- doctools:build ecm:build \
+ kio kquickcharts kscreenlocker kwin layer-shell-qt libkexiv2 \
+ libkscreen libksysguard newstuff notifications notifyconfig \
+ package parts people phonon plasma-framework plasma-integration \
+ prison pty runner service solid sonnet syntaxhighlighting \
+ texteditor textwidgets unitconversion wallet wayland \
+ widgetsaddons windowsystem xmlgui xmlrpcclient \
+ doctools:build ecm:build plasma-wayland-protocols:build \
breeze-icons:run breeze:run kded:run kquickcharts:run \
milou:run oxygen-icons5:run
USE_QT= concurrent core dbus declarative graphicaleffects gui network \
@@ -56,8 +61,14 @@ CPE_VENDOR= kde
CMAKE_OFF= BUILD_TESTING
-# In 5.15 a file was moved from x11/plasma5-plasma-desktop to x11/plasma5-plasma-workspace:
-CONFLICTS_INSTALL= plasma5-plasma-desktop-5.14.*
+OPTIONS_DEFINE= PIPEWIRE
+OPTIONS_DEFAULT= PIPEWIRE
+
+PIPEWIRE_DESC= Screen capture via PipeWire
+
+PIPEWIRE_LIB_DEPENDS= libpipewire-0.3.so:multimedia/pipewire
+PIPEWIRE_USE= KDE=kpipewire
+PIPEWIRE_CMAKE_OFF= -DDISABLE_PIPEWIRE:BOOL=ON
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
diff --git a/x11/plasma5-plasma-workspace/files/patch-CMakeLists.txt b/x11/plasma5-plasma-workspace/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..aeae194a35f9
--- /dev/null
+++ b/x11/plasma5-plasma-workspace/files/patch-CMakeLists.txt
@@ -0,0 +1,26 @@
+Don't auto-detect PipeWire
+
+--- CMakeLists.txt.orig 2024-05-31 12:34:07 UTC
++++ CMakeLists.txt
+@@ -47,7 +47,9 @@ find_package(KDED CONFIG REQUIRED)
+ OPTIONAL_COMPONENTS DocTools)
+
+ find_package(KDED CONFIG REQUIRED)
+-find_package(KPipeWire CONFIG)
++if(NOT DISABLE_PIPEWIRE)
++ find_package(KPipeWire CONFIG)
++endif()
+
+ find_package(KF5NetworkManagerQt ${KF5_MIN_VERSION})
+ set_package_properties(KF5NetworkManagerQt PROPERTIES DESCRIPTION "Qt wrapper for NetworkManager API"
+@@ -152,7 +154,9 @@ endif()
+ set(HAVE_XFIXES 0)
+ endif()
+
+-pkg_check_modules(PipeWire IMPORTED_TARGET libpipewire-0.3)
++if(NOT DISABLE_PIPEWIRE)
++ pkg_check_modules(PipeWire IMPORTED_TARGET libpipewire-0.3)
++endif()
+ add_feature_info(PipeWire PipeWire_FOUND "Required for Wayland screencasting")
+
+ if(PipeWire_FOUND)
diff --git a/x11/plasma5-plasma-workspace/pkg-plist b/x11/plasma5-plasma-workspace/pkg-plist
index 89abd277d6c0..d850766dc5a8 100644
--- a/x11/plasma5-plasma-workspace/pkg-plist
+++ b/x11/plasma5-plasma-workspace/pkg-plist
@@ -210,6 +210,7 @@ lib/libweather_ion.so.7.0.0
%%QT_PLUGINDIR%%/plasma/kcms/systemsettings/kcm_colors.so
%%QT_PLUGINDIR%%/plasma/kcms/systemsettings/kcm_cursortheme.so
%%QT_PLUGINDIR%%/plasma/kcms/systemsettings/kcm_desktoptheme.so
+%%QT_PLUGINDIR%%/plasma/kcms/systemsettings/kcm_feedback.so
%%QT_PLUGINDIR%%/plasma/kcms/systemsettings/kcm_fonts.so
%%QT_PLUGINDIR%%/plasma/kcms/systemsettings/kcm_icons.so
%%QT_PLUGINDIR%%/plasma/kcms/systemsettings/kcm_lookandfeel.so
@@ -284,6 +285,7 @@ lib/systemd/user/plasma-xembedsniproxy.service
share/applications/kcm_autostart.desktop
share/applications/kcm_colors.desktop
share/applications/kcm_cursortheme.desktop
+share/applications/kcm_feedback.desktop
share/applications/kcm_fontinst.desktop
share/applications/kcm_fonts.desktop
share/applications/kcm_icons.desktop
@@ -301,6 +303,7 @@ share/applications/org.kde.plasmawindowed.desktop
share/applications/org.kde.systemmonitor.desktop
share/config.kcfg/colorssettings.kcfg
share/config.kcfg/cursorthemesettings.kcfg
+share/config.kcfg/feedbacksettings.kcfg
share/config.kcfg/fontssettings.kcfg
share/config.kcfg/freespacenotifier.kcfg
share/config.kcfg/iconssettingsbase.kcfg
@@ -504,6 +507,8 @@ share/doc/HTML/es/kcontrol/screenlocker/index.cache.bz2
share/doc/HTML/es/kcontrol/screenlocker/index.docbook
share/doc/HTML/es/klipper/index.cache.bz2
share/doc/HTML/es/klipper/index.docbook
+share/doc/HTML/fr/kcontrol/desktopthemedetails/index.cache.bz2
+share/doc/HTML/fr/kcontrol/desktopthemedetails/index.docbook
share/doc/HTML/fr/kcontrol/fontinst/index.cache.bz2
share/doc/HTML/fr/kcontrol/fontinst/index.docbook
share/doc/HTML/id/kcontrol/autostart/index.cache.bz2
@@ -832,6 +837,7 @@ share/kpackage/kcms/kcm_cursortheme/contents/ui/main.qml
share/kpackage/kcms/kcm_desktoptheme/contents/ui/Hand.qml
share/kpackage/kcms/kcm_desktoptheme/contents/ui/ThemePreview.qml
share/kpackage/kcms/kcm_desktoptheme/contents/ui/main.qml
+share/kpackage/kcms/kcm_feedback/contents/ui/main.qml
share/kpackage/kcms/kcm_fonts/contents/ui/FontWidget.qml
share/kpackage/kcms/kcm_fonts/contents/ui/main.qml
share/kpackage/kcms/kcm_icons/contents/ui/IconSizePopup.qml
@@ -1922,29 +1928,62 @@ share/locale/eo/LC_MESSAGES/kcm_autostart.mo
share/locale/eo/LC_MESSAGES/kcm_colors.mo
share/locale/eo/LC_MESSAGES/kcm_cursortheme.mo
share/locale/eo/LC_MESSAGES/kcm_desktoptheme.mo
+share/locale/eo/LC_MESSAGES/kcm_feedback.mo
share/locale/eo/LC_MESSAGES/kcm_fonts.mo
share/locale/eo/LC_MESSAGES/kcm_icons.mo
+share/locale/eo/LC_MESSAGES/kcm_lookandfeel.mo
+share/locale/eo/LC_MESSAGES/kcm_nightcolor.mo
+share/locale/eo/LC_MESSAGES/kcm_notifications.mo
+share/locale/eo/LC_MESSAGES/kcm_regionandlang.mo
share/locale/eo/LC_MESSAGES/kcm_style.mo
+share/locale/eo/LC_MESSAGES/kcm_users.mo
share/locale/eo/LC_MESSAGES/kcminit.mo
share/locale/eo/LC_MESSAGES/kfontinst.mo
+share/locale/eo/LC_MESSAGES/kholidays_calendar_plugin.mo
share/locale/eo/LC_MESSAGES/kio5_applications.mo
+share/locale/eo/LC_MESSAGES/kio_desktop.mo
share/locale/eo/LC_MESSAGES/klipper.mo
share/locale/eo/LC_MESSAGES/krdb.mo
+share/locale/eo/LC_MESSAGES/krunner.mo
share/locale/eo/LC_MESSAGES/ksmserver.mo
+share/locale/eo/LC_MESSAGES/libkicker.mo
share/locale/eo/LC_MESSAGES/libkworkspace.mo
+share/locale/eo/LC_MESSAGES/libnotificationmanager.mo
share/locale/eo/LC_MESSAGES/phonon_kde_plugin.mo
+share/locale/eo/LC_MESSAGES/plasma_applet_org.kde.plasma.activitybar.mo
share/locale/eo/LC_MESSAGES/plasma_applet_org.kde.plasma.analogclock.mo
+share/locale/eo/LC_MESSAGES/plasma_applet_org.kde.plasma.appmenu.mo
share/locale/eo/LC_MESSAGES/plasma_applet_org.kde.plasma.battery.mo
+share/locale/eo/LC_MESSAGES/plasma_applet_org.kde.plasma.calendar.mo
+share/locale/eo/LC_MESSAGES/plasma_applet_org.kde.plasma.clipboard.mo
share/locale/eo/LC_MESSAGES/plasma_applet_org.kde.plasma.devicenotifier.mo
+share/locale/eo/LC_MESSAGES/plasma_applet_org.kde.plasma.digitalclock.mo
+share/locale/eo/LC_MESSAGES/plasma_applet_org.kde.plasma.icon.mo
share/locale/eo/LC_MESSAGES/plasma_applet_org.kde.plasma.lock_logout.mo
+share/locale/eo/LC_MESSAGES/plasma_applet_org.kde.plasma.manageinputmethod.mo
+share/locale/eo/LC_MESSAGES/plasma_applet_org.kde.plasma.mediacontroller.mo
share/locale/eo/LC_MESSAGES/plasma_applet_org.kde.plasma.notifications.mo
+share/locale/eo/LC_MESSAGES/plasma_applet_org.kde.plasma.panelspacer.mo
+share/locale/eo/LC_MESSAGES/plasma_applet_org.kde.plasma.private.systemtray.mo
+share/locale/eo/LC_MESSAGES/plasma_applet_org.kde.plasma.systemmonitor.mo
+share/locale/eo/LC_MESSAGES/plasma_containmentactions_applauncher.mo
share/locale/eo/LC_MESSAGES/plasma_containmentactions_contextmenu.mo
share/locale/eo/LC_MESSAGES/plasma_containmentactions_switchwindow.mo
share/locale/eo/LC_MESSAGES/plasma_engine_applicationjobs.mo
+share/locale/eo/LC_MESSAGES/plasma_engine_devicenotifications.mo
+share/locale/eo/LC_MESSAGES/plasma_engine_dict.mo
+share/locale/eo/LC_MESSAGES/plasma_engine_hotplug.mo
share/locale/eo/LC_MESSAGES/plasma_engine_keystate.mo
+share/locale/eo/LC_MESSAGES/plasma_engine_mpris2.mo
share/locale/eo/LC_MESSAGES/plasma_engine_notifications.mo
+share/locale/eo/LC_MESSAGES/plasma_engine_powermanagement.mo
share/locale/eo/LC_MESSAGES/plasma_engine_soliddevice.mo
+share/locale/eo/LC_MESSAGES/plasma_engine_time.mo
share/locale/eo/LC_MESSAGES/plasma_engine_weather.mo
+share/locale/eo/LC_MESSAGES/plasma_lookandfeel_org.kde.lookandfeel.mo
+share/locale/eo/LC_MESSAGES/plasma_package_plasmashell.mo
+share/locale/eo/LC_MESSAGES/plasma_runner_appstream.mo
+share/locale/eo/LC_MESSAGES/plasma_runner_baloosearch5.mo
share/locale/eo/LC_MESSAGES/plasma_runner_bookmarksrunner.mo
share/locale/eo/LC_MESSAGES/plasma_runner_calculatorrunner.mo
share/locale/eo/LC_MESSAGES/plasma_runner_kill.mo
@@ -1957,7 +1996,10 @@ share/locale/eo/LC_MESSAGES/plasma_runner_sessions.mo
share/locale/eo/LC_MESSAGES/plasma_runner_shell.mo
share/locale/eo/LC_MESSAGES/plasma_runner_webshortcuts.mo
share/locale/eo/LC_MESSAGES/plasma_runner_windowedwidgets.mo
+share/locale/eo/LC_MESSAGES/plasma_wallpaper_org.kde.color.mo
share/locale/eo/LC_MESSAGES/plasma_wallpaper_org.kde.image.mo
+share/locale/eo/LC_MESSAGES/plasmashell.mo
+share/locale/eo/LC_MESSAGES/plasmashellprivateplugin.mo
share/locale/eo/LC_MESSAGES/soliduiserver5.mo
share/locale/es/LC_MESSAGES/freespacenotifier.mo
share/locale/es/LC_MESSAGES/kcm_autostart.mo