aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-12 17:44:13 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-12 17:44:41 +0000
commit8cb8c44ed01337de2e381f9ded3be94088421110 (patch)
tree6b12da5f3d06a40832ac3fb541b702ee59232407
parentc5d0ff512f8e440b2e6deceb76b7c7423af05145 (diff)
downloadports-8cb8c44ed01337de2e381f9ded3be94088421110.tar.gz
ports-8cb8c44ed01337de2e381f9ded3be94088421110.zip
devel/concurrentqueue: New port: Fast C++11 multi-producer multi-consumer lock-free concurrent queue
-rw-r--r--devel/Makefile1
-rw-r--r--devel/concurrentqueue/Makefile20
-rw-r--r--devel/concurrentqueue/distinfo3
-rw-r--r--devel/concurrentqueue/pkg-descr3
-rw-r--r--devel/concurrentqueue/pkg-plist7
5 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c6fb7a4aa4cd..aff682d58cbc 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -387,6 +387,7 @@
SUBDIR += compiz-bcop
SUBDIR += concurrencpp
SUBDIR += concurrencykit
+ SUBDIR += concurrentqueue
SUBDIR += configkit
SUBDIR += cons
SUBDIR += cons-test
diff --git a/devel/concurrentqueue/Makefile b/devel/concurrentqueue/Makefile
new file mode 100644
index 000000000000..46fb48336daf
--- /dev/null
+++ b/devel/concurrentqueue/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= concurrentqueue
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.3-15
+DISTVERSIONSUFFIX= -g0753496
+CATEGORIES= devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Fast C++11 multi-producer multi-consumer lock-free concurrent queue
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+USES= cmake compiler:c++11-lang
+
+USE_GITHUB= yes
+GH_ACCOUNT= cameron314
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/concurrentqueue/distinfo b/devel/concurrentqueue/distinfo
new file mode 100644
index 000000000000..0c4c20a1577b
--- /dev/null
+++ b/devel/concurrentqueue/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1631468244
+SHA256 (cameron314-concurrentqueue-v1.0.3-15-g0753496_GH0.tar.gz) = 442da9bced11046a23654c6356253603ba064001b99b021ae0c0b3e5a3b8746c
+SIZE (cameron314-concurrentqueue-v1.0.3-15-g0753496_GH0.tar.gz) = 1565255
diff --git a/devel/concurrentqueue/pkg-descr b/devel/concurrentqueue/pkg-descr
new file mode 100644
index 000000000000..228cf118e14e
--- /dev/null
+++ b/devel/concurrentqueue/pkg-descr
@@ -0,0 +1,3 @@
+concurrentqueue is an industrial-strength lock-free queue for C++.
+
+WWW: https://github.com/cameron314/concurrentqueue
diff --git a/devel/concurrentqueue/pkg-plist b/devel/concurrentqueue/pkg-plist
new file mode 100644
index 000000000000..7be81b61a83e
--- /dev/null
+++ b/devel/concurrentqueue/pkg-plist
@@ -0,0 +1,7 @@
+include/concurrentqueue/moodycamel/LICENSE.md
+include/concurrentqueue/moodycamel/blockingconcurrentqueue.h
+include/concurrentqueue/moodycamel/concurrentqueue.h
+include/concurrentqueue/moodycamel/lightweightsemaphore.h
+lib/cmake/concurrentqueue/concurrentqueueConfig.cmake
+lib/cmake/concurrentqueue/concurrentqueueConfigVersion.cmake
+lib/cmake/concurrentqueue/concurrentqueueTargets.cmake