aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-09-04 03:47:19 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-09-04 03:47:19 +0000
commit8cccb3bc0af570216a5aa36a14f487e2f52bd72a (patch)
tree27f9cbb56fd8d943878aeb31fc3b4f9877f9b6fa
parent00dd9064b5abfa8bf15dd4a2f5e702c2ef288f07 (diff)
downloadports-8cccb3bc0af570216a5aa36a14f487e2f52bd72a.tar.gz
ports-8cccb3bc0af570216a5aa36a14f487e2f52bd72a.zip
www/py-planet: Update to 1.5.2
- Change RUN_DEPENDS from py-requests-futures to py-requests-futures0 Changes: https://github.com/planetlabs/planet-client-python/releases
-rw-r--r--www/py-planet/Makefile4
-rw-r--r--www/py-planet/distinfo6
-rw-r--r--www/py-planet/files/patch-planet-api-dispatch.py11
3 files changed, 5 insertions, 16 deletions
diff --git a/www/py-planet/Makefile b/www/py-planet/Makefile
index 9d7f249451c8..be06bb19826e 100644
--- a/www/py-planet/Makefile
+++ b/www/py-planet/Makefile
@@ -1,5 +1,5 @@
PORTNAME= planet
-PORTVERSION= 1.5.1
+PORTVERSION= 1.5.2
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=0:devel/py-click@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}requests-futures>=0:www/py-requests-futures@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}requests-futures0>=0<1.0:www/py-requests-futures0@${PY_FLAVOR}
USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
diff --git a/www/py-planet/distinfo b/www/py-planet/distinfo
index 450c389b2603..2b65845830b9 100644
--- a/www/py-planet/distinfo
+++ b/www/py-planet/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1659161207
-SHA256 (planet-1.5.1.tar.gz) = cf2aaf1aaac006d9dffd875cfa4a3b4873c0b92b2d29fb74ab943833d96b0f77
-SIZE (planet-1.5.1.tar.gz) = 88807
+TIMESTAMP = 1662212196
+SHA256 (planet-1.5.2.tar.gz) = 44991e49da8c5ea95760dc3f18f0533870540a76c598e1194a55a16fdbf2d42c
+SIZE (planet-1.5.2.tar.gz) = 88951
diff --git a/www/py-planet/files/patch-planet-api-dispatch.py b/www/py-planet/files/patch-planet-api-dispatch.py
deleted file mode 100644
index c6d078c26a02..000000000000
--- a/www/py-planet/files/patch-planet-api-dispatch.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- planet/api/dispatch.py.orig 2020-01-13 22:11:38 UTC
-+++ planet/api/dispatch.py
-@@ -149,7 +149,7 @@ class RequestsDispatcher(object):
-
- def _dispatch_async(self, request, callback):
- return _do_request(self._asyncpool, request, stream=True,
-- background_callback=callback)
-+ hooks=callback)
-
- def _dispatch(self, request, callback=None):
- return _do_request(self.session, request)