aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:45:36 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:21:05 +0000
commit8cd3dfbee2977b6dd4396720b7e8f7fba61ce741 (patch)
treea7c1962ed9e405889f4019591a04564f8e5e43a9
parentb5b72385ccd12905a23c3b44811906476df650ea (diff)
downloadports-8cd3dfbee2977b6dd4396720b7e8f7fba61ce741.tar.gz
ports-8cd3dfbee2977b6dd4396720b7e8f7fba61ce741.zip
devel/py-twine: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for dependency and package change
-rw-r--r--devel/py-twine/Makefile10
-rw-r--r--devel/py-twine/files/setup.py3
2 files changed, 5 insertions, 8 deletions
diff --git a/devel/py-twine/Makefile b/devel/py-twine/Makefile
index 454ef8fe1678..fb6f928b612c 100644
--- a/devel/py-twine/Makefile
+++ b/devel/py-twine/Makefile
@@ -1,5 +1,6 @@
PORTNAME= twine
PORTVERSION= 4.0.2
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,7 +12,9 @@ WWW= https://github.com/pypa/twine
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=1.15:devel/py-setuptools_scm@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=45:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=6.0:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=3.6:devel/py-importlib-metadata@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}keyring>=15.1,1:security/py-keyring@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pkginfo>=1.8.1:sysutils/py-pkginfo@${PY_FLAVOR} \
@@ -23,11 +26,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=3.6:devel/py-importlib-m
${PYTHON_PKGNAMEPREFIX}urllib3>=1.26.0,1:net/py-urllib3@${PY_FLAVOR}
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
-post-patch:
- @${CP} ${FILESDIR}/setup.py ${WRKSRC}/
-
.include <bsd.port.mk>
diff --git a/devel/py-twine/files/setup.py b/devel/py-twine/files/setup.py
deleted file mode 100644
index 606849326a40..000000000000
--- a/devel/py-twine/files/setup.py
+++ /dev/null
@@ -1,3 +0,0 @@
-from setuptools import setup
-
-setup()