aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-08-25 09:22:18 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-08-25 09:22:25 +0000
commit8ce6ae76ffd5cd8d32bd81b09f8b7a8340cf07ee (patch)
tree7f204a940ce714037313feefc945d11df7830753
parent19313c122e1f5ad8339cb9a432704d5bc30866b2 (diff)
downloadports-8ce6ae76ffd5cd8d32bd81b09f8b7a8340cf07ee.tar.gz
ports-8ce6ae76ffd5cd8d32bd81b09f8b7a8340cf07ee.zip
graphics/zint: update Zint Barcode Generator to version 2.10.0.
-rw-r--r--graphics/zint/Makefile10
-rw-r--r--graphics/zint/distinfo6
-rw-r--r--graphics/zint/files/patch-CMakeLists.txt8
-rw-r--r--graphics/zint/files/patch-backend_CMakeLists.txt12
-rw-r--r--graphics/zint/files/patch-backend__qt_qzint.cpp10
-rw-r--r--graphics/zint/pkg-plist8
6 files changed, 18 insertions, 36 deletions
diff --git a/graphics/zint/Makefile b/graphics/zint/Makefile
index 03b8d3c2a8bf..d8c83f45d5ea 100644
--- a/graphics/zint/Makefile
+++ b/graphics/zint/Makefile
@@ -1,9 +1,10 @@
# Created by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
PORTNAME= zint
-PORTVERSION= 2.9.0
+PORTVERSION= 2.10.0
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= danfe@FreeBSD.org
COMMENT= Zint Barcode Generator
@@ -15,10 +16,13 @@ LIB_DEPENDS= libpng.so:graphics/png
USES= cmake compiler:c++11-lang qt:5
USE_LDCONFIG= yes
-USE_QT= buildtools_build qmake_build uitools_build core gui widgets
+USE_QT= buildtools_build qmake_build uitools_build core gui \
+ widgets xml
DESKTOP_ENTRIES="Zint" "Barcode generator" "" "zint-qt" "" false
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.src
+post-patch:
+ @${REINPLACE_CMD} -e '/^add_library/s,STATIC,SHARED,' \
+ ${WRKSRC}/backend_qt/CMakeLists.txt
.include <bsd.port.mk>
diff --git a/graphics/zint/distinfo b/graphics/zint/distinfo
index 910ade386905..d32fe6d386e7 100644
--- a/graphics/zint/distinfo
+++ b/graphics/zint/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1596187506
-SHA256 (zint-2.9.0.tar.gz) = fa02fa637f1cecb242bcc751f02710cda4026d41f8f60e0c60a8884525e56fea
-SIZE (zint-2.9.0.tar.gz) = 1954642
+TIMESTAMP = 1628952058
+SHA256 (zint-2.10.0-src.tar.gz) = bb97e98a32e140c344e92c8da84a9df413dca16083f2fcdc29791bec77350339
+SIZE (zint-2.10.0-src.tar.gz) = 2850363
diff --git a/graphics/zint/files/patch-CMakeLists.txt b/graphics/zint/files/patch-CMakeLists.txt
index d351088ff8c4..66ac0863a06d 100644
--- a/graphics/zint/files/patch-CMakeLists.txt
+++ b/graphics/zint/files/patch-CMakeLists.txt
@@ -4,12 +4,12 @@
ADD_CUSTOM_TARGET(uninstall
"${CMAKE_COMMAND}" -P "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake")
--# staniek: don't install
--if (DATA_INSTALL_DIR)
+-# staniek: don't install
+-if(DATA_INSTALL_DIR)
- set(CMAKE_MODULES_INSTALL_PATH ${DATA_INSTALL_DIR}/cmake/modules)
--else (DATA_INSTALL_DIR)
+-else()
- set(CMAKE_MODULES_INSTALL_PATH ${CMAKE_ROOT}/Modules)
--endif(DATA_INSTALL_DIR)
+-endif()
+set(CMAKE_MODULES_INSTALL_PATH ${CMAKE_ROOT}/Modules)
install(FILES cmake/modules/FindZint.cmake DESTINATION ${CMAKE_MODULES_INSTALL_PATH} COMPONENT Devel)
diff --git a/graphics/zint/files/patch-backend_CMakeLists.txt b/graphics/zint/files/patch-backend_CMakeLists.txt
deleted file mode 100644
index 438a1991163b..000000000000
--- a/graphics/zint/files/patch-backend_CMakeLists.txt
+++ /dev/null
@@ -1,12 +0,0 @@
---- backend/CMakeLists.txt.orig 2018-02-15 10:47:59 UTC
-+++ backend/CMakeLists.txt
-@@ -2,7 +2,8 @@
-
- project(zint)
-
--find_package(PNG)
-+find_package(PNG REQUIRED)
-+include_directories(${PNG_INCLUDE_DIR})
-
- set(zint_COMMON_SRCS common.c library.c render.c large.c reedsol.c gs1.c eci.c)
- set(zint_ONEDIM_SRCS code.c code128.c 2of5.c upcean.c telepen.c medical.c plessey.c rss.c)
diff --git a/graphics/zint/files/patch-backend__qt_qzint.cpp b/graphics/zint/files/patch-backend__qt_qzint.cpp
deleted file mode 100644
index 943134c40425..000000000000
--- a/graphics/zint/files/patch-backend__qt_qzint.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- backend_qt/qzint.cpp.orig 2020-05-21 11:07:30 UTC
-+++ backend_qt/qzint.cpp
-@@ -17,6 +17,7 @@
-
- #include <math.h>
- #include <QFontMetrics>
-+#include <QPainterPath>
-
- namespace Zint {
-
diff --git a/graphics/zint/pkg-plist b/graphics/zint/pkg-plist
index 47f790e97209..989ee0508283 100644
--- a/graphics/zint/pkg-plist
+++ b/graphics/zint/pkg-plist
@@ -3,9 +3,9 @@ bin/zint-qt
include/qzint.h
include/zint.h
lib/libQZint.so
-lib/libQZint.so.2.9
-lib/libQZint.so.2.9.0
+lib/libQZint.so.2.10
+lib/libQZint.so.2.10.0.0
lib/libzint.so
-lib/libzint.so.2.9
-lib/libzint.so.2.9.0
+lib/libzint.so.2.10
+lib/libzint.so.2.10.0.0
share/cmake/Modules/FindZint.cmake