aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-04-24 10:44:24 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-04-27 19:07:31 +0000
commit8d37e75b116c0edd59c34f07ed7c40944f8e2be9 (patch)
treef997df593856abb1e7f63ae207f3bd16fe80ab2f
parentb46d53b6cedd133f4caa018e76a161e686ff5858 (diff)
downloadports-8d37e75b116c0edd59c34f07ed7c40944f8e2be9.tar.gz
ports-8d37e75b116c0edd59c34f07ed7c40944f8e2be9.zip
graphics/tiled: update to 1.6.0
-rw-r--r--graphics/tiled/Makefile11
-rw-r--r--graphics/tiled/distinfo6
-rw-r--r--graphics/tiled/files/patch-src_tiled_main.cpp46
-rw-r--r--graphics/tiled/files/patch-src_tiled_tiled.pro11
-rw-r--r--graphics/tiled/pkg-plist1
5 files changed, 68 insertions, 7 deletions
diff --git a/graphics/tiled/Makefile b/graphics/tiled/Makefile
index af561ae2d04e..6ffefa282a54 100644
--- a/graphics/tiled/Makefile
+++ b/graphics/tiled/Makefile
@@ -1,5 +1,5 @@
PORTNAME= tiled
-PORTVERSION= 1.5.0
+PORTVERSION= 1.6.0
DISTVERSIONPREFIX= v
CATEGORIES= graphics editors games
@@ -17,21 +17,24 @@ GH_ACCOUNT= bjorn
USES= compiler:c++14-lang desktop-file-utils gl qmake qt:5 \
shared-mime-info xorg
USE_QT= core gui widgets opengl network declarative \
- buildtools_build linguisttools_build
+ buildtools_build linguisttools_build dbus
USE_GL= gl
USE_LDCONFIG= yes
QMAKE_ARGS= SYSTEM_ZSTD=yes
PORTDOCS= *
-OPTIONS_DEFINE= PYTHON DOCS
-OPTIONS_DEFAULT=PYTHON
+OPTIONS_DEFINE= PYTHON DBUS DOCS
+OPTIONS_DEFAULT=PYTHON DBUS
OPTIONS_SUB= yes
PYTHON_DESC= Enable python plugin
PYTHON_USES= pkgconfig python:3.6+
PYTHON_QMAKE_OFF= DISABLE_PYTHON_PLUGIN=yes
+DBUS_USE= QT=dbus
+DBUS_QMAKE_OFF= DISABLE_DBUS=yes
+
post-patch-PYTHON-on:
@${REINPLACE_CMD} -e 's|python3|python-${PYTHON_VER}|' \
${WRKSRC}/src/plugins/python/find_python.pri
diff --git a/graphics/tiled/distinfo b/graphics/tiled/distinfo
index 1e78b487ea1e..78cf71c31c38 100644
--- a/graphics/tiled/distinfo
+++ b/graphics/tiled/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1616878149
-SHA256 (bjorn-tiled-v1.5.0_GH0.tar.gz) = 9fa9b5818a35469bf61e51f77096c8c1ec02207cc97831b9402d3f6d13b207a0
-SIZE (bjorn-tiled-v1.5.0_GH0.tar.gz) = 16694406
+TIMESTAMP = 1619258429
+SHA256 (bjorn-tiled-v1.6.0_GH0.tar.gz) = c8bc2cd8f48c9085ac391cf17e351eccae9bed95b0a726f62d3a77f1fddba6ae
+SIZE (bjorn-tiled-v1.6.0_GH0.tar.gz) = 16730026
diff --git a/graphics/tiled/files/patch-src_tiled_main.cpp b/graphics/tiled/files/patch-src_tiled_main.cpp
new file mode 100644
index 000000000000..9bcc5fa8e2d6
--- /dev/null
+++ b/graphics/tiled/files/patch-src_tiled_main.cpp
@@ -0,0 +1,46 @@
+--- src/tiled/main.cpp.orig 2021-04-23 13:13:21 UTC
++++ src/tiled/main.cpp
+@@ -66,10 +66,6 @@ static QTextStream& stdOut()
+ return ts;
+ }
+
+-#if QT_VERSION >= QT_VERSION_CHECK(5,14,0)
+-using Qt::endl;
+-#endif
+-
+ namespace {
+
+ class CommandLineHandler : public CommandLineParser
+@@ -260,7 +256,7 @@ void CommandLineHandler::showVersion()
+ if (!showedVersion) {
+ showedVersion = true;
+ stdOut() << QApplication::applicationDisplayName() << " "
+- << QApplication::applicationVersion() << endl;
++ << QApplication::applicationVersion() << Qt::endl;
+ quit = true;
+ }
+ }
+@@ -317,9 +313,9 @@ void CommandLineHandler::showExportFormats()
+ }
+ formats.sort(Qt::CaseSensitive);
+
+- stdOut() << tr("Map export formats:") << endl;
++ stdOut() << tr("Map export formats:") << Qt::endl;
+ for (const QString &name : formats)
+- stdOut() << " " << name << endl;
++ stdOut() << " " << name << Qt::endl;
+
+ formats.clear();
+ const auto tilesetFormats = PluginManager::objects<TilesetFormat>();
+@@ -329,9 +325,9 @@ void CommandLineHandler::showExportFormats()
+ }
+ formats.sort(Qt::CaseSensitive);
+
+- stdOut() << tr("Tileset export formats:") << endl;
++ stdOut() << tr("Tileset export formats:") << Qt::endl;
+ for (const QString &name : formats)
+- stdOut() << " " << name << endl;
++ stdOut() << " " << name << Qt::endl;
+
+ quit = true;
+ }
diff --git a/graphics/tiled/files/patch-src_tiled_tiled.pro b/graphics/tiled/files/patch-src_tiled_tiled.pro
new file mode 100644
index 000000000000..7bc3803b84bf
--- /dev/null
+++ b/graphics/tiled/files/patch-src_tiled_tiled.pro
@@ -0,0 +1,11 @@
+--- src/tiled/tiled.pro.orig 2021-04-23 13:13:21 UTC
++++ src/tiled/tiled.pro
+@@ -19,7 +19,7 @@ contains(QT_CONFIG, opengl):minQtVersion(6, 0, 0) {
+ QT += openglwidgets
+ }
+
+-contains(QT_CONFIG, dbus) {
++!contains(DISABLE_DBUS, yes):contains(QT_CONFIG, dbus) {
+ QT += dbus
+ DEFINES += TILED_ENABLE_DBUS
+ }
diff --git a/graphics/tiled/pkg-plist b/graphics/tiled/pkg-plist
index 9da0cdeb04b6..e67c3b8f7454 100644
--- a/graphics/tiled/pkg-plist
+++ b/graphics/tiled/pkg-plist
@@ -53,6 +53,7 @@ share/thumbnailers/tiled.thumbnailer
%%DATADIR%%/translations/tiled_pt_PT.qm
%%DATADIR%%/translations/tiled_ru.qm
%%DATADIR%%/translations/tiled_sv.qm
+%%DATADIR%%/translations/tiled_th.qm
%%DATADIR%%/translations/tiled_tr.qm
%%DATADIR%%/translations/tiled_uk.qm
%%DATADIR%%/translations/tiled_zh_CN.qm