aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-16 20:49:24 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-16 23:47:13 +0000
commit8d41276e20f55d9f059378bca799881574b1bc50 (patch)
treec9d0ecd123f2b6b65d7375996911b20e72546052
parent97efbe298b4985f21bc76c612f8ae2cf9415b6a5 (diff)
downloadports-8d41276e20f55d9f059378bca799881574b1bc50.tar.gz
ports-8d41276e20f55d9f059378bca799881574b1bc50.zip
science/yoda: Fix tests
Add test dependencies and correct test environment.
-rw-r--r--science/yoda/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/science/yoda/Makefile b/science/yoda/Makefile
index 87d8cdfe8fd5..b10f75d136f2 100644
--- a/science/yoda/Makefile
+++ b/science/yoda/Makefile
@@ -11,7 +11,9 @@ COMMENT= Particle physics package with classes for data analysis, histogramming
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-TEST_DEPENDS= bash:shells/bash
+TEST_DEPENDS= bash:shells/bash \
+ ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR}
USES= compiler:c++11-lang gmake libtool python:test shebangfix
GNU_CONFIGURE= yes
@@ -27,12 +29,14 @@ OPTIONS_DEFINE= PYTHON
OPTIONS_DEFAULT= PYTHON
OPTIONS_SUB= yes
-PYTHON_USES= python shebangfix
+PYTHON_USES= python
PYTHON_USE= PYTHON=cython
PYTHON_CONFIGURE_ENABLE= pyext
PYTHON_MAKE_ENV= PYTHON_VERSION=${PYTHON_VER} PYTHON=${PYTHON_CMD}
PYTHON_VARS= SHEBANG_FILES="bin/${PORTNAME}* bin/aida2yoda bin/aida2flat bin/flat2yoda"
+TEST_ENV= ${MAKE_ENV} PATH=${STAGEDIR}${PREFIX}/bin:${PATH} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libYODA.so