aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-11-20 05:53:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-11-20 06:22:40 +0000
commit8e7be7293a75482272f879c8fec824ab689fac39 (patch)
tree2ae89f920d67769648cf0ded9f153f85f82badd9
parentd428258ccc80e28ae4a044347a9d13d5da5ff629 (diff)
downloadports-8e7be7293a75482272f879c8fec824ab689fac39.tar.gz
ports-8e7be7293a75482272f879c8fec824ab689fac39.zip
cad/libgdsii: New port: C++ library and command-line utility for reading GDSII geometry files
-rw-r--r--cad/Makefile1
-rw-r--r--cad/libgdsii/Makefile26
-rw-r--r--cad/libgdsii/distinfo3
-rw-r--r--cad/libgdsii/pkg-descr3
4 files changed, 33 insertions, 0 deletions
diff --git a/cad/Makefile b/cad/Makefile
index 0305f495969e..c618a23996d1 100644
--- a/cad/Makefile
+++ b/cad/Makefile
@@ -71,6 +71,7 @@
SUBDIR += ldview
SUBDIR += leocad
SUBDIR += lepton-eda
+ SUBDIR += libgdsii
SUBDIR += libopencad
SUBDIR += librecad
SUBDIR += libredwg
diff --git a/cad/libgdsii/Makefile b/cad/libgdsii/Makefile
new file mode 100644
index 000000000000..aee60b1704a8
--- /dev/null
+++ b/cad/libgdsii/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= libgdsii
+DISTVERSION= 0.21
+CATEGORIES= cad
+MASTER_SITES= https://github.com/HomerReid/libGDSII/releases/download/v${DISTVERSION}/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ library and command-line utility for reading GDSII geometry files
+WWW= https://github.com/HomerReid/libGDSII
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= autoreconf gmake libtool
+USE_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/GDSIIConvert \
+ include/libGDSII.h \
+ lib/libGDSII.a \
+ lib/libGDSII.so \
+ lib/libGDSII.so.0 \
+ lib/libGDSII.so.0.0.0 \
+ share/libGDSII/examples/bend-flux/bend-flux.gds
+
+.include <bsd.port.mk>
diff --git a/cad/libgdsii/distinfo b/cad/libgdsii/distinfo
new file mode 100644
index 000000000000..f028cdb63d16
--- /dev/null
+++ b/cad/libgdsii/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1668922879
+SHA256 (libgdsii-0.21.tar.gz) = 31c90a4fb699746d051c0c597ef0543889c9f17b2a711fed398756ac4f1b1f4c
+SIZE (libgdsii-0.21.tar.gz) = 410747
diff --git a/cad/libgdsii/pkg-descr b/cad/libgdsii/pkg-descr
new file mode 100644
index 000000000000..6866136cf6c9
--- /dev/null
+++ b/cad/libgdsii/pkg-descr
@@ -0,0 +1,3 @@
+libGDSII is a C++ library for working with GDSII binary data files, intended
+primarily for use with the computational electromagnetism codes scuff-em and
+meep but sufficiently general-purpose to allow other uses as well.