aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-18 17:46:54 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-18 17:46:54 +0000
commit8e9b9448c5eafab3bb43eef2d3b8d0d6421bfea6 (patch)
treee8fceb54646ee6bc3c39d151f91a9d35e682d801
parentd3fc725e0b6787537db404b6f1d145445106b847 (diff)
downloadports-8e9b9448c5eafab3bb43eef2d3b8d0d6421bfea6.tar.gz
ports-8e9b9448c5eafab3bb43eef2d3b8d0d6421bfea6.zip
security/py-google-auth-oauthlib: Add py-google-auth-oauthlib 0.4.4
google-auth-oauthlib provides oauthlib integration with google-auth. WWW: https://github.com/googleapis/google-auth-library-python-oauthlib
-rw-r--r--security/Makefile1
-rw-r--r--security/py-google-auth-oauthlib/Makefile23
-rw-r--r--security/py-google-auth-oauthlib/distinfo3
-rw-r--r--security/py-google-auth-oauthlib/files/patch-setup.py11
-rw-r--r--security/py-google-auth-oauthlib/pkg-descr3
5 files changed, 41 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 3fdc3fded2dd..fd9ea92c64d7 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -905,6 +905,7 @@
SUBDIR += py-gnutls
SUBDIR += py-google-auth
SUBDIR += py-google-auth-httplib2
+ SUBDIR += py-google-auth-oauthlib
SUBDIR += py-gpgme
SUBDIR += py-gpsoauth
SUBDIR += py-gssapi
diff --git a/security/py-google-auth-oauthlib/Makefile b/security/py-google-auth-oauthlib/Makefile
new file mode 100644
index 000000000000..4b2f13931a80
--- /dev/null
+++ b/security/py-google-auth-oauthlib/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= google-auth-oauthlib
+PORTVERSION= 0.4.4
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Google Authentication Library
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}google-auth>=1.0.0:security/py-google-auth@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests-oauthlib>=0:www/py-requests-oauthlib@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-google-auth-oauthlib/distinfo b/security/py-google-auth-oauthlib/distinfo
new file mode 100644
index 000000000000..e464068a45c6
--- /dev/null
+++ b/security/py-google-auth-oauthlib/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1626542060
+SHA256 (google-auth-oauthlib-0.4.4.tar.gz) = 09832c6e75032f93818edf1affe4746121d640c625a5bef9b5c96af676e98eee
+SIZE (google-auth-oauthlib-0.4.4.tar.gz) = 19453
diff --git a/security/py-google-auth-oauthlib/files/patch-setup.py b/security/py-google-auth-oauthlib/files/patch-setup.py
new file mode 100644
index 000000000000..01ad4bc30bdd
--- /dev/null
+++ b/security/py-google-auth-oauthlib/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2021-03-29 20:04:36 UTC
++++ setup.py
+@@ -20,7 +20,7 @@ from setuptools import setup
+
+ TOOL_DEPENDENCIES = "click>=6.0.0"
+
+-DEPENDENCIES = ("google-auth>=1.0.0", "requests-oauthlib>=0.7.0")
++DEPENDENCIES = ("google-auth>=1.0.0", "requests-oauthlib>=0")
+
+
+ with io.open("README.rst", "r") as fh:
diff --git a/security/py-google-auth-oauthlib/pkg-descr b/security/py-google-auth-oauthlib/pkg-descr
new file mode 100644
index 000000000000..e496ac4d3035
--- /dev/null
+++ b/security/py-google-auth-oauthlib/pkg-descr
@@ -0,0 +1,3 @@
+google-auth-oauthlib provides oauthlib integration with google-auth.
+
+WWW: https://github.com/googleapis/google-auth-library-python-oauthlib