aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 14:12:48 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 15:06:05 +0000
commit8eb920e429a0d5f88bcbce0e9d1007a00fdb3b2c (patch)
tree17919c33ba6e695a0a16458ff7cf943ec042a446
parented17a9032d94a5abd4e97bae56256d105cb04291 (diff)
downloadports-8eb920e429a0d5f88bcbce0e9d1007a00fdb3b2c.tar.gz
ports-8eb920e429a0d5f88bcbce0e9d1007a00fdb3b2c.zip
devel/py-hatch-mypyc: Add py-hatch-mypyc 0.16.0
hatch-mypyc provides a build hook plugin for Hatch that compiles code with Mypyc.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-hatch-mypyc/Makefile26
-rw-r--r--devel/py-hatch-mypyc/distinfo3
-rw-r--r--devel/py-hatch-mypyc/pkg-descr2
4 files changed, 32 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 539631acdd3a..9744db7ea3b3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4802,6 +4802,7 @@
SUBDIR += py-hatch-autorun
SUBDIR += py-hatch-fancy-pypi-readme
SUBDIR += py-hatch-jupyter-builder
+ SUBDIR += py-hatch-mypyc
SUBDIR += py-hatch-nodejs-version
SUBDIR += py-hatch-requirements-txt
SUBDIR += py-hatch-semver
diff --git a/devel/py-hatch-mypyc/Makefile b/devel/py-hatch-mypyc/Makefile
new file mode 100644
index 000000000000..0ac9900d5f4c
--- /dev/null
+++ b/devel/py-hatch-mypyc/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= hatch-mypyc
+PORTVERSION= 0.16.0
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= hatch_mypyc-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Hatch build hook plugin for Mypyc
+WWW= https://github.com/ofek/hatch-mypyc
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=1.12.2:devel/py-hatchling@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=1.12.2:devel/py-hatchling@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mypy>=0.971:devel/py-mypy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pathspec>=0:devel/py-pathspec@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-hatch-mypyc/distinfo b/devel/py-hatch-mypyc/distinfo
new file mode 100644
index 000000000000..98a3cb0e5276
--- /dev/null
+++ b/devel/py-hatch-mypyc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1708448820
+SHA256 (hatch_mypyc-0.16.0.tar.gz) = 6e3aa99634d81142cab993358698eaae823de91fe87ee85029a82f2e737c3ded
+SIZE (hatch_mypyc-0.16.0.tar.gz) = 12851
diff --git a/devel/py-hatch-mypyc/pkg-descr b/devel/py-hatch-mypyc/pkg-descr
new file mode 100644
index 000000000000..b29cea2e6219
--- /dev/null
+++ b/devel/py-hatch-mypyc/pkg-descr
@@ -0,0 +1,2 @@
+hatch-mypyc provides a build hook plugin for Hatch that compiles code with
+Mypyc.