aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2022-07-03 12:48:43 +0000
committerThierry Thomas <thierry@FreeBSD.org>2022-07-03 12:48:43 +0000
commit8ebe2acebff6ba16c07cc5b5d15c9edfbd0376b6 (patch)
tree4c1e5be01f499a275ba47ad609c7f5ee6266ec61
parent7df62bd196659b39be130723af0a1bb51068b671 (diff)
downloadports-8ebe2acebff6ba16c07cc5b5d15c9edfbd0376b6.tar.gz
ports-8ebe2acebff6ba16c07cc5b5d15c9edfbd0376b6.zip
science/paraview: unbreak after the upgrade of science/netcdf
d1e81465471ca5a4976e6119991aa464ea03788b broke Paraview: chase this upgrade. Obtained from: https://bugs.debian.org/1012663 by Bas Couwenberg
-rw-r--r--science/paraview/Makefile1
-rw-r--r--science/paraview/files/patch-VTK_ThirdParty_exodusII_vtkexodusII_src_ex__utils.c16
2 files changed, 17 insertions, 0 deletions
diff --git a/science/paraview/Makefile b/science/paraview/Makefile
index d420e8945b62..41e3ad65e3ed 100644
--- a/science/paraview/Makefile
+++ b/science/paraview/Makefile
@@ -2,6 +2,7 @@
PORTNAME= paraview
DISTVERSION= 5.10.1
+PORTREVISION= 1
CATEGORIES= science graphics
MASTER_SITES= http://www.paraview.org/files/v${VERMAJORMINOR}/
DISTNAME= ParaView-v${PORTVERSION}
diff --git a/science/paraview/files/patch-VTK_ThirdParty_exodusII_vtkexodusII_src_ex__utils.c b/science/paraview/files/patch-VTK_ThirdParty_exodusII_vtkexodusII_src_ex__utils.c
new file mode 100644
index 000000000000..06985d1ffa22
--- /dev/null
+++ b/science/paraview/files/patch-VTK_ThirdParty_exodusII_vtkexodusII_src_ex__utils.c
@@ -0,0 +1,16 @@
+--- VTK/ThirdParty/exodusII/vtkexodusII/src/ex_utils.c.orig 2022-03-11 22:19:30 UTC
++++ VTK/ThirdParty/exodusII/vtkexodusII/src/ex_utils.c
+@@ -1770,11 +1770,11 @@ void ex__compress_variable(int exoid, int varid, int t
+ */
+
+ /* const int NC_SZIP_EC = 4; */ /* Selects entropy coding method for szip. */
+- const int NC_SZIP_NN = 32; /* Selects nearest neighbor coding method for szip. */
++ const int NC_SZIP_NN_ = 32; /* Selects nearest neighbor coding method for szip. */
+ /* Even and between 4 and 32; typical values are 8, 10, 16, 32 */
+ const int SZIP_PIXELS_PER_BLOCK =
+ file->compression_level == 0 ? 32 : file->compression_level;
+- nc_def_var_szip(exoid, varid, NC_SZIP_NN, SZIP_PIXELS_PER_BLOCK);
++ nc_def_var_szip(exoid, varid, NC_SZIP_NN_, SZIP_PIXELS_PER_BLOCK);
+ #else
+ char errmsg[MAX_ERR_LENGTH];
+ snprintf(errmsg, MAX_ERR_LENGTH,