aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-03-08 17:21:58 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-03-11 08:34:45 +0000
commit8ede8da5f192ec5f79b5b26094d11e6a66ff0c5b (patch)
treeb5afd6e494287bdcd089ea83348553465dfed60f
parent3ed981826623f4a1b656ad625fd746c0e8d23c4c (diff)
downloadports-8ede8da5f192ec5f79b5b26094d11e6a66ff0c5b.tar.gz
ports-8ede8da5f192ec5f79b5b26094d11e6a66ff0c5b.zip
biology/ncbi-entrez-direct: fix build on riscv64
Bump golang.org/x/sys dependency to a version new enough to build on riscv64-freebsd. Sponsored by: Berliner Linux User Group e.V. Approved by: portmgr (build fix blanket) Differential Revision: https://reviews.freebsd.org/D38996
-rw-r--r--biology/ncbi-entrez-direct/Makefile4
-rw-r--r--biology/ncbi-entrez-direct/distinfo6
-rw-r--r--biology/ncbi-entrez-direct/files/modules.txt15
-rw-r--r--biology/ncbi-entrez-direct/files/patch-cmd_go.mod29
-rw-r--r--biology/ncbi-entrez-direct/files/patch-cmd_go.sum15
5 files changed, 60 insertions, 9 deletions
diff --git a/biology/ncbi-entrez-direct/Makefile b/biology/ncbi-entrez-direct/Makefile
index a85be9b5c1ab..ddd55ca12cb9 100644
--- a/biology/ncbi-entrez-direct/Makefile
+++ b/biology/ncbi-entrez-direct/Makefile
@@ -1,6 +1,6 @@
PORTNAME= ncbi-entrez-direct
DISTVERSION= 14.9.20210423
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= biology perl5
MASTER_SITES= ftp://ftp.ncbi.nlm.nih.gov/entrez/entrezdirect/versions/${PORTVERSION}/
DISTFILES= edirect.tar.gz
@@ -40,7 +40,7 @@ GH_TUPLE= fatih:color:v1.10.0:a/${GHSD}/fatih/color \
mattn:go-isatty:v0.0.12:g/${GHSD}/mattn/go-isatty \
fiam:gounidecode:8deddbd03fec:h/${GHSD}/fiam/gounidecode \
golang:text:v0.3.5:i/${GLSD}/x/text \
- golang:sys:d5e6a3e2c0ae:j/${GLSD}/x/sys
+ golang:sys:v0.5.0:j/${GLSD}/x/sys
SHEBANG_FILES= nquire edirect.pl word-at-a-time accn-at-a-time \
amino-acid-composition between-two-genes exclude-uid-lists \
diff --git a/biology/ncbi-entrez-direct/distinfo b/biology/ncbi-entrez-direct/distinfo
index e959f316b0e8..563875c07842 100644
--- a/biology/ncbi-entrez-direct/distinfo
+++ b/biology/ncbi-entrez-direct/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1619443745
+TIMESTAMP = 1678294976
SHA256 (edirect-14.9.20210423/edirect.tar.gz) = 9d6534226164fc5dfae7abcf25bfdbd08db068b27f1c13b8a3c4681cda5b0cea
SIZE (edirect-14.9.20210423/edirect.tar.gz) = 829737
SHA256 (edirect-14.9.20210423/fatih-color-v1.10.0_GH0.tar.gz) = a00342a7ffb8b119346dce56e152a111cbb9eab3970c429cc2ed4272aec2858e
@@ -19,5 +19,5 @@ SHA256 (edirect-14.9.20210423/fiam-gounidecode-8deddbd03fec_GH0.tar.gz) = b763f4
SIZE (edirect-14.9.20210423/fiam-gounidecode-8deddbd03fec_GH0.tar.gz) = 190666
SHA256 (edirect-14.9.20210423/golang-text-v0.3.5_GH0.tar.gz) = f85d1185ba116cd40ef8cf702fe1d960ed41d039c08fd314dbeb5866f3166f27
SIZE (edirect-14.9.20210423/golang-text-v0.3.5_GH0.tar.gz) = 8348127
-SHA256 (edirect-14.9.20210423/golang-sys-d5e6a3e2c0ae_GH0.tar.gz) = 6cd44aa33cb0fc4caedadde44b3a943bece0aa67d803c00bfb09b03222845f19
-SIZE (edirect-14.9.20210423/golang-sys-d5e6a3e2c0ae_GH0.tar.gz) = 1539001
+SHA256 (edirect-14.9.20210423/golang-sys-v0.5.0_GH0.tar.gz) = 810c8f1b7704674971ab6b2b614aba20a5a1765018fd2c639f528dbbcbf88b1f
+SIZE (edirect-14.9.20210423/golang-sys-v0.5.0_GH0.tar.gz) = 1429723
diff --git a/biology/ncbi-entrez-direct/files/modules.txt b/biology/ncbi-entrez-direct/files/modules.txt
index bf713fd9c42b..77a6af417917 100644
--- a/biology/ncbi-entrez-direct/files/modules.txt
+++ b/biology/ncbi-entrez-direct/files/modules.txt
@@ -1,32 +1,39 @@
# eutils v0.0.0-00010101000000-000000000000 => ../eutils
-## explicit
+## explicit; go 1.15
eutils
# github.com/fatih/color v1.10.0
-## explicit
+## explicit; go 1.13
github.com/fatih/color
# github.com/fiam/gounidecode v0.0.0-20150629112515-8deddbd03fec
## explicit
github.com/fiam/gounidecode/unidecode
# github.com/gedex/inflector v0.0.0-20170307190818-16278e9db813
+## explicit
github.com/gedex/inflector
# github.com/klauspost/cpuid v1.3.1
+## explicit; go 1.12
github.com/klauspost/cpuid
# github.com/mattn/go-colorable v0.1.8
+## explicit; go 1.13
github.com/mattn/go-colorable
# github.com/mattn/go-isatty v0.0.12
+## explicit; go 1.12
github.com/mattn/go-isatty
# github.com/pbnjay/memory v0.0.0-20201129165224-b12e5d931931
+## explicit
github.com/pbnjay/memory
# github.com/stretchr/testify v1.7.0
-## explicit
+## explicit; go 1.13
# github.com/surge/glog v0.0.0-20141108051140-2578deb2b95c
## explicit
# github.com/surgebase/porter2 v0.0.0-20150829210152-56e4718818e8
## explicit
github.com/surgebase/porter2
-# golang.org/x/sys v0.0.0-20200223170610-d5e6a3e2c0ae
+# golang.org/x/sys v0.5.0
+## explicit; go 1.17
golang.org/x/sys/unix
# golang.org/x/text v0.3.5
+## explicit; go 1.11
golang.org/x/text/runes
golang.org/x/text/transform
golang.org/x/text/unicode/norm
diff --git a/biology/ncbi-entrez-direct/files/patch-cmd_go.mod b/biology/ncbi-entrez-direct/files/patch-cmd_go.mod
new file mode 100644
index 000000000000..84d5b957c08e
--- /dev/null
+++ b/biology/ncbi-entrez-direct/files/patch-cmd_go.mod
@@ -0,0 +1,29 @@
+--- cmd/go.mod.orig 2023-03-08 17:07:24 UTC
++++ cmd/go.mod
+@@ -1,6 +1,6 @@
+ module edirect
+
+-go 1.15
++go 1.17
+
+ replace eutils => ../eutils
+
+@@ -8,7 +8,17 @@ require (
+ eutils v0.0.0-00010101000000-000000000000
+ github.com/fatih/color v1.10.0
+ github.com/fiam/gounidecode v0.0.0-20150629112515-8deddbd03fec
++ github.com/surgebase/porter2 v0.0.0-20150829210152-56e4718818e8
++)
++
++require (
++ github.com/gedex/inflector v0.0.0-20170307190818-16278e9db813 // indirect
++ github.com/klauspost/cpuid v1.3.1 // indirect
++ github.com/mattn/go-colorable v0.1.8 // indirect
++ github.com/mattn/go-isatty v0.0.12 // indirect
++ github.com/pbnjay/memory v0.0.0-20201129165224-b12e5d931931 // indirect
+ github.com/stretchr/testify v1.7.0 // indirect
+ github.com/surge/glog v0.0.0-20141108051140-2578deb2b95c // indirect
+- github.com/surgebase/porter2 v0.0.0-20150829210152-56e4718818e8
++ golang.org/x/sys v0.5.0 // indirect
++ golang.org/x/text v0.3.5 // indirect
+ )
diff --git a/biology/ncbi-entrez-direct/files/patch-cmd_go.sum b/biology/ncbi-entrez-direct/files/patch-cmd_go.sum
new file mode 100644
index 000000000000..6b3d64b34b93
--- /dev/null
+++ b/biology/ncbi-entrez-direct/files/patch-cmd_go.sum
@@ -0,0 +1,15 @@
+--- cmd/go.sum.orig 2023-03-08 17:10:13 UTC
++++ cmd/go.sum
+@@ -26,10 +26,11 @@ github.com/surgebase/porter2 v0.0.0-20150829210152-56e
+ golang.org/x/sys v0.0.0-20200116001909-b77594299b42/go.mod h1:h1NjWce9XRLGQEsW7wpKNCjG9DtNlClVuFLEZdDNbEs=
+ golang.org/x/sys v0.0.0-20200223170610-d5e6a3e2c0ae h1:/WDfKMnPU+m5M4xB+6x4kaepxRw6jWvR5iDRdvjHgy8=
+ golang.org/x/sys v0.0.0-20200223170610-d5e6a3e2c0ae/go.mod h1:h1NjWce9XRLGQEsW7wpKNCjG9DtNlClVuFLEZdDNbEs=
++golang.org/x/sys v0.5.0 h1:MUK/U/4lj1t1oPg0HfuXDN/Z1wv31ZJ/YcPiGccS4DU=
++golang.org/x/sys v0.5.0/go.mod h1:oPkhp1MJrh7nUepCBck5+mAzfO9JrbApNNgaTdGDITg=
+ golang.org/x/text v0.3.5 h1:i6eZZ+zk0SOf0xgBpEpPD18qWcJda6q1sxt3S0kzyUQ=
+ golang.org/x/text v0.3.5/go.mod h1:5Zoc/QRtKVWzQhOtBMvqHzDpF6irO9z98xDceosuGiQ=
+ golang.org/x/tools v0.0.0-20180917221912-90fa682c2a6e/go.mod h1:n7NCudcB/nEzxVGmLbDWY5pfWTLqBcC2KZ6jyYvM4mQ=
+-gopkg.in/check.v1 v0.0.0-20161208181325-20d25e280405 h1:yhCVgyC4o1eVCa2tZl7eS0r+SDo693bJlVdllGtEeKM=
+ gopkg.in/check.v1 v0.0.0-20161208181325-20d25e280405/go.mod h1:Co6ibVJAznAaIkqp8huTwlJQCZ016jof/cbN4VW5Yz0=
+ gopkg.in/yaml.v3 v3.0.0-20200313102051-9f266ea9e77c h1:dUUwHk2QECo/6vqA44rthZ8ie2QXMNeKRTHCNY2nXvo=
+ gopkg.in/yaml.v3 v3.0.0-20200313102051-9f266ea9e77c/go.mod h1:K4uyk7z7BCEPqu6E+C64Yfv1cQ7kz7rIZviUmN+EgEM=