aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-09 13:44:30 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-09 14:05:16 +0000
commit8f49288172b4c76b13d11f6da336e72d755ad62c (patch)
tree56c6e2ebb8a91a64ce7c2e0e036be26d11c39fb8
parentf946b683c3b5fa84b9b9ada7a97dc06ce02188f0 (diff)
downloadports-8f49288172b4c76b13d11f6da336e72d755ad62c.tar.gz
ports-8f49288172b4c76b13d11f6da336e72d755ad62c.zip
www/py-dj42-django-treebeard: Add py-dj42-django-treebeard 4.7.1 (copied from py-django-treebeard)
django-treebeard is a library that implements efficient tree implementations for the Django Web Framework 1.8 and later. Features: - Flexible: Includes 3 different tree implementations with the same API: * Adjacency List * Materialized Path * Nested Sets - Fast: Optimized non-naive tree operations - Easy: Uses Django Model Inheritance with abstract classes to define your own models. - Clean: Testable and well tested code base. Code/branch test coverage is above 96%.
-rw-r--r--www/Makefile1
-rw-r--r--www/py-dj42-django-treebeard/Makefile37
-rw-r--r--www/py-dj42-django-treebeard/distinfo3
-rw-r--r--www/py-dj42-django-treebeard/pkg-descr14
4 files changed, 55 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 3d230de775fe..4e5fbc0d4bd3 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1518,6 +1518,7 @@
SUBDIR += py-dj42-django-tables2
SUBDIR += py-dj42-django-taggit
SUBDIR += py-dj42-django-timezone-field
+ SUBDIR += py-dj42-django-treebeard
SUBDIR += py-dj42-djangoql
SUBDIR += py-dj42-djangorestframework
SUBDIR += py-dj42-djangorestframework-guardian
diff --git a/www/py-dj42-django-treebeard/Makefile b/www/py-dj42-django-treebeard/Makefile
new file mode 100644
index 000000000000..9a3f7334f35f
--- /dev/null
+++ b/www/py-dj42-django-treebeard/Makefile
@@ -0,0 +1,37 @@
+PORTNAME= django-treebeard
+DISTVERSION= 4.7.1
+CATEGORIES= www python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}dj42-
+
+MAINTAINER= kai@FreeBSD.org
+COMMENT= Efficient tree implementations for Django
+WWW= https://github.com/django-treebeard/django-treebeard
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django42>=3.2:www/py-django42@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-django>=4.0:devel/py-pytest-django@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils pytest
+
+TEST_ENV= DATABASE_ENGINE=sqlite
+
+NO_ARCH= yes
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS
+DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django42>=2.2:www/py-django42@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}graphviz>0:graphics/py-graphviz@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sphinx>=0,1:textproc/py-sphinx@${PY_FLAVOR}
+DOCS_VARS= PYDISTUTILS_BUILD_TARGET+="build_sphinx -a -E"
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @(cd ${WRKSRC}/build/sphinx/html && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} \
+ "! -name .buildinfo -and ! -name objects.inv")
+
+.include <bsd.port.mk>
diff --git a/www/py-dj42-django-treebeard/distinfo b/www/py-dj42-django-treebeard/distinfo
new file mode 100644
index 000000000000..56310b6db66c
--- /dev/null
+++ b/www/py-dj42-django-treebeard/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1706970935
+SHA256 (django-treebeard-4.7.1.tar.gz) = 846e462904b437155f76e04907ba4e48480716855f88b898df4122bdcfbd6e98
+SIZE (django-treebeard-4.7.1.tar.gz) = 294139
diff --git a/www/py-dj42-django-treebeard/pkg-descr b/www/py-dj42-django-treebeard/pkg-descr
new file mode 100644
index 000000000000..1529d6d19b22
--- /dev/null
+++ b/www/py-dj42-django-treebeard/pkg-descr
@@ -0,0 +1,14 @@
+django-treebeard is a library that implements efficient tree implementations for
+the Django Web Framework 1.8 and later.
+
+Features:
+
+- Flexible: Includes 3 different tree implementations with the same API:
+ * Adjacency List
+ * Materialized Path
+ * Nested Sets
+- Fast: Optimized non-naive tree operations
+- Easy: Uses Django Model Inheritance with abstract classes to define your own
+ models.
+- Clean: Testable and well tested code base. Code/branch test coverage is
+ above 96%.