aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-01-29 20:53:06 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-01-29 22:25:54 +0000
commit8f80d6dde15c23f550d7f2201299c04e49d91ecc (patch)
treefbd15880c3d452a177d4c54c203224c6d244dd48
parent80c694a0f6b98d77c4ac1a1770dc4ec69fe3aa1b (diff)
downloadports-8f80d6dde15c23f550d7f2201299c04e49d91ecc.tar.gz
ports-8f80d6dde15c23f550d7f2201299c04e49d91ecc.zip
Mk/bsd.port.mk: Sunset MANPREFIX
For historical reasons FreeBSD had been using PREFIX/man to install man pages and a variable MANPREFIX was utilized to do this. While the rest of the UNIX/Linux world had been mostly using PREFIX/share. As the first step of moving to PREFIX/share/man this commit removes all the references to the MANPREFIX variable. Apart from MAKE_ARGS this variable no longer exists and should not be used to refer to PREFIX anymore in the future. The entire shift to PREFIX/share/man will take some more times as there are around 4000 ports which installs man page to PREFIX/man. PR: 276551 Approved by: portmgr (exp-run)
-rw-r--r--Mk/bsd.port.mk17
1 files changed, 4 insertions, 13 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index f9eb4aebcb6a..0f0aa8c2c392 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -501,9 +501,6 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# Installs all directories and files from ${WRKSRC}/doc
# to ${DOCSDIR} except sed(1) backup files.
#
-# MANPREFIX - The directory prefix for manual pages.
-# Default: ${PREFIX}
-#
# Set the following to specify all .info files your port installs.
#
# INFO - A list of .info files (omitting the trailing ".info");
@@ -752,7 +749,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# - Pass these args to configure if ${HAS_CONFIGURE} is set.
# Default: "--prefix=${GNU_CONFIGURE_PREFIX}
# --infodir=${PREFIX}/${INFO_PATH} --localstatedir=/var
-# --mandir=${MANPREFIX}/man --build=${CONFIGURE_TARGET}" if
+# --mandir=${PREFIX}/man --build=${CONFIGURE_TARGET}" if
# GNU_CONFIGURE is set, "CC=${CC} CFLAGS=${CFLAGS}
# PREFIX=${PREFIX} INSTALLPRIVLIB=${PREFIX}/lib
# INSTALLARCHLIB=${PREFIX}/lib" if USES=perl5 and
@@ -2028,8 +2025,7 @@ MAKE_ENV+= PREFIX=${PREFIX} \
CC="${CC}" CFLAGS="${CFLAGS}" \
CPP="${CPP}" CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}" LIBS="${LIBS}" \
- CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
- MANPREFIX="${MANPREFIX}"
+ CXX="${CXX}" CXXFLAGS="${CXXFLAGS}"
# Add -fno-strict-aliasing to CFLAGS with optimization level -O2 or higher.
# gcc 4.x enable strict aliasing optimization with -O2 which is known to break
@@ -2701,7 +2697,7 @@ CONFIGURE_MAX_CMD_LEN!= ${SYSCTL} -n kern.argmax
. endif
_EXPORTED_VARS+= CONFIGURE_MAX_CMD_LEN
GNU_CONFIGURE_PREFIX?= ${PREFIX}
-GNU_CONFIGURE_MANPREFIX?= ${MANPREFIX}
+GNU_CONFIGURE_MANPREFIX?= ${PREFIX}
CONFIGURE_ARGS+= --prefix=${GNU_CONFIGURE_PREFIX} $${_LATE_CONFIGURE_ARGS}
. if defined(CROSS_TOOLCHAIN)
CROSS_HOST= ${ARCH:S/amd64/x86_64/}-unknown-${OPSYS:tl}${OSREL}
@@ -2745,14 +2741,9 @@ SCRIPTS_ENV+= CURDIR=${MASTERDIR} DISTDIR=${DISTDIR} \
SCRIPTS_ENV+= BATCH=yes
. endif
-. if ${PREFIX} == /usr
-MANPREFIX?= /usr/share
-. else
-MANPREFIX?= ${PREFIX}
MANDIRS+= ${PREFIX}/share/man
-. endif
-MANDIRS+= ${MANPREFIX}/man
+MANDIRS+= ${PREFIX}/man
INFO_PATH?= share/info
. if defined(INFO)