aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-29 16:13:57 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-29 16:13:57 +0000
commit8fb26126cd4d0390d33aeb5c7c3c4010eafc0640 (patch)
tree971bc1446d3f88cd4a917a06c220ac56eac8e453
parentd4e146d4a97fad1354a8edae315cb2b47975d261 (diff)
downloadports-8fb26126cd4d0390d33aeb5c7c3c4010eafc0640.tar.gz
ports-8fb26126cd4d0390d33aeb5c7c3c4010eafc0640.zip
devel/py-gcsfs: Add GCSFUSE and CRC options
-rw-r--r--devel/py-gcsfs/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/devel/py-gcsfs/Makefile b/devel/py-gcsfs/Makefile
index ccd18459ab60..be6227481af9 100644
--- a/devel/py-gcsfs/Makefile
+++ b/devel/py-gcsfs/Makefile
@@ -25,4 +25,11 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
+OPTIONS_DEFINE= GCSFUSE CRC
+GCSFUSE_DESC= Fuse support
+CRC_DESC= CRC support
+
+GCSFUSE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}crcmod>=0:devel/py-crcmod@${PY_FLAVOR}
+CRC_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}fusepy>=0:devel/py-fusepy@${PY_FLAVOR}
+
.include <bsd.port.mk>