aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Hurling <rhurlin@FreeBSD.org>2022-10-15 07:20:16 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2022-10-15 07:24:30 +0000
commit90089ea6aab07f7687607ed0413be5d74833df8a (patch)
tree19d89666fcd4571b4d3cbc1a86b6002f7b5213ff
parent9b8cd91058a02a7a76e1bf72d727918be73e681d (diff)
downloadports-90089ea6aab07f7687607ed0413be5d74833df8a.tar.gz
ports-90089ea6aab07f7687607ed0413be5d74833df8a.zip
textproc/py-python-lsp-server: Add missing dep
Add missing run dependency textproc/py-whatthepatch as wanted by pyproject.toml. PR: 267066 MFH: 2022Q4 (cherry picked from commit 309c70a92b7ef846ea361c53fe290a37c91893d5)
-rw-r--r--textproc/py-python-lsp-server/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/textproc/py-python-lsp-server/Makefile b/textproc/py-python-lsp-server/Makefile
index f6e6aecf5de6..b11e997f3ccf 100644
--- a/textproc/py-python-lsp-server/Makefile
+++ b/textproc/py-python-lsp-server/Makefile
@@ -1,6 +1,6 @@
PORTNAME= python-lsp-server
PORTVERSION= 1.5.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -28,6 +28,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}autopep8>0:textproc/py-autopep8@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}python-lsp-jsonrpc>0:textproc/py-python-lsp-jsonrpc@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}rope>0:devel/py-rope@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ujson>0:devel/py-ujson@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}whatthepatch>0:textproc/py-whatthepatch@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yapf>0:textproc/py-yapf@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>=0:devel/py-coverage@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}flaky>=3.4.0:devel/py-flaky@${PY_FLAVOR} \
@@ -41,7 +42,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>=0:devel/py-coverage@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}yapf>0:textproc/py-yapf@${PY_FLAVOR} \
${PYNUMPY}
-# make test: 3 failed, 134 passed, 9 skipped, 18 warnings
+# make test: 4 failed, 133 passed, 9 skipped, 18 warnings
# mainly because of py-numpy>=1.23.0 ...
USES= python:3.7+ pytest
USE_PYTHON= autoplist concurrent distutils