aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2023-10-17 00:06:37 +0000
committerJason E. Hale <jhale@FreeBSD.org>2023-10-17 00:14:15 +0000
commit90b6cf74484bcd5a922d85210f71b1bc4c849b0c (patch)
tree73ca9ff1e24bf19d03576ca42c823ba555f70d9c
parentf09facfac88b87236eafbb55cee898874e4e3fd6 (diff)
downloadports-90b6cf74484bcd5a922d85210f71b1bc4c849b0c.tar.gz
ports-90b6cf74484bcd5a922d85210f71b1bc4c849b0c.zip
devel/cmake-core: Fix build with non-base SSL
This is a just a hotfix to keep things building, but more investigation is certaintly warranted. PR: 274512 Reported by: Dean E. Weimer <dweimer@dweimer.net>
-rw-r--r--devel/cmake-core/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/devel/cmake-core/Makefile b/devel/cmake-core/Makefile
index 0e5f63ee4bdf..6a2304277993 100644
--- a/devel/cmake-core/Makefile
+++ b/devel/cmake-core/Makefile
@@ -39,6 +39,10 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
--parallel=${MAKE_JOBS_NUMBER} \
--init="${WRKSRC}/InitialCache.cmake"
+# Quick fix to enable build with non-base SSL (PR: 274512)
+CFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
+
OPTIONS_DEFINE= DOCS CPACK
OPTIONS_DEFAULT= CPACK
OPTIONS_SUB= yes