aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2022-06-14 13:39:49 +0000
committerDima Panov <fluffy@FreeBSD.org>2022-06-14 13:39:49 +0000
commit9105f6edb2964fd253737a70a63cf7c4a146732e (patch)
treeb7eb4028c4986a8e224fb99017de4d5490623a95
parenta5fcdcb5e51f4fd8031cf4dc7ece55e15bbbac1a (diff)
downloadports-9105f6edb2964fd253737a70a63cf7c4a146732e.tar.gz
ports-9105f6edb2964fd253737a70a63cf7c4a146732e.zip
graphics/gegl: update to 0.4.36 release
-rw-r--r--graphics/gegl/Makefile13
-rw-r--r--graphics/gegl/distinfo6
-rw-r--r--graphics/gegl/files/patch-gegl_opencl_cl_platform_h13
-rw-r--r--graphics/gegl/files/patch-operations_external_png-load_c15
-rw-r--r--graphics/gegl/files/patch-operations_external_tiff-load_c15
-rw-r--r--graphics/gegl/pkg-plist15
6 files changed, 71 insertions, 6 deletions
diff --git a/graphics/gegl/Makefile b/graphics/gegl/Makefile
index 3d7680e4e8fb..e678b899ab72 100644
--- a/graphics/gegl/Makefile
+++ b/graphics/gegl/Makefile
@@ -1,8 +1,7 @@
# Created by: Pietro Cerutti <gahr@FreeBSD.org>
PORTNAME= gegl
-PORTVERSION= 0.4.34
-PORTREVISION= 5
+PORTVERSION= 0.4.36
CATEGORIES= graphics
MASTER_SITES= GIMP
@@ -35,7 +34,7 @@ MESON_ARGS= -Ddocs=false \
-Dpygobject=disabled \
-Dlua=disabled
-GEGL_SHLIB= 0.433.1
+GEGL_SHLIB= 0.435.1
GEGL_VER= 0.4
PLIST_SUB+= GEGL_SHLIB=${GEGL_SHLIB} GEGL_VER=${GEGL_VER}
@@ -132,6 +131,14 @@ PLIST_SUB+= PANGOCAIRO="@comment "
LDFLAGS+= -lexecinfo
.endif
+.if ${ARCH} == "amd64"
+PLIST_SUB+= AMD64="" AARCH64="@comment "
+.elif ${ARCH} == "aarch64"
+PLIST_SUB+= AMD64="@comment " AARCH64=""
+.else
+PLIST_SUB+= AMD64="@comment " AARCH64="@comment "
+.endif
+
post-patch:
.if ${CHOSEN_COMPILER_TYPE} == clang
${REINPLACE_CMD} -e '/altivec.h/d' ${WRKSRC}/gegl/opencl/cl_platform.h
diff --git a/graphics/gegl/distinfo b/graphics/gegl/distinfo
index 2a786c59220b..b68a93a0f27f 100644
--- a/graphics/gegl/distinfo
+++ b/graphics/gegl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1640768817
-SHA256 (gegl-0.4.34.tar.xz) = ef63f0bca5b431c6119addd834ca7fbb507c900c4861c57b3667b6f4ccfcaaaa
-SIZE (gegl-0.4.34.tar.xz) = 5647516
+TIMESTAMP = 1655194019
+SHA256 (gegl-0.4.36.tar.xz) = 6fd58a0cdcc7702258adaeffb573a389228ae8f0eff47578efda2309b61b2ca6
+SIZE (gegl-0.4.36.tar.xz) = 5680876
diff --git a/graphics/gegl/files/patch-gegl_opencl_cl_platform_h b/graphics/gegl/files/patch-gegl_opencl_cl_platform_h
new file mode 100644
index 000000000000..824a5565a3d8
--- /dev/null
+++ b/graphics/gegl/files/patch-gegl_opencl_cl_platform_h
@@ -0,0 +1,13 @@
+Don't include altivec.h as this break the build on powerpc64.
+
+Index: gegl/opencl/cl_platform.h
+--- gegl/opencl/cl_platform.h.orig
++++ gegl/opencl/cl_platform.h
+@@ -270,7 +270,6 @@ typedef unsigned int cl_GLenum;
+
+ /* Define basic vector types */
+ #if defined( __VEC__ )
+- #include <altivec.h> /* may be omitted depending on compiler. AltiVec spec provides no way to detect whether the header is required. */
+ typedef vector unsigned char __cl_uchar16;
+ typedef vector signed char __cl_char16;
+ typedef vector unsigned short __cl_ushort8;
diff --git a/graphics/gegl/files/patch-operations_external_png-load_c b/graphics/gegl/files/patch-operations_external_png-load_c
new file mode 100644
index 000000000000..9dbbc15e1362
--- /dev/null
+++ b/graphics/gegl/files/patch-operations_external_png-load_c
@@ -0,0 +1,15 @@
+../gegl-0.4.30/operations/external/png-load.c:85:9: warning:
+implicit declaration of function 'strptime' is invalid in C99 [-Wimplicit-function-declaration]
+
+Index: operations/external/png-load.c
+--- operations/external/png-load.c.orig
++++ operations/external/png-load.c
+@@ -20,7 +20,7 @@
+
+ #include "config.h"
+ #ifdef HAVE_STRPTIME
+-#define _XOPEN_SOURCE
++#define _XOPEN_SOURCE 700
+ #include <time.h>
+ #endif
+ #include <glib/gi18n-lib.h>
diff --git a/graphics/gegl/files/patch-operations_external_tiff-load_c b/graphics/gegl/files/patch-operations_external_tiff-load_c
new file mode 100644
index 000000000000..26c2caa40cdd
--- /dev/null
+++ b/graphics/gegl/files/patch-operations_external_tiff-load_c
@@ -0,0 +1,15 @@
+../gegl-0.4.30/operations/external/tiff-load.c:99:9: warning:
+implicit declaration of function 'strptime' is invalid in C99
+
+Index: operations/external/tiff-load.c
+--- operations/external/tiff-load.c.orig
++++ operations/external/tiff-load.c
+@@ -18,7 +18,7 @@
+
+ #include "config.h"
+ #ifdef HAVE_STRPTIME
+-#define _XOPEN_SOURCE
++#define _XOPEN_SOURCE 700
+ #include <time.h>
+ #endif
+ #include <glib/gi18n-lib.h>
diff --git a/graphics/gegl/pkg-plist b/graphics/gegl/pkg-plist
index 2088a99839ad..816b3bf3b88e 100644
--- a/graphics/gegl/pkg-plist
+++ b/graphics/gegl/pkg-plist
@@ -89,10 +89,25 @@ include/gegl-%%GEGL_VER%%/sc/sc-sample.h
%%FFMPEG%%lib/gegl-%%GEGL_VER%%/ff-save.so
lib/gegl-%%GEGL_VER%%/dropshadow2.json
lib/gegl-%%GEGL_VER%%/gegl-common-cxx.so
+%%AARCH64%%lib/gegl-%%GEGL_VER%%/gegl-common-cxx-arm-neon.so
+%%AMD64%%lib/gegl-%%GEGL_VER%%/gegl-common-cxx-x86_64-v2.so
+%%AMD64%%lib/gegl-%%GEGL_VER%%/gegl-common-cxx-x86_64-v3.so
lib/gegl-%%GEGL_VER%%/gegl-common-gpl3.so
+%%AARCH64%%lib/gegl-%%GEGL_VER%%/gegl-common-gpl3-arm-neon.so
+%%AMD64%%lib/gegl-%%GEGL_VER%%/gegl-common-gpl3-x86_64-v2.so
+%%AMD64%%lib/gegl-%%GEGL_VER%%/gegl-common-gpl3-x86_64-v3.so
lib/gegl-%%GEGL_VER%%/gegl-common.so
+%%AARCH64%%lib/gegl-%%GEGL_VER%%/gegl-common-arm-neon.so
+%%AMD64%%lib/gegl-%%GEGL_VER%%/gegl-common-x86_64-v2.so
+%%AMD64%%lib/gegl-%%GEGL_VER%%/gegl-common-x86_64-v3.so
lib/gegl-%%GEGL_VER%%/gegl-core.so
lib/gegl-%%GEGL_VER%%/gegl-generated.so
+%%AARCH64%%lib/gegl-%%GEGL_VER%%/gegl-generated-arm-neon.so
+%%AMD64%%lib/gegl-%%GEGL_VER%%/gegl-generated-x86_64-v2.so
+%%AMD64%%lib/gegl-%%GEGL_VER%%/gegl-generated-x86_64-v3.so
+%%AARCH64%%lib/gegl-%%GEGL_VER%%/gegl-transformops-arm-neon.so
+%%AMD64%%lib/gegl-%%GEGL_VER%%/gegl-transformops-x86_64-v2.so
+%%AMD64%%lib/gegl-%%GEGL_VER%%/gegl-transformops-x86_64-v3.so
lib/gegl-%%GEGL_VER%%/gif-load.so
lib/gegl-%%GEGL_VER%%/grey2.json
%%JASPER%%lib/gegl-%%GEGL_VER%%/jp2-load.so