aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof <ports@bsdserwis.com>2023-03-14 09:35:49 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-03-17 09:02:16 +0000
commit910e52c9d15669b8caf7101011e86786e3b25f54 (patch)
treee39f5c17c564f539c37707978b65e2beb9f4afb6
parent90a925078ced9cadfee65d6bd0dee6904d770510 (diff)
downloadports-910e52c9d15669b8caf7101011e86786e3b25f54.tar.gz
ports-910e52c9d15669b8caf7101011e86786e3b25f54.zip
net-mgmt/collectd5: update varnish dependency, modify nut dependency
As discussed in PR 265217 there is small patch for the nut (libups) dependency. I also add the actual varnish depndency (6 instead of 4). PR: 268972, 265217
-rw-r--r--net-mgmt/collectd5/Makefile42
-rw-r--r--net-mgmt/collectd5/files/patch-Makefile.am6
-rw-r--r--net-mgmt/collectd5/files/patch-configure.ac104
-rw-r--r--net-mgmt/collectd5/files/patch-version-gen.sh6
4 files changed, 122 insertions, 36 deletions
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index daedbdd58e7a..a9db572e6fc0 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -1,6 +1,6 @@
PORTNAME= collectd
PORTVERSION= 5.12.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net-mgmt
MASTER_SITES= https://storage.googleapis.com/collectd-tarballs/
PKGNAMESUFFIX= 5
@@ -42,7 +42,7 @@ LOGGING_DESC= Enable debug logging
LOGSTASH_DESC= Enable log_logstash plugin (requires json)
MEMCACHEC_DESC= Enable memcachec plugin
MODBUS_DESC= Enable modbus plugin
-MONGODB_DESC= Enable write_mongodb plugin (BROKEN)
+MONGODB_DESC= Enable write_mongodb plugin
MQTT_DESC= Enable MQTT broker metrics
MYSQL_DESC= Enable mysql-based plugins
NOTIFYDESKTOP_DESC= Enable desktop notifications
@@ -61,13 +61,13 @@ RABBITMQ_DESC= Enable rabbitmq-based plugins
REDIS_DESC= Enable redis-based plugins
RIEMANN_DESC= Enable write_riemann plugin (via riemann-c-client)
RRDTOOL_DESC= Enable rrdtool plugin (also rrdcached plugin)
-SIGROK_DESC= Enable sigrok plugin
+SIGROK_DESC= Enable sigrok plugin (BROKEN)
SLURM_DESC= Enable slurm plugin
SNMP_DESC= Enable SNMP plugin
STATSD_DESC= Enable statsd plugin
TOKYOTYRANT_DESC= Enable tokyotyrant plugin
TSDB_DESC= Enable write_tsdb plugin
-VARNISH_DESC= Enable varnish 4.x cache statistics
+VARNISH_DESC= Enable varnish 6.x cache statistics
VIRT_DESC= Enable libvirt plugin (requires XML)
XML_DESC= Enable XML plugins
ZOOKEEPER_DESC= Enable zookeeper plugin
@@ -87,7 +87,6 @@ CONFIGURE_ARGS= --disable-all-plugins \
--disable-ceph \
--disable-cgroups \
--disable-fhcount \
- --disable-lvm \
--disable-static \
--disable-turbostat \
--enable-disk \
@@ -96,7 +95,6 @@ CONFIGURE_ARGS= --disable-all-plugins \
--without-libganglia \
--without-libiptc \
--without-libldap \
- --without-liblvm2app \
--without-libmnl \
--without-libnetapp \
--without-libowcapi \
@@ -104,6 +102,7 @@ CONFIGURE_ARGS= --disable-all-plugins \
--without-mic \
--without-oracle
+CGI_USES= perl5
CGI_RUN_DEPENDS= p5-CGI>=0:www/p5-CGI \
p5-HTML-Parser>=0:www/p5-HTML-Parser \
p5-URI>=0:net/p5-URI
@@ -123,7 +122,7 @@ CURL_XML_CONFIGURE_ENABLE= ascent bind curl_xml
JAVA_USE= java
JAVA_CONFIGURE_ENABLE= java
-JAVA_CONFIGURE_WITH= java=${LOCALBASE} libjvm
+JAVA_CONFIGURE_WITH= java=${LOCALBASE}
DBI_LIB_DEPENDS= libdbi.so:databases/libdbi
DBI_CONFIGURE_ENABLE= dbi
@@ -158,11 +157,10 @@ MODBUS_LIB_DEPENDS= libmodbus.so:comms/libmodbus
MODBUS_CONFIGURE_ENABLE= modbus
MODBUS_CONFIGURE_WITH= libmodbus=use_pkgconfig
-MONGODB_LIB_DEPENDS+= libbson-1.0.so:devel/libbson \
- libmongoc-1.0.so:devel/mongo-c-driver
+MONGODB_LIB_DEPENDS+= libmongoc-1.0.so:devel/mongo-c-driver \
+ libbson-1.0.so:devel/libbson
MONGODB_CONFIGURE_ENABLE= write_mongodb
-MONGODB_CONFIGURE_WITH= libmongoc=${LOCALBASE}
-MONGODB_BROKEN= fails to configure with write_mongodb option
+MONGODB_CONFIGURE_WITH= libmongoc
MQTT_LIB_DEPENDS= libmosquitto.so:net/mosquitto
MQTT_CONFIGURE_ENABLE= mqtt
@@ -174,7 +172,6 @@ MYSQL_CONFIGURE_WITH= libmysql=${LOCALBASE}
NOTIFYDESKTOP_LIB_DEPENDS= libnotify.so:devel/libnotify
NOTIFYDESKTOP_CONFIGURE_ENABLE= notify_desktop
-NOTIFYDESKTOP_CONFIGURE_WITH= libnotify=${LOCALBASE}
NOTIFYDESKTOP_USE= GNOME=gdkpixbuf2
NOTIFYDESKTOP_USES= gettext-runtime gnome
@@ -182,9 +179,9 @@ NOTIFYEMAIL_LIB_DEPENDS= libesmtp.so:mail/libesmtp
NOTIFYEMAIL_CONFIGURE_ENABLE= notify_email
NOTIFYEMAIL_CONFIGURE_WITH= libesmtp=${LOCALBASE}
-NUTUPS_LIB_DEPENDS= libnutclient.so:sysutils/nut
+NUTUPS_LIB_DEPENDS= libupsclient.so:sysutils/nut
NUTUPS_CONFIGURE_ENABLE= nut
-NUTUPS_CONFIGURE_WITH= upsclient=${LOCALBASE}
+NUTUPS_CONFIGURE_WITH= libupsclient=${LOCALBASE}
OLSRD_CONFIGURE_ENABLE= olsrd
@@ -198,11 +195,11 @@ OPENLDAP_CONFIGURE_WITH= libldap=${LOCALBASE}
PERL_USES= perl5
PERL_CONFIGURE_ENABLE= perl
-PERL_CONFIGURE_WITH= libperl perl-bindings perl=${PERL}
+PERL_CONFIGURE_WITH= libperl=${LOCALBASE} perl-bindings
PGSQL_USES= pgsql
PGSQL_CONFIGURE_ENABLE= postgresql
-PGSQL_CONFIGURE_WITH= libpq postgresql=${LOCALBASE}
+PGSQL_CONFIGURE_WITH= libpq=${LOCALBASE}
PINBA_LIB_DEPENDS= libprotobuf-c.so:devel/protobuf-c
PINBA_CONFIGURE_ENABLE= pinba
@@ -218,11 +215,9 @@ PROMETHEUS_CONFIGURE_ENABLE= write_prometheus
PYTHON_USES= python
PYTHON_CONFIGURE_ENABLE= python
-PYTHON_CONFIGURE_WITH= python=${PYTHON_CMD}
PYTHON_CONFIGURE_ENV= PYTHON_CONFIG=${PYTHON_CMD}-config
RABBITMQ_LIB_DEPENDS= librabbitmq.so:net/rabbitmq-c
-RABBITMQ_CONFIGURE_ENABLE= rabbitmq
RABBITMQ_CONFIGURE_WITH= librabbitmq=${LOCALBASE}
REDIS_LIB_DEPENDS= libhiredis.so:databases/hiredis
@@ -238,12 +233,11 @@ RRDTOOL_CONFIGURE_ENABLE= rrdcached rrdtool
RRDTOOL_CONFIGURE_WITH= librrd=${LOCALBASE}
SIGROK_USE= GNOME=glib20
-SIGROK_CFLAGS= `pkg-config --cflags glib-2.0`
+SIGROK_CFLAGS= `pkg-config --cflags libsigrok`
SIGROK_LIB_DEPENDS= libsigrok.so:devel/libsigrok
SIGROK_CONFIGURE_ENABLE= sigrok
-SIGROK_CONFIGURE_WITH= libsigrok=${LOCALBASE}
SIGROK_USES= gettext-runtime
-SIGROK_BROKEN= fails to configure with sigrok option
+SIGROK_BROKEN= working only with sigrok < 0.4
SLURM_LIB_DEPENDS= libslurm.so:sysutils/slurm-wlm
SLURM_CONFIGURE_ENABLE= slurm
@@ -262,7 +256,7 @@ TOKYOTYRANT_CONFIGURE_WITH= libtokyotyrant=${LOCALBASE}
TSDB_CONFIGURE_ENABLE= write_tsdb
-VARNISH_LIB_DEPENDS= libvarnishapi.so:www/varnish4
+VARNISH_LIB_DEPENDS= libvarnishapi.so:www/varnish6
VARNISH_CONFIGURE_ENABLE= varnish
VIRT_IMPLIES= XML
@@ -270,7 +264,6 @@ VIRT_LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
libgpg-error.so:security/libgpg-error \
libvirt.so:devel/libvirt
VIRT_CONFIGURE_ENABLE= virt
-VIRT_CONFIGURE_WITH= virt=${LOCALBASE}
XML_CFLAGS= `pkg-config --cflags libxml-2.0`
XML_LIB_DEPENDS= libxml2.so:textproc/libxml2
@@ -278,7 +271,6 @@ XML_CONFIGURE_WITH= libxml2
ZOOKEEPER_LIB_DEPENDS= libzookeeper_mt.so:devel/libzookeeper
ZOOKEEPER_CONFIGURE_ENABLE= zookeeper
-ZOOKEEPER_CONFIGURE_WITH= libzookeeper=${LOCALBASE}
# NOTE: Plugins without external dependencies
CONFIGURE_ARGS+= --enable-aggregation \
@@ -336,8 +328,6 @@ INSTALL_TARGET= install-strip
SHEBANG_FILES= contrib/collection.cgi
post-patch:
- @${REINPLACE_CMD} 's/-Werror//' \
- ${WRKSRC}/configure.ac
@${REINPLACE_CMD} \
-e 's;@prefix@/var/;/var/;' \
-e 's;/var/lib/;/var/db/;' \
diff --git a/net-mgmt/collectd5/files/patch-Makefile.am b/net-mgmt/collectd5/files/patch-Makefile.am
index e4a986fa2ee8..44ec84831749 100644
--- a/net-mgmt/collectd5/files/patch-Makefile.am
+++ b/net-mgmt/collectd5/files/patch-Makefile.am
@@ -1,6 +1,6 @@
---- Makefile.am.orig 2020-03-08 15:57:09 UTC
+--- Makefile.am.orig 2020-09-03 15:12:19 UTC
+++ Makefile.am
-@@ -188,7 +188,7 @@ AM_CPPFLAGS = \
+@@ -190,7 +190,7 @@ AM_CPPFLAGS = \
-DPREFIX='"${prefix}"' \
-DCONFIGFILE='"${sysconfdir}/${PACKAGE_NAME}.conf"' \
-DLOCALSTATEDIR='"${localstatedir}"' \
@@ -9,7 +9,7 @@
-DPLUGINDIR='"${cpkglibdir}"' \
-DPKGDATADIR='"${cpkgdatadir}"'
if BUILD_WIN32
-@@ -2377,15 +2377,10 @@ endif
+@@ -2424,15 +2424,10 @@ endif
install-exec-hook:
$(mkinstalldirs) $(DESTDIR)$(localstatedir)/run
diff --git a/net-mgmt/collectd5/files/patch-configure.ac b/net-mgmt/collectd5/files/patch-configure.ac
index 1d8e1e6c772e..a0a08e537d02 100644
--- a/net-mgmt/collectd5/files/patch-configure.ac
+++ b/net-mgmt/collectd5/files/patch-configure.ac
@@ -1,6 +1,82 @@
---- configure.ac.orig 2020-09-03 04:09:35.126575027 -0700
-+++ configure.ac 2022-05-06 19:19:22.707837000 -0700
-@@ -5810,6 +5810,7 @@
+--- configure.ac.orig 2020-09-03 11:09:35 UTC
++++ configure.ac
+@@ -24,7 +24,7 @@ AC_SYS_LARGEFILE
+ #
+ # Checks for programs.
+ #
+-AC_PROG_CC_C99([],
++AC_PROG_CC([],
+ [AC_MSG_ERROR([No compiler found that supports C99])]
+ )
+
+@@ -725,7 +725,7 @@ AC_C_CONST
+ AC_TYPE_PID_T
+ AC_TYPE_SIZE_T
+ AC_TYPE_UID_T
+-AC_HEADER_TIME
++AC_CHECK_HEADERS([sys/time.h])
+
+ test_cxx_flags() {
+ AC_LANG_PUSH([C++])
+@@ -757,7 +757,7 @@ AC_FUNC_STRERROR_R
+
+ if test "x$GCC" = "xyes"; then
+ SAVE_CFLAGS="$CFLAGS"
+- CFLAGS="$CFLAGS -Wall -Werror"
++ CFLAGS="$CFLAGS -Wall "
+ fi
+ SAVE_LDFLAGS="$LDFLAGS"
+ LDFLAGS=""
+@@ -929,7 +929,7 @@ AC_CHECK_FUNCS([thread_info], [have_thread_info="yes"]
+ # Check for strptime {{{
+ if test "x$GCC" = "xyes"; then
+ SAVE_CFLAGS="$CFLAGS"
+- CFLAGS="$CFLAGS -Wall -Wextra -Werror"
++ CFLAGS="$CFLAGS -Wall -Wextra "
+ fi
+
+ AC_CHECK_FUNCS([strptime], [have_strptime="yes"], [have_strptime="no"])
+@@ -1000,10 +1000,10 @@ fi
+
+ # Check for timegm {{{
+
+-# These checks need -Werror because implicit function declarations are only a
++# These checks need because implicit function declarations are only a
+ # warning ...
+ SAVE_CFLAGS="$CFLAGS"
+-CFLAGS="$CFLAGS -Werror"
++CFLAGS="$CFLAGS "
+
+ AC_CACHE_CHECK([for timegm],
+ [c_cv_have_timegm],
+@@ -3454,7 +3454,7 @@ if test "x$with_libmongoc" = "xyes"; then
+ SAVE_LDFLAGS="$LDFLAGS"
+
+ CPPFLAGS="$CPPFLAGS $LIBMONGOC_CFLAGS"
+- LDFLAGS="$LDFLAGS $LIBMONGOC_LDFLAGS"
++ LDFLAGS="$LDFLAGS $LIBMONGOC_LIBS"
+
+ AC_CHECK_LIB([mongoc-1.0], [mongoc_init],
+ [with_libmongoc="yes"],
+@@ -3874,7 +3874,7 @@ if test "x$with_libnetsnmp" = "xyes"; then
+ SAVE_LIBS="$LIBS"
+ CPPFLAGS="$CPPFLAGS $with_libnetsnmp_cppflags"
+ if test "x$GCC" = "xyes"; then
+- CPPFLAGS="$CPPFLAGS -Wall -Werror"
++ CPPFLAGS="$CPPFLAGS -Wall "
+ fi
+ LDFLAGS="$LDFLAGS $with_libnetsnmp_ldflags"
+ LIBS="$LIBS -lnetsnmp"
+@@ -4348,7 +4348,7 @@ if test "x$with_libperl" = "xyes"; then
+ SAVE_LIBS="$LIBS"
+ CFLAGS="$CFLAGS $PERL_CFLAGS"
+ if test "x$GCC" = "xyes"; then
+- CFLAGS="$CFLAGS -Wall -Werror"
++ CFLAGS="$CFLAGS -Wall "
+ fi
+ LIBS="$LIBS $PERL_LIBS"
+
+@@ -5810,6 +5810,7 @@ if test "x$with_libupsclient" = "xyes"; then
[],
[],
[[
@@ -8,7 +84,7 @@
#include <stdlib.h>
#include <stdio.h>
#include <upsclient.h>
-@@ -6507,7 +6508,7 @@
+@@ -6507,7 +6508,7 @@ AC_ARG_WITH([libslurm],
else if test -d "$with_libslurm/lib"; then
AC_MSG_NOTICE([Not checking for libslurm: Manually configured])
with_libslurm_cflags="-I$withval/include"
@@ -17,3 +93,23 @@
with_libslurm="yes"
fi; fi; fi
],
+@@ -6579,7 +6580,7 @@ collectd features:])
+ AC_COLLECTD([debug], [enable], [feature], [debugging])
+ AC_COLLECTD([daemon], [disable], [feature], [daemon mode])
+ AC_COLLECTD([getifaddrs],[enable], [feature], [getifaddrs under Linux])
+-AC_COLLECTD([werror], [disable], [feature], [building with -Werror])
++AC_COLLECTD([werror], [disable], [feature], [building with ])
+
+ dependency_warning="no"
+ dependency_error="no"
+@@ -7348,8 +7349,8 @@ if test "x$GCC" = "xyes"; then
+ AM_CFLAGS="-Wall"
+ AM_CXXFLAGS="-Wall"
+ if test "x$enable_werror" != "xno"; then
+- AM_CFLAGS="$AM_CFLAGS -Werror"
+- AM_CXXFLAGS="$AM_CXXFLAGS -Werror"
++ AM_CFLAGS="$AM_CFLAGS "
++ AM_CXXFLAGS="$AM_CXXFLAGS "
+ fi
+ fi
+
diff --git a/net-mgmt/collectd5/files/patch-version-gen.sh b/net-mgmt/collectd5/files/patch-version-gen.sh
index e99fccaccb16..5ee4815805da 100644
--- a/net-mgmt/collectd5/files/patch-version-gen.sh
+++ b/net-mgmt/collectd5/files/patch-version-gen.sh
@@ -1,8 +1,8 @@
---- version-gen.sh.orig 2020-03-19 09:52:56.313967100 +0100
-+++ version-gen.sh 2020-03-27 19:15:53.407855000 +0100
+--- version-gen.sh.orig 2020-09-03 11:26:25 UTC
++++ version-gen.sh
@@ -2,10 +2,6 @@
- DEFAULT_VERSION="5.11.0.git"
+ DEFAULT_VERSION="5.12.0.git"
-if [ -d .git ]; then
- VERSION="`git describe --dirty=+ --abbrev=7 2> /dev/null | sed -e '/^collectd-/!d' -e 's///' -e 'y/-/./'`"