aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-08-14 17:30:45 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-08-14 18:37:55 +0000
commit9152f9cc5bcfc9d17a410c054eaf6a62e8ce096b (patch)
treefa57029cee82a8646af1c7ce5f6157b4aadcaf59
parent05f42514356340c207b81caefb67484223082e11 (diff)
downloadports-9152f9cc5bcfc9d17a410c054eaf6a62e8ce096b.tar.gz
ports-9152f9cc5bcfc9d17a410c054eaf6a62e8ce096b.zip
devel/py-diskcache: New port: Disk and file backed persistent cache
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-diskcache/Makefile26
-rw-r--r--devel/py-diskcache/distinfo3
-rw-r--r--devel/py-diskcache/pkg-descr8
4 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 46005b354e83..a7197492b4a6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4435,6 +4435,7 @@
SUBDIR += py-diazo
SUBDIR += py-dill
SUBDIR += py-dirspec
+ SUBDIR += py-diskcache
SUBDIR += py-distlib
SUBDIR += py-distributed
SUBDIR += py-dj40-django-rq
diff --git a/devel/py-diskcache/Makefile b/devel/py-diskcache/Makefile
new file mode 100644
index 000000000000..be59e0e24db8
--- /dev/null
+++ b/devel/py-diskcache/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= diskcache
+DISTVERSIONPREFIX= v
+DISTVERSION= 5.4.0
+CATEGORIES= devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Disk and file backed persistent cache
+
+LICENSE= APACHE20
+
+PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django41>0:www/py-django41@${PY_FLAVOR}
+BUILD_DEPENDS= ${PY_DEPENDS}
+RUN_DEPENDS= ${PY_DEPENDS}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tox>0:devel/py-tox@${PY_FLAVOR}
+
+USES= python:3.5+
+USE_PYTHON= distutils autoplist unittest # 1 test fails, see https://github.com/grantjenks/python-diskcache/issues/262
+
+USE_GITHUB= yes
+GH_ACCOUNT= grantjenks
+GH_PROJECT= python-diskcache
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-diskcache/distinfo b/devel/py-diskcache/distinfo
new file mode 100644
index 000000000000..c3ee85274567
--- /dev/null
+++ b/devel/py-diskcache/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1660497519
+SHA256 (grantjenks-python-diskcache-v5.4.0_GH0.tar.gz) = 5cdfcb16c9773584e8dca21c23c622e3c787721b1b09635a25e4f00c28073b2a
+SIZE (grantjenks-python-diskcache-v5.4.0_GH0.tar.gz) = 653968
diff --git a/devel/py-diskcache/pkg-descr b/devel/py-diskcache/pkg-descr
new file mode 100644
index 000000000000..28ecf78254f0
--- /dev/null
+++ b/devel/py-diskcache/pkg-descr
@@ -0,0 +1,8 @@
+DiskCache is an Apache2 licensed disk and file backed cache library, written in
+pure-Python, and compatible with Django.
+
+The cloud-based computing of 2021 puts a premium on memory. Gigabytes of empty
+space is left on disks as processes vie for memory. Among these processes is
+Memcached (and sometimes Redis) which is used as a cache.
+
+WWW: https://grantjenks.com/docs/diskcache/