aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-10-06 20:52:23 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-10-06 20:52:23 +0000
commit915dfb48de3eb2e3f1da066d3c1857f2035e7ef8 (patch)
tree9a95d75c40bd87a294f6af1f79a49b00a2ecb125
parent9105b6f7338ae45c2911209cd9ef02fc984b5882 (diff)
downloadports-915dfb48de3eb2e3f1da066d3c1857f2035e7ef8.tar.gz
ports-915dfb48de3eb2e3f1da066d3c1857f2035e7ef8.zip
archivers/pxz: fix build on powerpc
cc -o pxz -O2 -pipe -fstack-protector-strong -fno-strict-aliasing -fopenmp -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE pxz.c -fstack-protector-strong -llzma -DPXZ_BUILD_DATE=\"`date +%Y%m%d`\" -DPXZ_VERSION=\"4.999.9beta\" pxz.c:48:10: fatal error: 'omp.h' file not found
-rw-r--r--archivers/pxz/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/archivers/pxz/Makefile b/archivers/pxz/Makefile
index 0e6a5793ca2a..9988e39bf09b 100644
--- a/archivers/pxz/Makefile
+++ b/archivers/pxz/Makefile
@@ -25,6 +25,12 @@ MAKE_ENV+= BINDIR=${PREFIX}/bin \
MAKE_ARGS+= CC="${CC}"
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc
+USES+= compiler:gcc-c++11-lib
+.endif
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/pxz