aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2024-05-29 09:37:37 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2024-05-29 13:24:35 +0000
commit91b0e9abd6cb634795571c33b8c888be9df343ae (patch)
tree29cdb852f0d5b6e4e8b33a2597a008b6a67c5e70
parent4f81105c64be56cc963cc5549be223d0500495fd (diff)
downloadports-91b0e9abd6cb634795571c33b8c888be9df343ae.tar.gz
ports-91b0e9abd6cb634795571c33b8c888be9df343ae.zip
www/ufdbguard: update to 1.35.7
Changelog: https://www.urlfilterdb.com/products/releases.html Major changes: * Fix: potential buffer overrun with clientid * ufdbgclient has new option to choose between UNIX and TCP socket Port changes: * remove unix socket compile option. It's no longer a compile option, there is 'socket-type' configuration option instead. * minor adjustments for configure PR: 278258 Reported by: Pavel Timofeev <timp87@gmail.com> (maintainer)
-rw-r--r--www/ufdbguard/Makefile40
-rw-r--r--www/ufdbguard/distinfo6
-rw-r--r--www/ufdbguard/files/patch-configure18
-rw-r--r--www/ufdbguard/files/patch-src_Makefile.in14
-rw-r--r--www/ufdbguard/files/patch-src_install__etcfiles.sh.in4
-rw-r--r--www/ufdbguard/files/patch-src_mtserver_Makefile.in10
-rw-r--r--www/ufdbguard/files/pkg-message.in4
-rw-r--r--www/ufdbguard/files/ufdbguardd.in14
8 files changed, 58 insertions, 52 deletions
diff --git a/www/ufdbguard/Makefile b/www/ufdbguard/Makefile
index 7101df5a4ffb..9cb76966c5f2 100644
--- a/www/ufdbguard/Makefile
+++ b/www/ufdbguard/Makefile
@@ -1,6 +1,5 @@
PORTNAME= ufdbGuard
-PORTVERSION= 1.35.3
-PORTREVISION= 1
+PORTVERSION= 1.35.7
CATEGORIES= www
MASTER_SITES= SF/${PORTNAME:tl}/1.35
@@ -17,43 +16,40 @@ USE_RC_SUBR= ufdbguardd
SHEBANG_FILES= samples/URLblocked.cgi
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-ssl=${OPENSSLBASE} \
- --with-ssl-lib=${OPENSSLLIB} \
- --with-ssl-inc=${OPENSSLINC} \
- --with-bz2=/usr \
+CONFIGURE_ARGS= --with-bz2-inc=/usr/include \
--with-bz2-lib=/usr/lib \
- --with-bz2-inc=/usr/include \
- --with-ufdb-user=root \
- --with-ufdb-mandir=${PREFIX}/share/man \
+ --with-bz2=/usr \
+ --with-ssl-inc=${OPENSSLINC} \
+ --with-ssl-lib=${OPENSSLLIB} \
+ --with-ssl=${OPENSSLBASE} \
+ --with-ufdb-config=${ETCDIR} \
+ --with-ufdb-dbhome=${DBDIR} \
+ --with-ufdb-imagesdir=${EXAMPLESDIR}/images \
--with-ufdb-logdir=${LOGDIR} \
+ --with-ufdb-mandir=${PREFIX}/share/man \
--with-ufdb-piddir=${RUNDIR} \
--with-ufdb-samplesdir=${EXAMPLESDIR} \
- --with-ufdb-config=${ETCDIR} \
- --with-ufdb-dbhome=${DBDIR} \
- --with-ufdb-imagesdir=${EXAMPLESDIR}/images
+ --with-ufdb-user=root
MAKE_JOBS_UNSAFE= yes
SUB_FILES= pkg-message
-SUB_LIST= PORTNAME=${PORTNAME} \
- USERS=${USERS} \
+SUB_LIST= DBDIR=${DBDIR} \
+ PORTNAME=${PORTNAME} \
RUNDIR=${RUNDIR} \
- DBDIR=${DBDIR}
+ USERS=${USERS}
USERS= ufdb
GROUPS= ${USERS}
-PLIST_SUB= USERS=${USERS} \
+PLIST_SUB= DBDIR=${DBDIR} \
GROUPS=${GROUPS} \
+ LOGDIR=${LOGDIR} \
RUNDIR=${RUNDIR} \
- DBDIR=${DBDIR} \
- LOGDIR=${LOGDIR}
-
-OPTIONS_DEFINE= UNIXSOCKETS EXAMPLES
+ USERS=${USERS}
-UNIXSOCKETS_DESC= Unix sockets support
-UNIXSOCKETS_CONFIGURE_WITH= unix-sockets
+OPTIONS_DEFINE= EXAMPLES
DBDIR= /var/db/${PORTNAME}
LOGDIR= /var/log/${PORTNAME}
diff --git a/www/ufdbguard/distinfo b/www/ufdbguard/distinfo
index c2e6f20fdff3..901500a810ab 100644
--- a/www/ufdbguard/distinfo
+++ b/www/ufdbguard/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1604849332
-SHA256 (ufdbGuard-1.35.3.tar.gz) = eb6134b2b5430da3006cd28a0977034f3ff8df9d5a72058e2e9d956f2d57c449
-SIZE (ufdbGuard-1.35.3.tar.gz) = 1738159
+TIMESTAMP = 1712588046
+SHA256 (ufdbGuard-1.35.7.tar.gz) = 2707c6786fe3cf0b1199f0f970883838e8dd529741db7c4a728788824fcec8a4
+SIZE (ufdbGuard-1.35.7.tar.gz) = 1711624
diff --git a/www/ufdbguard/files/patch-configure b/www/ufdbguard/files/patch-configure
new file mode 100644
index 000000000000..38d7189990fc
--- /dev/null
+++ b/www/ufdbguard/files/patch-configure
@@ -0,0 +1,18 @@
+--- configure.orig 2024-03-20 15:31:17 UTC
++++ configure
+@@ -7847,7 +7847,6 @@ then
+ echo " The bash package is most likely on your UNIX distribution media."
+ echo " It is required to install the bash package and rerun configure."
+ echo
+- exit 1
+ fi
+
+ # Extract the first word of "wget", so it can be a program name with args.
+@@ -7905,7 +7904,6 @@ then
+ echo " The wget package is most likely on your UNIX distribution media."
+ echo " It is required to install the wget package and rerun configure."
+ echo
+- exit 1
+ fi
+
+ # Extract the first word of "curl", so it can be a program name with args.
diff --git a/www/ufdbguard/files/patch-src_Makefile.in b/www/ufdbguard/files/patch-src_Makefile.in
index e2e5372afed4..ed838ade98a4 100644
--- a/www/ufdbguard/files/patch-src_Makefile.in
+++ b/www/ufdbguard/files/patch-src_Makefile.in
@@ -1,6 +1,6 @@
---- src/Makefile.in.orig 2019-02-04 19:45:45 UTC
+--- src/Makefile.in.orig 2024-03-21 13:58:11 UTC
+++ src/Makefile.in
-@@ -227,7 +227,7 @@ install.bin: ufdbGenTable ufdbAnalyse ufdbhttpd create
+@@ -237,7 +237,7 @@ install.bin: ufdbGenTable ufdbAnalyse ufdbhttpd create
$(INSTALL_PROGRAM) ufdb_top_urls.pl $(DESTDIR)$(bindir)/ufdb_top_urls
$(INSTALL_PROGRAM) ufdb_top_users.pl $(DESTDIR)$(bindir)/ufdb_top_users
@if [ -f ufdbpeek ] ; then $(INSTALL_PROGRAM) ufdbpeek $(DESTDIR)$(bindir)/ufdbpeek ; fi
@@ -9,7 +9,7 @@
install.pid::
if [ $(piddir) != /var/tmp ] ; then $(INSTALL) -d $(DESTDIR)$(piddir) ; fi
-@@ -239,10 +239,10 @@ install.update::
+@@ -249,10 +249,10 @@ install.update::
install.security::
echo "Installing SSL root certificates"
@@ -22,3 +22,11 @@
install.debug::
-if [ -x /usr/bin/debuginfo-install ] ; then /usr/bin/debuginfo-install glibc ; fi
+@@ -269,7 +269,6 @@ install.log::
+
+ createdirs::
+ echo "Creating directories ..."
+- $(INSTALL) -d $(DESTDIR)/usr/lib/systemd/system
+ $(INSTALL) -d $(DESTDIR)$(bindir)
+ $(INSTALL) -o $(RUNAS) -d $(DESTDIR)$(logdir)
+ $(INSTALL) -d $(DESTDIR)$(cfgdir)
diff --git a/www/ufdbguard/files/patch-src_install__etcfiles.sh.in b/www/ufdbguard/files/patch-src_install__etcfiles.sh.in
index 5fa9195cd556..6a4e7f76e729 100644
--- a/www/ufdbguard/files/patch-src_install__etcfiles.sh.in
+++ b/www/ufdbguard/files/patch-src_install__etcfiles.sh.in
@@ -1,4 +1,4 @@
---- src/install_etcfiles.sh.in.orig 2019-02-27 23:03:09 UTC
+--- src/install_etcfiles.sh.in.orig 2024-03-22 12:30:31 UTC
+++ src/install_etcfiles.sh.in
@@ -22,19 +22,6 @@ else
DESTDIR=""
@@ -20,7 +20,7 @@
OS="@ufdb_os_type@"
INITDIR="@ufdb_initdir@"
-@@ -281,12 +268,10 @@ fix_piddir_permissions () {
+@@ -293,12 +280,10 @@ fix_piddir_permissions () {
case $OS in
diff --git a/www/ufdbguard/files/patch-src_mtserver_Makefile.in b/www/ufdbguard/files/patch-src_mtserver_Makefile.in
index 37ac2487116b..ac158fced37c 100644
--- a/www/ufdbguard/files/patch-src_mtserver_Makefile.in
+++ b/www/ufdbguard/files/patch-src_mtserver_Makefile.in
@@ -1,11 +1,11 @@
---- src/mtserver/Makefile.in.orig 2020-11-01 13:42:44 UTC
+--- src/mtserver/Makefile.in.orig 2024-03-21 13:58:11 UTC
+++ src/mtserver/Makefile.in
@@ -16,7 +16,7 @@
CC = @CC@
CXX = @CXX@
--CFLAGS = @CFLAGS@ -I. -I.. # -DUFDB_TEST_PROXY
-+CFLAGS = @CFLAGS@ -D__BSD_VISIBLE=1 -I. -I..
- CXXFLAGS= @CXXFLAGS@ -I. -I..
+-CFLAGS = @CFLAGS@ -I. -I.. -Wall -Wextra -Wmissing-prototypes -Wstrict-prototypes -Wold-style-definition
++CFLAGS = @CFLAGS@ -D__BSD_VISIBLE=1 -I. -I.. -Wall -Wextra -Wmissing-prototypes -Wstrict-prototypes -Wold-style-definition
+ CXXFLAGS= @CXXFLAGS@ -I. -I.. -Wall -Wextra -Wmissing-declarations
CPPFLAGS= @CPPFLAGS@
- LDFLAGS = @LDFLAGS@
+ LDFLAGS = @LDFLAGS@ # -Wl,-z,relro -Wl,-z,now
diff --git a/www/ufdbguard/files/pkg-message.in b/www/ufdbguard/files/pkg-message.in
index fa4f167cd4db..32510a1d6d67 100644
--- a/www/ufdbguard/files/pkg-message.in
+++ b/www/ufdbguard/files/pkg-message.in
@@ -3,10 +3,6 @@
message: <<EOM
Please, note the following statements about %%PORTNAME%% port:
- o it's decided during compilation if ufdbguardd will work through Unix
- or TCP socket. It's set to Unix socket by default and if you want it
- to work via TCP socket unset UNIXSOCKETS port option and rebuild it.
-
o ufdbUpdate script is left in non-working state for now.
The only purpose of this script is to download URLfilterDB updates
using paid subscription and to run it by cron. The script implies on
diff --git a/www/ufdbguard/files/ufdbguardd.in b/www/ufdbguard/files/ufdbguardd.in
index 60488990d4cb..fb5e8cbc4c7f 100644
--- a/www/ufdbguard/files/ufdbguardd.in
+++ b/www/ufdbguard/files/ufdbguardd.in
@@ -49,8 +49,6 @@ ufdbguardd_load_rc_config()
: ${ufdbguardd_enable:=NO}
: ${ufdbguardd_user:=%%USERS%%}
- ufdbguardd_unixsocket="/tmp/ufdbguardd-[0-9]*"
-
required_dirs="$ufdbguardd_dbdir %%RUNDIR%%"
required_files="$ufdbguardd_conf"
pidfile="%%RUNDIR%%/${name}.pid"
@@ -68,19 +66,9 @@ ufdbguardd_configtest()
fi
}
-ufdbguardd_checksocket()
-{
- echo "Checking if $name unix socket exists."
- if test -e $ufdbguardd_unixsocket; then
- echo "Unix socket $ufdbguardd_unixsocket exists. Probably stale file after abnormal shutdown. Removing it."
- rm -f $ufdbguardd_unixsocket
- fi
-}
-
ufdbguardd_prestart()
{
- ufdbguardd_configtest && \
- ufdbguardd_checksocket
+ ufdbguardd_configtest
}
ufdbguardd_rotatelog()