aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-08-27 10:07:55 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-08-27 10:07:55 +0000
commit923abd142a40df449eec6cda7bdcc7d6f148fe46 (patch)
tree3b02de6bd38bd19a29591b840e921fb611f708fe
parent70ff716aaf0e39c9904d0b0960e833c62129f62e (diff)
downloadports-923abd142a40df449eec6cda7bdcc7d6f148fe46.tar.gz
ports-923abd142a40df449eec6cda7bdcc7d6f148fe46.zip
www/smarty: Add smarty 4.2.0
Smarty is a template engine for PHP. Many other template engines for PHP provide basic variable substitution and dynamic block functionality. Smarty takes a step further to be a "smart" template engine, adding features such as configuration files, template functions, and variable modifiers, and making all of this functionality as easy as possible to use for both programmers and template designers. Smarty also converts the templates into PHP scripts, eliminating the need to parse the templates on every invocation. This makes Smarty extremely scalable and managable for large application needs. WWW: https://www.smarty.net/
-rw-r--r--MOVED1
-rw-r--r--www/Makefile1
-rw-r--r--www/smarty/Makefile29
-rw-r--r--www/smarty/distinfo3
-rw-r--r--www/smarty/files/pkg-message.in10
-rw-r--r--www/smarty/pkg-descr10
-rw-r--r--www/smarty/pkg-plist201
7 files changed, 254 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index c8213d43f613..03e54b981b4a 100644
--- a/MOVED
+++ b/MOVED
@@ -3648,7 +3648,6 @@ www/linuxpluginwrapper||2012-09-22|Has expired: doesn't support ELF symbol versi
net/fping+ipv6|net/fping|2012-09-24|IPv6 support has been merged
textproc/aspell-without-dicten|textproc/aspell|2012-09-24|The dictionary is no longer installed with textproc/aspell
www/jakarta-jmeter|www/jmeter|2012-09-25|Former Jakarta projects now live on their own
-www/smarty|www/smarty2|2012-09-26|Renamed to prepare for addition of Smarty 3.x to the tree
devel/p5-Devel-Mallinfo||2012-10-08|Has expired: Does not work on FreeBSD, mallinfo() is a GNU libc function and is not available on FreeBSD
multimedia/vdpau-video|multimedia/libva-vdpau-driver|2012-10-09|Project renamed
mail/enigmail||2012-10-10|Enigmail is now an option in the thunderbird/seamonkey port
diff --git a/www/Makefile b/www/Makefile
index da7dd182dc7e..49ef7dc9a067 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -2181,6 +2181,7 @@
SUBDIR += sitecopy
SUBDIR += slowcgi
SUBDIR += slowhttptest
+ SUBDIR += smarty
SUBDIR += smarty2
SUBDIR += smarty3
SUBDIR += smb_auth
diff --git a/www/smarty/Makefile b/www/smarty/Makefile
new file mode 100644
index 000000000000..4c568e6fe6ba
--- /dev/null
+++ b/www/smarty/Makefile
@@ -0,0 +1,29 @@
+PORTNAME= smarty
+DISTVERSIONPREFIX= v
+PORTVERSION= 4.2.0
+CATEGORIES= www
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= PHP compiling template engine
+
+LICENSE= LGPL3+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cpe php:flavors,web
+USE_PHP= pcre
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+DATADIR= ${PREFIX}/share/smarty${PHP_PKGNAMESUFFIX}
+SUB_FILES= pkg-message
+
+USE_GITHUB= yes
+GH_ACCOUNT= smarty-php
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ cd ${WRKSRC}/libs && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/www/smarty/distinfo b/www/smarty/distinfo
new file mode 100644
index 000000000000..0ba861f617aa
--- /dev/null
+++ b/www/smarty/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1660576666
+SHA256 (smarty-php-smarty-v4.2.0_GH0.tar.gz) = f875fa4c2859b0b82fff03f3c941df2cc64304e40de108a1ec3c84f9c8dedec4
+SIZE (smarty-php-smarty-v4.2.0_GH0.tar.gz) = 235962
diff --git a/www/smarty/files/pkg-message.in b/www/smarty/files/pkg-message.in
new file mode 100644
index 000000000000..d46544aea6db
--- /dev/null
+++ b/www/smarty/files/pkg-message.in
@@ -0,0 +1,10 @@
+[
+{ type: install
+ message: <<EOM
+You need to adjust php's include_path to contain %%DATADIR%%!
+For example, insert
+ include_path = ".:%%DATADIR%%"
+into %%LOCALBASE%%/etc/php.ini.
+EOM
+}
+]
diff --git a/www/smarty/pkg-descr b/www/smarty/pkg-descr
new file mode 100644
index 000000000000..5a72dea37c6e
--- /dev/null
+++ b/www/smarty/pkg-descr
@@ -0,0 +1,10 @@
+Smarty is a template engine for PHP. Many other template engines for PHP provide
+basic variable substitution and dynamic block functionality. Smarty takes a step
+further to be a "smart" template engine, adding features such as configuration
+files, template functions, and variable modifiers, and making all of this
+functionality as easy as possible to use for both programmers and template
+designers. Smarty also converts the templates into PHP scripts, eliminating the
+need to parse the templates on every invocation. This makes Smarty extremely
+scalable and managable for large application needs.
+
+WWW: https://www.smarty.net/
diff --git a/www/smarty/pkg-plist b/www/smarty/pkg-plist
new file mode 100644
index 000000000000..e0e78d90367d
--- /dev/null
+++ b/www/smarty/pkg-plist
@@ -0,0 +1,201 @@
+%%DATADIR%%/Autoloader.php
+%%DATADIR%%/Smarty.class.php
+%%DATADIR%%/bootstrap.php
+%%DATADIR%%/debug.tpl
+%%DATADIR%%/plugins/block.textformat.php
+%%DATADIR%%/plugins/function.counter.php
+%%DATADIR%%/plugins/function.cycle.php
+%%DATADIR%%/plugins/function.fetch.php
+%%DATADIR%%/plugins/function.html_checkboxes.php
+%%DATADIR%%/plugins/function.html_image.php
+%%DATADIR%%/plugins/function.html_options.php
+%%DATADIR%%/plugins/function.html_radios.php
+%%DATADIR%%/plugins/function.html_select_date.php
+%%DATADIR%%/plugins/function.html_select_time.php
+%%DATADIR%%/plugins/function.html_table.php
+%%DATADIR%%/plugins/function.mailto.php
+%%DATADIR%%/plugins/function.math.php
+%%DATADIR%%/plugins/modifier.capitalize.php
+%%DATADIR%%/plugins/modifier.date_format.php
+%%DATADIR%%/plugins/modifier.debug_print_var.php
+%%DATADIR%%/plugins/modifier.escape.php
+%%DATADIR%%/plugins/modifier.mb_wordwrap.php
+%%DATADIR%%/plugins/modifier.regex_replace.php
+%%DATADIR%%/plugins/modifier.replace.php
+%%DATADIR%%/plugins/modifier.spacify.php
+%%DATADIR%%/plugins/modifier.truncate.php
+%%DATADIR%%/plugins/modifiercompiler.cat.php
+%%DATADIR%%/plugins/modifiercompiler.count_characters.php
+%%DATADIR%%/plugins/modifiercompiler.count_paragraphs.php
+%%DATADIR%%/plugins/modifiercompiler.count_sentences.php
+%%DATADIR%%/plugins/modifiercompiler.count_words.php
+%%DATADIR%%/plugins/modifiercompiler.default.php
+%%DATADIR%%/plugins/modifiercompiler.escape.php
+%%DATADIR%%/plugins/modifiercompiler.from_charset.php
+%%DATADIR%%/plugins/modifiercompiler.indent.php
+%%DATADIR%%/plugins/modifiercompiler.lower.php
+%%DATADIR%%/plugins/modifiercompiler.noprint.php
+%%DATADIR%%/plugins/modifiercompiler.string_format.php
+%%DATADIR%%/plugins/modifiercompiler.strip.php
+%%DATADIR%%/plugins/modifiercompiler.strip_tags.php
+%%DATADIR%%/plugins/modifiercompiler.to_charset.php
+%%DATADIR%%/plugins/modifiercompiler.unescape.php
+%%DATADIR%%/plugins/modifiercompiler.upper.php
+%%DATADIR%%/plugins/modifiercompiler.wordwrap.php
+%%DATADIR%%/plugins/outputfilter.trimwhitespace.php
+%%DATADIR%%/plugins/shared.escape_special_chars.php
+%%DATADIR%%/plugins/shared.literal_compiler_param.php
+%%DATADIR%%/plugins/shared.make_timestamp.php
+%%DATADIR%%/plugins/shared.mb_str_replace.php
+%%DATADIR%%/plugins/shared.mb_unicode.php
+%%DATADIR%%/plugins/variablefilter.htmlspecialchars.php
+%%DATADIR%%/sysplugins/smarty_cacheresource.php
+%%DATADIR%%/sysplugins/smarty_cacheresource_custom.php
+%%DATADIR%%/sysplugins/smarty_cacheresource_keyvaluestore.php
+%%DATADIR%%/sysplugins/smarty_data.php
+%%DATADIR%%/sysplugins/smarty_internal_block.php
+%%DATADIR%%/sysplugins/smarty_internal_cacheresource_file.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_append.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_assign.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_block.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_block_child.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_block_parent.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_break.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_call.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_capture.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_child.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_config_load.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_continue.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_debug.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_eval.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_extends.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_for.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_foreach.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_function.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_if.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_include.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_insert.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_ldelim.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_make_nocache.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_nocache.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_parent.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_private_block_plugin.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_private_foreachsection.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_private_function_plugin.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_private_modifier.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_private_object_block_function.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_private_object_function.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_private_print_expression.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_private_registered_block.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_private_registered_function.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_private_special_variable.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_rdelim.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_section.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_setfilter.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_shared_inheritance.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_while.php
+%%DATADIR%%/sysplugins/smarty_internal_compilebase.php
+%%DATADIR%%/sysplugins/smarty_internal_config_file_compiler.php
+%%DATADIR%%/sysplugins/smarty_internal_configfilelexer.php
+%%DATADIR%%/sysplugins/smarty_internal_configfileparser.php
+%%DATADIR%%/sysplugins/smarty_internal_data.php
+%%DATADIR%%/sysplugins/smarty_internal_debug.php
+%%DATADIR%%/sysplugins/smarty_internal_errorhandler.php
+%%DATADIR%%/sysplugins/smarty_internal_extension_handler.php
+%%DATADIR%%/sysplugins/smarty_internal_method_addautoloadfilters.php
+%%DATADIR%%/sysplugins/smarty_internal_method_adddefaultmodifiers.php
+%%DATADIR%%/sysplugins/smarty_internal_method_append.php
+%%DATADIR%%/sysplugins/smarty_internal_method_appendbyref.php
+%%DATADIR%%/sysplugins/smarty_internal_method_assignbyref.php
+%%DATADIR%%/sysplugins/smarty_internal_method_assignglobal.php
+%%DATADIR%%/sysplugins/smarty_internal_method_clearallassign.php
+%%DATADIR%%/sysplugins/smarty_internal_method_clearallcache.php
+%%DATADIR%%/sysplugins/smarty_internal_method_clearassign.php
+%%DATADIR%%/sysplugins/smarty_internal_method_clearcache.php
+%%DATADIR%%/sysplugins/smarty_internal_method_clearcompiledtemplate.php
+%%DATADIR%%/sysplugins/smarty_internal_method_clearconfig.php
+%%DATADIR%%/sysplugins/smarty_internal_method_compileallconfig.php
+%%DATADIR%%/sysplugins/smarty_internal_method_compilealltemplates.php
+%%DATADIR%%/sysplugins/smarty_internal_method_configload.php
+%%DATADIR%%/sysplugins/smarty_internal_method_createdata.php
+%%DATADIR%%/sysplugins/smarty_internal_method_getautoloadfilters.php
+%%DATADIR%%/sysplugins/smarty_internal_method_getconfigvariable.php
+%%DATADIR%%/sysplugins/smarty_internal_method_getconfigvars.php
+%%DATADIR%%/sysplugins/smarty_internal_method_getdebugtemplate.php
+%%DATADIR%%/sysplugins/smarty_internal_method_getdefaultmodifiers.php
+%%DATADIR%%/sysplugins/smarty_internal_method_getglobal.php
+%%DATADIR%%/sysplugins/smarty_internal_method_getregisteredobject.php
+%%DATADIR%%/sysplugins/smarty_internal_method_getstreamvariable.php
+%%DATADIR%%/sysplugins/smarty_internal_method_gettags.php
+%%DATADIR%%/sysplugins/smarty_internal_method_gettemplatevars.php
+%%DATADIR%%/sysplugins/smarty_internal_method_literals.php
+%%DATADIR%%/sysplugins/smarty_internal_method_loadfilter.php
+%%DATADIR%%/sysplugins/smarty_internal_method_loadplugin.php
+%%DATADIR%%/sysplugins/smarty_internal_method_mustcompile.php
+%%DATADIR%%/sysplugins/smarty_internal_method_registercacheresource.php
+%%DATADIR%%/sysplugins/smarty_internal_method_registerclass.php
+%%DATADIR%%/sysplugins/smarty_internal_method_registerdefaultconfighandler.php
+%%DATADIR%%/sysplugins/smarty_internal_method_registerdefaultpluginhandler.php
+%%DATADIR%%/sysplugins/smarty_internal_method_registerdefaulttemplatehandler.php
+%%DATADIR%%/sysplugins/smarty_internal_method_registerfilter.php
+%%DATADIR%%/sysplugins/smarty_internal_method_registerobject.php
+%%DATADIR%%/sysplugins/smarty_internal_method_registerplugin.php
+%%DATADIR%%/sysplugins/smarty_internal_method_registerresource.php
+%%DATADIR%%/sysplugins/smarty_internal_method_setautoloadfilters.php
+%%DATADIR%%/sysplugins/smarty_internal_method_setdebugtemplate.php
+%%DATADIR%%/sysplugins/smarty_internal_method_setdefaultmodifiers.php
+%%DATADIR%%/sysplugins/smarty_internal_method_unloadfilter.php
+%%DATADIR%%/sysplugins/smarty_internal_method_unregistercacheresource.php
+%%DATADIR%%/sysplugins/smarty_internal_method_unregisterfilter.php
+%%DATADIR%%/sysplugins/smarty_internal_method_unregisterobject.php
+%%DATADIR%%/sysplugins/smarty_internal_method_unregisterplugin.php
+%%DATADIR%%/sysplugins/smarty_internal_method_unregisterresource.php
+%%DATADIR%%/sysplugins/smarty_internal_nocache_insert.php
+%%DATADIR%%/sysplugins/smarty_internal_parsetree.php
+%%DATADIR%%/sysplugins/smarty_internal_parsetree_code.php
+%%DATADIR%%/sysplugins/smarty_internal_parsetree_dq.php
+%%DATADIR%%/sysplugins/smarty_internal_parsetree_dqcontent.php
+%%DATADIR%%/sysplugins/smarty_internal_parsetree_tag.php
+%%DATADIR%%/sysplugins/smarty_internal_parsetree_template.php
+%%DATADIR%%/sysplugins/smarty_internal_parsetree_text.php
+%%DATADIR%%/sysplugins/smarty_internal_resource_eval.php
+%%DATADIR%%/sysplugins/smarty_internal_resource_extends.php
+%%DATADIR%%/sysplugins/smarty_internal_resource_file.php
+%%DATADIR%%/sysplugins/smarty_internal_resource_php.php
+%%DATADIR%%/sysplugins/smarty_internal_resource_stream.php
+%%DATADIR%%/sysplugins/smarty_internal_resource_string.php
+%%DATADIR%%/sysplugins/smarty_internal_runtime_cachemodify.php
+%%DATADIR%%/sysplugins/smarty_internal_runtime_cacheresourcefile.php
+%%DATADIR%%/sysplugins/smarty_internal_runtime_capture.php
+%%DATADIR%%/sysplugins/smarty_internal_runtime_codeframe.php
+%%DATADIR%%/sysplugins/smarty_internal_runtime_filterhandler.php
+%%DATADIR%%/sysplugins/smarty_internal_runtime_foreach.php
+%%DATADIR%%/sysplugins/smarty_internal_runtime_getincludepath.php
+%%DATADIR%%/sysplugins/smarty_internal_runtime_inheritance.php
+%%DATADIR%%/sysplugins/smarty_internal_runtime_make_nocache.php
+%%DATADIR%%/sysplugins/smarty_internal_runtime_tplfunction.php
+%%DATADIR%%/sysplugins/smarty_internal_runtime_updatecache.php
+%%DATADIR%%/sysplugins/smarty_internal_runtime_updatescope.php
+%%DATADIR%%/sysplugins/smarty_internal_runtime_writefile.php
+%%DATADIR%%/sysplugins/smarty_internal_smartytemplatecompiler.php
+%%DATADIR%%/sysplugins/smarty_internal_template.php
+%%DATADIR%%/sysplugins/smarty_internal_templatebase.php
+%%DATADIR%%/sysplugins/smarty_internal_templatecompilerbase.php
+%%DATADIR%%/sysplugins/smarty_internal_templatelexer.php
+%%DATADIR%%/sysplugins/smarty_internal_templateparser.php
+%%DATADIR%%/sysplugins/smarty_internal_testinstall.php
+%%DATADIR%%/sysplugins/smarty_internal_undefined.php
+%%DATADIR%%/sysplugins/smarty_resource.php
+%%DATADIR%%/sysplugins/smarty_resource_custom.php
+%%DATADIR%%/sysplugins/smarty_resource_recompiled.php
+%%DATADIR%%/sysplugins/smarty_resource_uncompiled.php
+%%DATADIR%%/sysplugins/smarty_security.php
+%%DATADIR%%/sysplugins/smarty_template_cached.php
+%%DATADIR%%/sysplugins/smarty_template_compiled.php
+%%DATADIR%%/sysplugins/smarty_template_config.php
+%%DATADIR%%/sysplugins/smarty_template_resource_base.php
+%%DATADIR%%/sysplugins/smarty_template_source.php
+%%DATADIR%%/sysplugins/smarty_undefined_variable.php
+%%DATADIR%%/sysplugins/smarty_variable.php
+%%DATADIR%%/sysplugins/smartycompilerexception.php
+%%DATADIR%%/sysplugins/smartyexception.php