aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-04-29 14:10:03 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-04-29 14:23:30 +0000
commit924b29e65f92c87ee489467f1907c6b28342f14f (patch)
treea53898853872ebbb9b0fa6a733c1ec9126cac70e
parent9bda2e207acdf77685ffdc4700b946681fcd3251 (diff)
downloadports-924b29e65f92c87ee489467f1907c6b28342f14f.tar.gz
ports-924b29e65f92c87ee489467f1907c6b28342f14f.zip
devel/p5-Parser-MGC: Add p5-Parser-MGC 0.19
Parser::MGC class provides a low-level framework for building recursive-descent parsers that consume a given input string from left to right, returning a parse structure. It takes its name from the m//gc regexps used to implement the token parsing behaviour. It provides a number of token-parsing methods, which each extract a grammatical token from the string. It also provides wrapping methods that can be used to build up a possibly-recursive grammar structure, by applying a structure around other parts of parsing code. WWW: https://metacpan.org/release/Parser-MGC
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Parser-MGC/Makefile25
-rw-r--r--devel/p5-Parser-MGC/distinfo3
-rw-r--r--devel/p5-Parser-MGC/pkg-descr11
-rw-r--r--devel/p5-Parser-MGC/pkg-plist6
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b1ef34eaf203..497a49f94941 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3030,6 +3030,7 @@
SUBDIR += p5-Parse-Yapp
SUBDIR += p5-ParseLex
SUBDIR += p5-ParseTemplate
+ SUBDIR += p5-Parser-MGC
SUBDIR += p5-PatchReader
SUBDIR += p5-Path-Abstract
SUBDIR += p5-Path-Class
diff --git a/devel/p5-Parser-MGC/Makefile b/devel/p5-Parser-MGC/Makefile
new file mode 100644
index 000000000000..31aa921634f2
--- /dev/null
+++ b/devel/p5-Parser-MGC/Makefile
@@ -0,0 +1,25 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= Parser-MGC
+PORTVERSION= 0.19
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Build simple recursive-descent parsers
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Feature-Compat-Try>=0:devel/p5-Feature-Compat-Try \
+ p5-File-Slurp-Tiny>=0:devel/p5-File-Slurp-Tiny
+
+USES= perl5
+USE_PERL5= modbuild
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Parser-MGC/distinfo b/devel/p5-Parser-MGC/distinfo
new file mode 100644
index 000000000000..934c28c2a661
--- /dev/null
+++ b/devel/p5-Parser-MGC/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1619569393
+SHA256 (Parser-MGC-0.19.tar.gz) = 92ff60753bbaa9b6166f105ac6dc2988f4e582e62d5ce74f5db2312351a4e37c
+SIZE (Parser-MGC-0.19.tar.gz) = 51748
diff --git a/devel/p5-Parser-MGC/pkg-descr b/devel/p5-Parser-MGC/pkg-descr
new file mode 100644
index 000000000000..efdd7b49e6a8
--- /dev/null
+++ b/devel/p5-Parser-MGC/pkg-descr
@@ -0,0 +1,11 @@
+Parser::MGC class provides a low-level framework for building recursive-descent
+parsers that consume a given input string from left to right, returning a parse
+structure. It takes its name from the m//gc regexps used to implement the token
+parsing behaviour.
+
+It provides a number of token-parsing methods, which each extract a grammatical
+token from the string. It also provides wrapping methods that can be used to
+build up a possibly-recursive grammar structure, by applying a structure around
+other parts of parsing code.
+
+WWW: https://metacpan.org/release/Parser-MGC
diff --git a/devel/p5-Parser-MGC/pkg-plist b/devel/p5-Parser-MGC/pkg-plist
new file mode 100644
index 000000000000..877b8f00f1e9
--- /dev/null
+++ b/devel/p5-Parser-MGC/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Parser/MGC.pm
+%%SITE_PERL%%/Parser/MGC/Examples/EvaluateExpression.pm
+%%SITE_PERL%%/Parser/MGC/Tutorial.pod
+%%PERL5_MAN3%%/Parser::MGC.3.gz
+%%PERL5_MAN3%%/Parser::MGC::Examples::EvaluateExpression.3.gz
+%%PERL5_MAN3%%/Parser::MGC::Tutorial.3.gz