aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2024-01-31 08:20:15 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2024-01-31 08:22:30 +0000
commit926b73117918979bf5f6ca10356fd94db564513c (patch)
tree682e98af40371c771ec9204cb312ceeef667f798
parente22931d36aaa47e847b9519fc8be279249ca1a8b (diff)
downloadports-926b73117918979bf5f6ca10356fd94db564513c.tar.gz
ports-926b73117918979bf5f6ca10356fd94db564513c.zip
Mk/Uses/vala.mk: remove powerpc conditional since clang condition fixes other build failures on powerpc
-rw-r--r--Mk/Uses/vala.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/Uses/vala.mk b/Mk/Uses/vala.mk
index a43969807a8a..b15c15461e30 100644
--- a/Mk/Uses/vala.mk
+++ b/Mk/Uses/vala.mk
@@ -25,7 +25,7 @@ BUILD_DEPENDS+= ${_VALA_BINARY}:${_VALA_PORT}
# remove after https://gitlab.gnome.org/GNOME/vala/-/issues/1408 is fixed
.include "${USESDIR}/compiler.mk"
-. if ${ARCH} != powerpc && ${CHOSEN_COMPILER_TYPE} == "clang"
+. if ${CHOSEN_COMPILER_TYPE} == "clang"
CFLAGS+= -Wno-error=incompatible-function-pointer-types
. endif