aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavel Timofeev <timp87@gmail.com>2023-12-09 12:58:28 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-12-10 17:27:01 +0000
commit92795b2fe3d12632f463d2821ce67f46416f453e (patch)
tree1314e893defb3d8c8004a65f3d43dbdbb084394e
parent41afbdaae94c823ac828489818cc3125a472dda4 (diff)
downloadports-92795b2fe3d12632f463d2821ce67f46416f453e.tar.gz
ports-92795b2fe3d12632f463d2821ce67f46416f453e.zip
net/kafka: update to v3.6.1
ChangeLog: https://downloads.apache.org/kafka/3.6.1/RELEASE_NOTES.html Improvement * In Java-client, backoff should be skipped for retried producer-batch to a new leader * Upgrade ZooKeeper to 3.8.3 Bug * block-cache-capacity metrics worth twice as much as normal * Gradle build fails with missing commitId after git gc * Concurrency bug in RemoteIndexCache leads to IOException * RackId doesn't exist error while running WordCountDemo * Handle large keystores in SslEngineValidator * Duplicate Producer ID blocks during ZK migration * StateRestoreListener#onRestoreSuspended is never called because wrapper DelegatingStateRestoreListener doesn't implement onRestoreSuspended * Breaking change in 3.4.0 ByteBufferSerializer * Topics marked for deletion in ZK are incorrectly migrated to KRaft * Possible NPE is thrown in MirrorCheckpointTask * Fix CVE-2023-4586 in netty:handler * NPE in ChunkedByteStream * Zookeeper.jar | CVE-2023-44981 * Partition-Count is not getting updated Correctly in the Incremental Co-operative Rebalancing(ICR) Mode of Rebalancing * Disabling scheduled rebalance delay in Connect can lead to indefinitely unassigned connectors and tasks * LeaveGroupResponse v0-v2 should handle no members * ProduceRequest#partitionSizes() is not an atomic operation * ZK brokers incorrectly handle KRaft metadata snapshots * Malformed connect source offsets corrupt other partitions with DataException * Trying to access uncopied segments metadata on listOffsets * KRaft controller writes empty state to ZK after migration Task * Add 3.5.0 to broker/client and streams upgrade/compatibility tests * Rolling upgrade system tests are failing * Remote log segments should be considered once for retention breach * Add 3.4.0 streams upgrade/compatibility tests Test * Add tests for RemoteIndexCache * Flaky test ZkMigrationIntegrationTest.testMigrateTopicDeletions PR: 275611 Reported by: timp87@gmail.com MFH: 2023Q4 (security fix) Security: CVE-2023-4586 (cherry picked from commit 452f0014ea7e0a1495dbbd29ae30955ca7d7f1f0)
-rw-r--r--net/kafka/Makefile2
-rw-r--r--net/kafka/distinfo6
-rw-r--r--net/kafka/pkg-plist24
3 files changed, 16 insertions, 16 deletions
diff --git a/net/kafka/Makefile b/net/kafka/Makefile
index 5a557453dcef..ffdd00002fd3 100644
--- a/net/kafka/Makefile
+++ b/net/kafka/Makefile
@@ -1,5 +1,5 @@
PORTNAME= kafka
-DISTVERSION= 3.5.1
+DISTVERSION= 3.6.1
CATEGORIES= net java
MASTER_SITES= APACHE/${PORTNAME}/${PORTVERSION}/
DISTNAME= ${PORTNAME}_2.13-${PORTVERSION}
diff --git a/net/kafka/distinfo b/net/kafka/distinfo
index 5686c9625419..f1860df8bd93 100644
--- a/net/kafka/distinfo
+++ b/net/kafka/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1693073524
-SHA256 (kafka_2.13-3.5.1.tgz) = f7b74d544023f2c0ec52a179de59975cb64e34ea03650d829328b407b560e4da
-SIZE (kafka_2.13-3.5.1.tgz) = 106748875
+TIMESTAMP = 1701888581
+SHA256 (kafka_2.13-3.6.1.tgz) = e3db568c7f8fccc7f981ea7b0944268ae9310592c73ee0eb579ebfdbfcf2d3ca
+SIZE (kafka_2.13-3.6.1.tgz) = 113466638
diff --git a/net/kafka/pkg-plist b/net/kafka/pkg-plist
index a870f81e74df..24e0faab0905 100644
--- a/net/kafka/pkg-plist
+++ b/net/kafka/pkg-plist
@@ -113,15 +113,15 @@
%%DATADIR%%/libs/maven-artifact-3.8.8.jar
%%DATADIR%%/libs/metrics-core-2.2.0.jar
%%DATADIR%%/libs/metrics-core-4.1.12.1.jar
-%%DATADIR%%/libs/netty-buffer-4.1.94.Final.jar
-%%DATADIR%%/libs/netty-codec-4.1.94.Final.jar
-%%DATADIR%%/libs/netty-common-4.1.94.Final.jar
-%%DATADIR%%/libs/netty-handler-4.1.94.Final.jar
-%%DATADIR%%/libs/netty-resolver-4.1.94.Final.jar
-%%DATADIR%%/libs/netty-transport-4.1.94.Final.jar
-%%DATADIR%%/libs/netty-transport-classes-epoll-4.1.94.Final.jar
-%%DATADIR%%/libs/netty-transport-native-epoll-4.1.94.Final.jar
-%%DATADIR%%/libs/netty-transport-native-unix-common-4.1.94.Final.jar
+%%DATADIR%%/libs/netty-buffer-4.1.100.Final.jar
+%%DATADIR%%/libs/netty-codec-4.1.100.Final.jar
+%%DATADIR%%/libs/netty-common-4.1.100.Final.jar
+%%DATADIR%%/libs/netty-handler-4.1.100.Final.jar
+%%DATADIR%%/libs/netty-resolver-4.1.100.Final.jar
+%%DATADIR%%/libs/netty-transport-4.1.100.Final.jar
+%%DATADIR%%/libs/netty-transport-classes-epoll-4.1.100.Final.jar
+%%DATADIR%%/libs/netty-transport-native-epoll-4.1.100.Final.jar
+%%DATADIR%%/libs/netty-transport-native-unix-common-4.1.100.Final.jar
%%DATADIR%%/libs/osgi-resource-locator-1.0.3.jar
%%DATADIR%%/libs/paranamer-2.8.jar
%%DATADIR%%/libs/plexus-utils-3.3.1.jar
@@ -135,11 +135,11 @@
%%DATADIR%%/libs/scala-reflect-2.13.10.jar
%%DATADIR%%/libs/slf4j-api-1.7.36.jar
%%DATADIR%%/libs/slf4j-reload4j-1.7.36.jar
-%%DATADIR%%/libs/snappy-java-1.1.10.1.jar
+%%DATADIR%%/libs/snappy-java-1.1.10.5.jar
%%DATADIR%%/libs/swagger-annotations-2.2.8.jar
%%DATADIR%%/libs/trogdor-%%PORTVERSION%%.jar
-%%DATADIR%%/libs/zookeeper-3.6.4.jar
-%%DATADIR%%/libs/zookeeper-jute-3.6.4.jar
+%%DATADIR%%/libs/zookeeper-3.8.3.jar
+%%DATADIR%%/libs/zookeeper-jute-3.8.3.jar
%%DATADIR%%/libs/zstd-jni-1.5.5-1.jar
%%PORTDOCS%%%%DOCSDIR%%/site-docs/api.html
%%PORTDOCS%%%%DOCSDIR%%/site-docs/configuration.html