aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeal Nelson <ports@nicandneal.net>2023-04-19 15:41:26 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-04-19 16:37:51 +0000
commit931d277e9f7db6872299f8b948b7c403d194c9c1 (patch)
treee4541d69f395afe92939bcd13c1460a5f0afeaaa
parent947a366e110c02f686746b8dd3468e1ff2d8e2a9 (diff)
downloadports-931d277e9f7db6872299f8b948b7c403d194c9c1.tar.gz
ports-931d277e9f7db6872299f8b948b7c403d194c9c1.zip
lang/nim: Fix invalid path to documentation in compiler source code
Use /usr/local/share/doc/nim instead of ../doc. PR: 270858 Reported by: thindil@laeran.pl.eu.org
-rw-r--r--lang/nim/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/lang/nim/Makefile b/lang/nim/Makefile
index 311bebdae76d..b283c05d82dd 100644
--- a/lang/nim/Makefile
+++ b/lang/nim/Makefile
@@ -1,5 +1,6 @@
PORTNAME= nim
DISTVERSION= 1.6.12
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= https://nim-lang.org/download/
@@ -81,6 +82,7 @@ do-install:
# Install nim lib files
${MKDIR} ${STAGEDIR}${PREFIX}/lib/${PORTNAME}
(cd ${WRKSRC}/lib && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/lib/${PORTNAME} "! -name libnimrtl.so")
+ ${REINPLACE_CMD} 's|\.\.\/doc|/usr/local/share/doc/nim|g' ${WRKSRC}/compiler/commands.nim
${MKDIR} ${STAGEDIR}${PREFIX}/lib/${PORTNAME}/compiler
(cd ${WRKSRC}/compiler && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/lib/${PORTNAME}/compiler "! -name nim ! -name nim1")
# Configuration files