aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2021-10-05 09:27:28 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2021-10-05 09:27:28 +0000
commit9349b94d98d3427e521117d0dcb00f5a0b701864 (patch)
tree8d0bb5cbdd1f28d742e6c5f226039949c2f58fc3
parentc41707e2c2079a4e6d648ce07860f14956e65684 (diff)
downloadports-9349b94d98d3427e521117d0dcb00f5a0b701864.tar.gz
ports-9349b94d98d3427e521117d0dcb00f5a0b701864.zip
games/py-2048-py: Add a new port
A console version of the 2048 game written in Python.
-rw-r--r--games/Makefile1
-rw-r--r--games/py-2048-py/Makefile21
-rw-r--r--games/py-2048-py/distinfo3
-rw-r--r--games/py-2048-py/pkg-descr4
4 files changed, 29 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index d50306610f9d..d99d98d45dca 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -774,6 +774,7 @@
SUBDIR += puckman
SUBDIR += pushover
SUBDIR += pvpgn
+ SUBDIR += py-2048-py
SUBDIR += py-cbeams
SUBDIR += py-discord.py
SUBDIR += py-fife
diff --git a/games/py-2048-py/Makefile b/games/py-2048-py/Makefile
new file mode 100644
index 000000000000..9e484e66647e
--- /dev/null
+++ b/games/py-2048-py/Makefile
@@ -0,0 +1,21 @@
+# Created by: Mateusz Piotrowski <0mp@FreeBSD.org>
+
+PORTNAME= 2048-py
+DISTVERSION= 0.1.6
+CATEGORIES= games python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+MASTER_SITES= CHEESESHOP
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Console version of the 2048 game written in Python
+
+LICENSE= GPLv3+
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}termcolor>=1.1.0:devel/py-termcolor@${PY_FLAVOR}
+
+USES= python:3.8+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/games/py-2048-py/distinfo b/games/py-2048-py/distinfo
new file mode 100644
index 000000000000..c5b3148e7051
--- /dev/null
+++ b/games/py-2048-py/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1633425852
+SHA256 (2048-py-0.1.6.tar.gz) = c99d11fd71ab9439e18b0455c9d4432fa5ccd783b1e47564c195a4ccdee575ff
+SIZE (2048-py-0.1.6.tar.gz) = 4995
diff --git a/games/py-2048-py/pkg-descr b/games/py-2048-py/pkg-descr
new file mode 100644
index 000000000000..376b53a520ba
--- /dev/null
+++ b/games/py-2048-py/pkg-descr
@@ -0,0 +1,4 @@
+The console version of the 2048 game implemented in Python by the Ladue High
+School Computer Science Club.
+
+WWW: https://github.com/LadueCS/2048